Microsoft Excel

Herbers Excel/VBA-Archiv

Filter und VBA | Herbers Excel-Forum


Betrifft: Filter und VBA von: Black
Geschrieben am: 13.08.2012 13:40:31

hallo werte VBA Profis

Ich habe eine Frage, gibt es eine Möglichkeit per VBA den Textfilter zu setzten der sich auf eine Zelle bezieht? zB. =Tabelle1!A3 ?
Wenn ja, wie ist das machbar?

Eine weitere Filter-frage, kann ich einen Filter setzten der mir immer den Monat-x anzeigt
also mit dem heutigen Datum arbeitet zB.
-2 =Juni
-1=july
Wie wäre das zu realisieren?

  

Betrifft: AW: Filter und VBA von: Josef Ehrensberger
Geschrieben am: 13.08.2012 13:57:32


Hallo Black,

eine Beispieldatei mit Beschreibung wäre von Vorteil.




« Gruß Sepp »



  

Betrifft: AW: Filter und VBA von: Black
Geschrieben am: 13.08.2012 15:11:14

Alles was ich suche ist den VBA Filter Befehl für die beiden Kritterien. Ich weis nicht was da eine Beispiels Datein bringen soll. Aber ja, ev gibt es ja noch andere Möglichkeiten.

Ich habe mal versucht mein Vorhaben zu Beschreiben und dies in eine Datei geschrieben.
Gruss


https://www.herber.de/bbs/user/81395.xlsx


  

Betrifft: AW: Filter und VBA von: Josef Ehrensberger
Geschrieben am: 13.08.2012 15:24:32


Hallo Black,

und ich verstehe nicht, was du wie Filtern willst und wie es ausgegeben werden soll.

Vielleicht ohne VBA.

Tabelle2

 ABCDE
1Jahr:2012   
2Sorte:l   
3     
4MonatGesamtoffengeschlossen 
5Jan 12000 
6Feb 12000 
7Mrz 12101 
8Apr 12312 
9Mai 12000 
10Jun 12000 
11Jul 12000 
12Aug 12000 
13Sep 12000 
14Okt 12000 
15Nov 12000 
16Dez 12000 
17     
18     

Formeln der Tabelle
ZelleFormel
A5=DATUM($B$1;ZEILE(A1); 1)
B5=SUMMENPRODUKT((JAHR(Tabelle1!$A$2:$A$1000)=$B$1)*(MONAT(Tabelle1!$A$2:$A$1000)=ZEILE(A1))*(Tabelle1!$B$2:$B$1000=$B$2))
C5=SUMMENPRODUKT((JAHR(Tabelle1!$A$2:$A$1000)=$B$1)*(MONAT(Tabelle1!$A$2:$A$1000)=ZEILE(B1))*(Tabelle1!$B$2:$B$1000=$B$2)*(Tabelle1!$C$2:$C$1000=C$4))
D5=SUMMENPRODUKT((JAHR(Tabelle1!$A$2:$A$1000)=$B$1)*(MONAT(Tabelle1!$A$2:$A$1000)=ZEILE(C1))*(Tabelle1!$B$2:$B$1000=$B$2)*(Tabelle1!$C$2:$C$1000=D$4))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



« Gruß Sepp »



  

Betrifft: AW: Filter und VBA von: Black
Geschrieben am: 13.08.2012 15:59:09

hmm VBA weil sich die Daten dauernd ändern, diese kommen von externen Abfrage.

Und das Datum soll immer so sein das der heutige Monat genommen wird und dann -12

also Jahr übergreifend.


  

Betrifft: AW: Filter und VBA von: Josef Ehrensberger
Geschrieben am: 13.08.2012 16:17:56


Hallo Alex,

Änderungen in Tabelle2 B1 stoßen den Code an.


https://www.herber.de/bbs/user/81398.xlsm




« Gruß Sepp »



  

Betrifft: AW: Filter und VBA von: Black
Geschrieben am: 13.08.2012 16:04:41

hmm VBA weil sich die Daten dauernd ändern, diese kommen von externen Abfrage.

Und das Datum soll immer so sein das der heutige Monat genommen wird und dann -12

also Jahr übergreifend.


Beiträge aus den Excel-Beispielen zum Thema "Filter und VBA"