Microsoft Excel

Herbers Excel/VBA-Archiv

Nettoarbeitstage, Matrixfomel | Herbers Excel-Forum


Betrifft: Nettoarbeitstage, Matrixfomel von: Enrico
Geschrieben am: 21.08.2012 21:10:27

Hallo,

ich möchte die Nettoarbeitstage mehrerer Zeiträume zusammen rechnen, Beispiel:

A1 = 01.01.12
B1 = 10.01.12
C1 = 01.02.12
D1 = 10.02.12 usw.

Nun möchte ich nicht ständige =nettoarbeitstage(A1;B1)+nettoarbeitstage(C1;D1) ... schreiben, sondern möglichst A1, C1 ... und B1, D1 ... als Anfangs- und Enddaten zusammenfassen.

Geht das mit einer Matrixformel? Wo setze ich da die geschweiften Klammern?

Danke & Gruß
Enrico

  

Betrifft: AW: Nettoarbeitstage, Matrixfomel von: Hajo_Zi
Geschrieben am: 22.08.2012 05:56:03

Hallo Enrico,

Feiertage intressieren nicht. Mache es ohne Matrix.

Tabelle1

 AB
101.01.2012So
210.01.2012Di
301.02.2012Mi
410.02.2012Fr
53 

verwendete Formeln
Zelle Formel Bereich
B1 =A1 
B2 =A2 
B3 =A3 
B4 =A4 
A5 =SUMMENPRODUKT((WOCHENTAG(A1:A4;2)<=5)*1) 

Tabellendarstellung in Foren Version 5.49



GrußformelHomepage