Microsoft Excel

Herbers Excel/VBA-Archiv

Stunden errechnen im gewissen Zeitraum

Betrifft: Stunden errechnen im gewissen Zeitraum von: Pit
Geschrieben am: 05.11.2012 18:24:59

Hallo Excelfreunde,

ich bräuchte mal wieder Hilfe eines neuen Themas....

Ich habe mir in Excel einen Jahreskalender für 2013 erstellt.

Das sieht folgendermaßen aus.....

A1=01.01. A2=02.01. A3=03.01.....usw. unter diesen Zellen habe ich frei gelassen, für die Anzahl der Stunden. Dann geht das ganze Spiel mit Februar in der dritten Zeile von vorne los.

Nun möchte ich, dass ich durch eingabe eines Zeitraums die Stunden errechnet werden. Beispiel: vom 03.04. bis 19.08.

Ich bedanke mich mal im Voraus und hoffe, es kann mir jemand helfen....

LG Chris

  

Betrifft: AW: Stunden errechnen im gewissen Zeitraum von: robert
Geschrieben am: 05.11.2012 19:18:31

Hi,

meinst Du sowas?

Gruß
robert
Tabelle1

 ABC
115. Mrz17. Mrz48

verwendete Formeln
Zelle Formel Bereich
C1 =(B1-A1)*24 

Zahlenformate
Zelle Format Wert
A1 TT. MMM40983
B1 TT. MMM40985
Zellen mit Format Standard werden nicht dargestellt

Tabellendarstellung in Foren Version 5.47




  

Betrifft: AW: Stunden errechnen im gewissen Zeitraum von: Pit
Geschrieben am: 05.11.2012 20:10:01

Nein Robert, sowas hatte ich nicht gesucht....sorry....

Ich habe in der ersten Zeile in jeder Zelle das Datum stehen. von A1 ab mit dem 01.01. bis zur Zelle AF1 31.01.
Unter jedem Datum steht dann eine Anzahl der Stunden. Beispiel jeder Tag waren es 2 Stunden. Ab der dritten Zeile geht es weiter mit dem Februar, ab der 5. Zeile mit dem März usw.

Nun bräuchte ich was, indem ich sagen kann, errechne mir die stunden vom 03.04. bis 19.08.

LG Chris


  

Betrifft: Summe über Tage im Kalender von: Erich G.
Geschrieben am: 05.11.2012 21:09:40

Hi Chris Pit,
meinst du so etwas? (Die je drei Teilsummen musst du noch addieren...)

 ABCDEFABACADAE
101.01.1202.01.1203.01.1204.01.1205.01.1206.01.1228.01.1229.01.1230.01.1231.01.12
212345628293031
301.02.1202.02.1203.02.1204.02.1205.02.1206.02.1228.02.1229.02.12  
43233343536375960  
501.03.1202.03.1203.03.1204.03.1205.03.1206.03.1228.03.1229.03.1230.03.1231.01.12
661626364656688899091
7          
8          
9vonbisSummeplusplus     
1008.01.1202.03.121334468123     
1128.02.1205.03.120119315     
1228.02.1228.02.120590     

Formeln der Tabelle
ZelleFormel
C10{=SUMME(WENN((REST(ZEILE($A$1:$A$5); 2)=1)*(MONAT($A$1:$A$5)>MONAT(A10)) *(MONAT($A$1:$A$5)<MONAT(B10)); $A$2:$AE$6))}
D10=SUMME(INDEX($A$1:$AE$6;2*MONAT(A10); TAG(A10)) :INDEX($A$1:$AE$6;2*MONAT(A10); WENN(MONAT(A10)=MONAT(B10); TAG(B10); 31)))
E10=SUMME(INDEX($A$1:$AE$6;2*MONAT(B10); WENN(MONAT(A10)=MONAT(B10); TAG(A10); 1)) :INDEX($A$1:$AE$6;2*MONAT(B10); TAG(B10))) -WENN(MONAT(A10)=MONAT(B10); INDEX($A$1:$AE$6;2*MONAT(B10); TAG(B10)); 0)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Summe über Tage im Kalender von: Pit
Geschrieben am: 05.11.2012 22:22:11

Hallo Erich,

vielen lieben Dank...das war genau das Richtige, was ich gesucht habe...echt Super....Danke für Deine Zeit...

Gruß Chris


 

Beiträge aus den Excel-Beispielen zum Thema "Stunden errechnen im gewissen Zeitraum"