Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema CheckBox
BildScreenshot zu CheckBox CheckBox-Seite mit Beispielarbeitsmappe aufrufen

Datenüberprüfung deaktivieren durch CheckBox

Betrifft: Datenüberprüfung deaktivieren durch CheckBox von: reiner
Geschrieben am: 23.11.2012 12:01:16

https://www.herber.de/bbs/user/82742.xls

hallo Leute,

die Datenüberprüfung an "A1" bezieht sich auf Werte im Bereich "E1-E5"
Nun will durch Setzen des Häkchens in der CheckBox in "C6" vorübergehend die Datenüberprüfung in "A1" deaktivieren bzw. aktivieren durch Entfernen des Häkchens.

Ist das möglich ohne VBA??

mfg
reiner

  

Betrifft: AW: Datenüberprüfung deaktivieren durch CheckBox von: Christian
Geschrieben am: 23.11.2012 12:31:10

Hallo Reiner,

Zellverknüpfung des Kontrollkästch mit C1 und dann

 ABCDE
110 WAHR 10
2    20
3    30
4    40
5    50
6     

Datengültigkeit der Tabelle
ZelleZulassenDatenEingabe 1Eingabe 2
A1Liste =WENN($C$1;$E$1:$E$5;"") 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


  

Betrifft: AW: Datenüberprüfung deaktivieren durch CheckBox von: reiner
Geschrieben am: 23.11.2012 12:51:11

hallo Christian,

leider funktioniert dein Vorschlag bei mir nicht

wenn ich die nachfolgende Formel in das Eingabefeld der Datenüberprüfung unter Quelle:

=WENN($C$1;$E$1:$E$5;"")

eintrage, erhalte ich die Fehlermeldung: "Die Quelle muss eine getrennte Liste oder ein Bezug auf eine einzelne Zeile oder Spalte sein"
fehlt nicht außerdem eine Überprüfung der Bedingung, z.B.
=WENN($C$1="Wahr";$E$1:$E$5;"")
?

Funktioniert die Datenüberprüfung bei dir?
Was mache ich falsch?

mfg
reiner


  

Betrifft: AW: Datenüberprüfung deaktivieren durch CheckBox von: Christian
Geschrieben am: 23.11.2012 12:56:48

Hallo Reiner,

kann ich nicht nachvollziehen!

https://www.herber.de/bbs/user/82744.xls


MfG Christian


  

Betrifft: AW: Datenüberprüfung deaktivieren durch CheckBox von: reiner
Geschrieben am: 23.11.2012 14:01:49

hallo Christian,

......ich auch nicht, danke dir

mfg
reiner


  

Betrifft: Du musst die CheckBox vorher 1 x aktivieren von: Matthias L
Geschrieben am: 23.11.2012 14:10:19

Hallo Reiner

.. nun kannst Du die Gültigkeit setzen und es kommt auch keine Fehlermeldung mehr.

Gruß Matthias


  

Betrifft: AW: Du musst die CheckBox vorher 1 x aktivieren von: reiner
Geschrieben am: 23.11.2012 14:58:47

hallo Matthias,

so ist es

mfg
reiner


 

Beiträge aus den Excel-Beispielen zum Thema "Datenüberprüfung deaktivieren durch CheckBox"