Vergleich



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Vergleich
von: Rolf St
Geschrieben am: 21.06.2002 - 16:06:29

Hallo Excel Experten!
Ich habe folgendes Problem:
Verschiedene Werte aus Tabelle2 Spalte D sollen in Tabelle1 Spalte A gesucht und wenn Suchwerte gleich sind, sollen die Werte aus den Spalten B:I der Fundzeile in Tabelle 2, (rechts neben dem Wert der gesucht wurde) übernommen werden.

- die Werte aus Tabelle2 Spalte D werden ständig geändert und müssen sich automatisch aktualisieren
- in Tabelle 2 Spalte D können bis zu 1000 Werte untereinander stehen
- bei beiden Tabellenblättern gibt es eine Überschrift

Zur Zeit habe ich dieses Problem mit SVERWEIS gelöst und habe nun das Problem das die Datei nicht mehr auf eine Diskette passt.
Beispiel : =WENN(C607>0;(SVERWEIS(C607;Tabelle1!$A$2:$I$800;2;FALSCH));" ")

Vielen Dank für eure Hilfe!

Tschüß
Rolf



nach oben   nach unten

Re: Vergleich
von: Hajo_Zi
Geschrieben am: 21.06.2002 - 16:56:01

Hallo Rolf

hast Du VBA Code in der Datei, dann lade Dir mal VBClear runter, das verringert schon die Dateigröße.

Ein Sache die noch die Datei groß macht ist, wenn jede Zele einzeln formatiert wird es solten schon (ich glaube zusammenhängede) Bereiche sein. Diesen Fall habe ich noch nicht getestet, ich habe nur davon gelesen.

Gruß Hajo


nach oben   nach unten

Re: Vergleich
von: Rolf St
Geschrieben am: 21.06.2002 - 17:27:07

Hallo Hajo,
bei VBClaer kommt bei mir eine Fehlermeldung.

Laufzeitfehler 1004

Der programmatische Zugriff auf das Visuell Basic Projekt ist nicht sicher!

Ich hätte das Makro auch gerne, damit mir nicht ständig Formeln gelöscht werden.

Tschüß
Rolf


nach oben   nach unten

Re: Vergleich
von: Hajo_Zi
Geschrieben am: 21.06.2002 - 17:34:55

Hallo Rolf

bei XP muß für VB Clear unter Extra, Makro Sicherheit, Register Vertrauenwürdige Quellen, Zugriff auf Visual Basic ... angewählt sein. Das könnte bei 2000 auch schon so sein.


Das Makro wird dabei nicht entfernt. Vba merkt sich nur alle Codezeilen die Du mal eingegeben hast und die werden entfernt. Du muß nur dran denken die Speicherung an einen anderem ort ablegen, falls es zu Problemen kommt. Daas VBA Projekt darf nicht geschützt sein.

Gruß Hajo


nach oben   nach unten

Re: Vergleich
von: Rolf St
Geschrieben am: 21.06.2002 - 18:30:32

Hallo Hajo,
ich habe jetzt Dank deiner Tips VBClear ausgeführt.

Vor VBClear Dateigröße : 2014208
Nach VBCLear Dateigröße : 2001920

Wenn ich die Formeln durch ein Makro ersetzten könnte, komme ich auf Dateigröße : 1270000 Dann würde die Datei wieder auf eine Diskette passen.

Tschüß
Rolf


nach oben   nach unten

Re: Vergleich
von: Daniel R.
Geschrieben am: 21.06.2002 - 19:54:49

Hallo Rolf
In VBA würde Deine Formel folgendermassen aussehen:
Sub test()
ActiveCell.FormulaR1C1 = _
"=IF(R[606]C[2]>0,(VLOOKUP(R[606]C[2],Tabelle1!R2C1:R800C9,2,FALSE)),"" "")"
end sub

Gruss Daniel R.

nach oben   nach unten

Re: Vergleich
von: Rolf St
Geschrieben am: 21.06.2002 - 22:34:19

Hallo Hajo,
ich habe ein tolles Makro gefunden und weiter oben einen Betrag verfaßt mit ein paar Fragen. Vielleicht kannst du mir helfen?

Vielen Dank!

Tschüß
Rolf


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Vergleich"