Werte von Mittelwertbildung ausschließen



Excel-Version: 5.0/7.0
nach unten

Betrifft: Werte von Mittelwertbildung ausschließen
von: Hermann
Geschrieben am: 23.06.2002 - 03:13:15

Hallo,
ich habe eine Spalte mit den Werten(A1..A100) und dem Mittelwert(A1:A100).Eine weitere Spalte (B1..B100) wird generiert indem alle Werte von Spalte A mit dem Mittelwert dividiert werden.
Nun sollen sollen folgende Werte von der Mittelwertbildung
ausgeschlossen werden:
A1/MW(A1:A100), A2/MW(A1:A100).......A100/MW(A1:A100) > 2.
Wie kann ich das bewerkstelligen ?

Grüße und vielen Dank
Hermann




nach oben   nach unten

Re: Werte von Mittelwertbildung ausschließen
von: Berai
Geschrieben am: 23.06.2002 - 06:41:26

Hallo Herman,

mit dieser Arrayformel werden für die Bildung des Mittelwertes nur Einzelwerte >0 <=2 berücksichtigt.

{=MITTELWERT(WENN((A1:A100>0)*(A1:A100<=2);A1:A100))}

geschweifte Klammern werden durch STRG+SHIFT+ENTER erzeugt.
Deine Formel müsste demzufolge

=A1/MITTELWERT(WENN((A1:A100>0)*(A1:A100<=2);A1:A100))

lauten.

Gruß
Rainer

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Aufteilen"