Microsoft Excel

Herbers Excel/VBA-Archiv

zusammenrechnen

Betrifft: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 11:40:10

Guten morgen an alle hier im Forum

Ich habe da ein Problem.
In Tabellenblatt 1 und 2 werden "wild" durcheinander Produkte eingegeben.Diese möchte ich in Tabellenblatt 3 zusammengezählt haben.
Natürlich die jeweiligen Produkte einzeln.
Ich habe mal eine Beispieldatei mit hochgeladen.
ich hoffe, ich konnte mein Anliegen einigermaßen beschreiben und würde mich über eine Antwort freuen.

https://www.herber.de/bbs/user/84037.xls

Andreas

  

Betrifft: AW: zusammenrechnen von: Hajo_Zi
Geschrieben am: 24.02.2013 11:48:14

Hallo Andreas,

Gesamt

 C
610
710
89
913
104
1132
120

verwendete Formeln
Zelle Formel Bereich
C6 =SUMMEWENN('Kunde 1'!A6:A12;A6;'Kunde 1'!C6:C12)+SUMMEWENN('Kunde 2'!A6:A12;A6;'Kunde 2'!C6:C12) 
C7 =SUMMEWENN('Kunde 1'!A7:A13;A7;'Kunde 1'!C7:C13)+SUMMEWENN('Kunde 2'!A7:A13;A7;'Kunde 2'!C7:C13) 
C8 =SUMMEWENN('Kunde 1'!A8:A14;A8;'Kunde 1'!C8:C14)+SUMMEWENN('Kunde 2'!A8:A14;A8;'Kunde 2'!C8:C14) 
C9 =SUMMEWENN('Kunde 1'!A9:A15;A9;'Kunde 1'!C9:C15)+SUMMEWENN('Kunde 2'!A9:A15;A9;'Kunde 2'!C9:C15) 
C10 =SUMMEWENN('Kunde 1'!A10:A16;A10;'Kunde 1'!C10:C16)+SUMMEWENN('Kunde 2'!A10:A16;A10;'Kunde 2'!C10:C16) 
C11 =SUMMEWENN('Kunde 1'!A11:A17;A11;'Kunde 1'!C11:C17)+SUMMEWENN('Kunde 2'!A11:A17;A11;'Kunde 2'!C11:C17) 
C12 =SUMMEWENN('Kunde 1'!A12:A18;A12;'Kunde 1'!C12:C18)+SUMMEWENN('Kunde 2'!A12:A18;A12;'Kunde 2'!C12:C18) 

Tabellendarstellung in Foren Version 5.51



GrußformelHomepage


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 11:56:32

moin Hajo

ersteinmal danke für die schnelle Abntwort.
Leider bleibt bei mir die Formel in der Zelle stehen und ein Ergebnis wird nicht angezeigt.
Muss ich noch irgendetwas formatieren.

Andreas


  

Betrifft: AW: zusammenrechnen von: Hajo_Zi
Geschrieben am: 24.02.2013 11:59:50

Hallo Andreas,

Ich habe in Deiner Datei nur die Formel eingetragen in c6, ein Fehler noch es müssen absolute Bezüge bei dem Bereich sein und dann runter ziehen.

Gruß Hajo


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 12:07:05

Hallo

ich bekomme selbst in Zelle C6 kein Ergebnis angezeigt, sondern nur die Formel.

Diese habe ich so abgeändert.
richtig so ??

=SUMMEWENN('Kunde 1'!$A$6:$A$12;A6;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A6;'Kunde 2'!$C$6:$C$12)

Andreas


  

Betrifft: AW: zusammenrechnen von: Hajo_Zi
Geschrieben am: 24.02.2013 12:09:51

Hallo Andreas,

dann lade die Datei in Deinem ersten Beitrag runter, da klappt es.

Gruß Hajo


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 12:25:13

Hi

wenn ich die Datei aus meiner Anfrage wieder runterlade, bekomme ich nur "meine" Ausgangsdatei wieder.
Dort steht keine Formel drin.
Und wenn ich die Formel dort einfüge, dann steht halt auch nur die Formel in der Zelle.

Andreas
Eventuell mache ich etwas mit dem runter laden dfalsch ??


  

Betrifft: AW: zusammenrechnen von: Hajo_Zi
Geschrieben am: 24.02.2013 12:28:52

Hallo Andreas,

ich habe die Datei nochmal aus dem Internet geöffnet und Formel eingetragen und bei mir stehen Ergebnisse.

Gesamt

 C
610
710
830
920
1030
1140
1220

verwendete Formeln
Zelle Formel Bereich
C6 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A6;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A6;'Kunde 2'!$C$6:$C$12) 
C7 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A7;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A7;'Kunde 2'!$C$6:$C$12) 
C8 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A8;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A8;'Kunde 2'!$C$6:$C$12) 
C9 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A9;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A9;'Kunde 2'!$C$6:$C$12) 
C10 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A10;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A10;'Kunde 2'!$C$6:$C$12) 
C11 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A11;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A11;'Kunde 2'!$C$6:$C$12) 
C12 =SUMMEWENN('Kunde 1'!$A$6:$A$12;A12;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A12;'Kunde 2'!$C$6:$C$12) 

Tabellendarstellung in Foren Version 5.51



Gruß Hajo


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 12:37:58

hi

ich habe die Datei nochmal hochgeladen.

Könntest Du da nochnal ein Blick drauf werfen.
Danke.

Andreas
https://www.herber.de/bbs/user/84039.xls


  

Betrifft: AW: zusammenrechnen von: Matze Matthias
Geschrieben am: 24.02.2013 12:40:31

du hast ein leerzeichen vor dem =


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 12:52:04

Hi Matze

....ich danke dir für den Hinweis.

jetzt ist der Tag gerettet.

Andreas


  

Betrifft: AW: zusammenrechnen von: Hajo_Zi
Geschrieben am: 24.02.2013 12:40:59

Hallo Andreas,

Du hast nicht das Eingetragen was ich vorgeschlagen habe.
mein Vorschlag "=SUMMEWENN('Kunde 1'!$A$6:$A$12;A6;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A6;'Kunde 2'!$C$6:$C$12)"
Dein Eintrag " =SUMMEWENN('Kunde 1'!$A$6:$A$12;A6;'Kunde 1'!$C$6:$C$12)+SUMMEWENN('Kunde 2'!$A$6:$A$12;A6;'Kunde 2'!$C$6:$C$12)"

Gruß Hajo


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 12:50:35

Hi Hajo

ich sehe keine Unterschied zwischen den Formeln.
ich hatte beim ersten mal Deine kopiert und dann eingefügt.
ABER
jetzt funktioniert diese.
Danke hierfür.

Könntest du mir netterweise noch sagen wo ich den Fehler eingebaut habe - nur zum Verständnis.

Andreas


  

Betrifft: AW: zusammenrechnen von: Hajo_Zi
Geschrieben am: 24.02.2013 12:52:46

Hallo Andreas,

genau vergleich, bei Dir steht vor = eine Leerstelle.

Gruß Hajo


  

Betrifft: AW: zusammenrechnen von: Andreas
Geschrieben am: 24.02.2013 12:56:34

Hi Hajo

sieht man so schlecht.
Ich danke dir für deine Mühen. Matze hatte mich auch schon drauf aufmerksam gemacht.
da kann der Tag ja nur besser werden.
Einen schönen Sonntag wünsche ich dir noch.

Andreas