Microsoft Excel

Herbers Excel/VBA-Archiv

lfd. Nummerierung ändern

Betrifft: lfd. Nummerierung ändern von: Dietmar
Geschrieben am: 25.07.2014 13:39:26

Hallo an alle,
folgendes Problem habe ich :
In Spalte A ( sagen wir mal ab Zelle A13 ) beginne ich mit der Nummerierung von 1 bis
z.b. 40. Wenn aber in z.B. Zelle B21 eine Fettmarkierung ist, sollte die Zelle A21 in
der Nummerierung ausgeklammert werden, dafür sollte dann ein F in A21 stehen.
Die Nummerierung in A22 sollte dann mit der folgenden Zahl nach A20 fortfahren.
Hoffentlich habe ich mich deutlich ausgedrückt.
Hoffentlich so dass mir geholfen werden kann. Makro oder Formel - ich weiß es nicht.
Vielen Dank
Dietmar

  

Betrifft: AW: lfd. Nummerierung ändern von: Christian
Geschrieben am: 25.07.2014 14:31:12

Hallo Dietmar,

ein Ansatz, wobei eine nachträgliche Formatierung auf "Fett" keine Änderung bewirkt, eine Änderung des Format per "Format übertragen" (mit dem Pinsel) jedoch schon:

 AB
131Test1
142Test2
15FTest3
163Test4
174Test5
18FTest6
195Test7
206Test8
217Test9
228Test10
23FTest11
249Test12
25FTest13
2610Test14
2711Test15
28FTest16
2912Test17
3013Test18
31FTest19
3214Test20
3315Test21

Formeln der Tabelle
ZelleFormel
A13=WENN(Fett;"F";MAX($A$12:A12)+1)
Namen in Formeln
ZelleNameBezieht sich auf
A13Fett=ZELLE.ZUORDNEN(20; Tabelle1!$B13)
Namen verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Christian


  

Betrifft: AW: lfd. Nummerierung ändern von: Dietmar
Geschrieben am: 26.07.2014 12:00:11

Hallo Christian,

Problem gelöst, vielen lieben Dank

Gruß
Dietmar


  

Betrifft: AW: lfd. Nummerierung ändern von: fcs
Geschrieben am: 25.07.2014 14:36:23

Hallo Dietmar,

da das Format Schrift "Fett" einer Zelle nicht direkt per Formel-Funktion abgefragt werden kann, hier eine gemischte Lösung:

Makro-Funktion, die du in einem allgemeinen Modul der Datei einfügen musst.

Public Function fncFett(Zelle As Range, varDummy) as Boolean
  'Zelle ist gleich auf Schrift "Fett" zu prüfende Zelle
  'varDummy sollte eine Funktion sein, die automatisch neu berechnet wird, wenn _
      ein Blatt berechnet wird. Sorgt dafür, dass Formel neu berechnet wird, wenn _
      andere Berechnungen gemacht werden
  'Formelbeispiel: =WENN(fncFett(B13; JETZT());"F";MAX($A$12:A12))
  fncFett = Zelle.Font.Bold
End Function
Formel in A13:
=WENN( fncFett(B13;JETZT());"F";MAX($A$12:A12)+1)

Diese Formel dann nach unten kopieren

Gruß
Franz


  

Betrifft: AW: lfd. Nummerierung ändern von: Dietmar
Geschrieben am: 26.07.2014 12:01:02

Hallo Franz,

Problem gelöst, vielen lieben Dank

Gruß
Dietmar


  

Betrifft: AW: lfd. Nummerierung ändern von: Martin
Geschrieben am: 25.07.2014 14:55:29

Hallo Dietmar,

hier noch eine VBA-Lösung ohne spezielle Formel, die du in das Modul der betreffenden Tabelle kopieren musst:

Option Explicit

Dim rngPos As Range

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    If Not rngPos Is Nothing Then
        If Not Application.Intersect(rngPos, ActiveSheet.UsedRange) Is Nothing Then
            If Cells(rngPos.Row, 2).Font.Bold = True Then
                Cells(rngPos.Row, 1).NumberFormat = """(""General"")"""
            Else
                Cells(rngPos.Row, 1).NumberFormat = "General"
            End If
        End If
    End If
    Set rngPos = ActiveCell
End Sub
Viele Grüße

Martin


  

Betrifft: AW: lfd. Nummerierung ändern von: Dietmar
Geschrieben am: 26.07.2014 12:01:37

Hallo Martin,

Problem gelöst, vielen lieben Dank

Gruß
Dietmar


 

Beiträge aus den Excel-Beispielen zum Thema "lfd. Nummerierung ändern"