Microsoft Excel

Herbers Excel/VBA-Archiv

Zellbezug ändert sich beim ausschneiden

Betrifft: Zellbezug ändert sich beim ausschneiden von: Frank Schellbach
Geschrieben am: 28.07.2014 16:35:09

Hallo Leute,

Bin neu hier und ein Rookie in Sachen excel, denke aber ,daß mir hier bestimmt jemand helfen kann.
Habe folgendes Problem:
Habe eine Arbeitsmappe mit 3 Bättern.(in Arbeit;fertig gebrannt;Berechnungen)
Die Berechnungen haben ihre Zellbezüge auf "in Arbeit"
Aufträge mit ihren Positionen werden auf "in Arbeit eingetragen
Nach Fertigstellung werden die Aufträge ganzzeilig ausgeschnitten und per Makro nach
"fertig gebrannt" verschoben.
Wenn jetzt der Bezug vorher K3:K1400 lautete und ich 10 Zeilen ausschneide, verkleinert
sich auch der Bezug K3:K1990.Das möchte ich verhindern. Könnt ihr mir helfen.
Was müsste ich an dieser Formel ändern daß,egal wieviele Zeilen ich ausschneide der bezug immer bis zeile 1400 geht?
Danke im Voraus.

=SUMME(WENN((' in Arbeit'!T3:T1400<$B$4)*(' in Arbeit'!N3:N1400=D2);' in Arbeit'!M3:M1400))

  

Betrifft: AW: Zellbezug ändert sich beim ausschneiden von: Rudi Maintaire
Geschrieben am: 28.07.2014 16:41:12

Hallo,
=SUMMEWENNS(' in Arbeit'!M:M;' in Arbeit'!T:T;"<" &B4;' in Arbeit'!N:N;D2)

Gruß
Rudi


  

Betrifft: AW: Zellbezug ändert sich beim ausschneiden von: Frank Schellbach
Geschrieben am: 28.07.2014 16:45:30

Das ging ja schnell. Danke schon mal. Wenn ich aber zeile 1 &2 nicht mit einbeziehen will dann T3.T ?


  

Betrifft: AW: Zellbezug ändert sich beim ausschneiden von: Daniel
Geschrieben am: 28.07.2014 16:44:38

Hi

ersezte den Zellbezug: ' in Arbeit'!T3:T1400
durch: ' in Arbeit'!T3:Index(' in Arbeit'!T:T;1400)

die anderen Zellbezüge dann entsprechend.


Gruß Daniel


  

Betrifft: AW: Zellbezug ändert sich beim ausschneiden von: Frank Schellbach
Geschrieben am: 28.07.2014 16:50:58

Besten Dank! Funzt super


 

Beiträge aus den Excel-Beispielen zum Thema "Zellbezug ändert sich beim ausschneiden"