Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS - Matrix wo Wert gleich ... ist

Betrifft: SVERWEIS - Matrix wo Wert gleich ... ist von: ebody
Geschrieben am: 31.07.2014 14:50:28

Hallo,

ich habe 2 Fragen:

1. Ich mache einen SVERWEIS. Es soll aber nur in der Matrix gesucht werden, wo in Spalte C der Wert "de" steht.

2. Ich mache einen SVERWEIS. Wird der gesuchte Wert darin gefunden, möchte ich wissen ob in Spalte E in der Zeile des gefundenen Wertes, der Wert "1" steht. Wenn ja, soll ein "ja" eingefügt werden.

Wie kann man das machen?

Gruß
ebody

  

Betrifft: AW: SVERWEIS - Matrix wo Wert gleich ... ist von: Hajo_Zi
Geschrieben am: 31.07.2014 14:59:06

=Wenn(sverweis(Deine Bedingugaber Spalte 5)=1:"ja;"keine Angabe")

GrußformelHomepage


  

Betrifft: mit INDEX() und VERWEIS() ... von: neopa C (paneo)
Geschrieben am: 31.07.2014 15:09:49

Hallo,

... wie Du es beschrieben hast, so z.B.:

 ABCDEFGHI
1       a4
2a1com 2   ja
3b2de 1    
4a3com 3    
5a4de 2    
6b5com 2    
7         
8         

Formeln der Tabelle
ZelleFormel
I1{=INDEX(B:B;VERGLEICH(H1;WENN(C1:C99="de";A1:A99); ))}
I2=WENN(INDEX(E:E;VERGLEICH("b";A:A;))=1;"ja";"")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS - Matrix wo Wert gleich ... ist"