Microsoft Excel

Herbers Excel/VBA-Archiv

Filterfunktion

Betrifft: Filterfunktion von: Jochen Dähne
Geschrieben am: 05.08.2014 11:51:55

Hallo,

ich habe folgende Herausforderung und bisher keine Lösung gefungen.

Der Dateninhalt meiner Tabelle (Arbeitszeitdaten/Stempelzeiten - Datenexport einer Zeiterfassung) änder sich immer wieder, wobei der Aufbau gleich bleibt. In Spalte B habe ich Personalnummern, die eindeutig sind. In Spalte E habe ich das Tagesdatum. Dieses kann für den gleichen Tag mehrmals vorkommen, da manche Mitarbeiter untertägig mehrmals ausstempeln (z.B. Ruacherpausen). Nun möchte ich in der Tabelle, zwecks Überprüfung von Rundungslogiken, nur jeweils pro Mitarbeiter und Arbeitstag die erste Buchung in Spalte E, also den ersten Datensatz sehen. Alle anderen, untertägigen Buchungen in Spalte sollen ausgeblendet bzw. gelöscht werden.
Kann mir da jemand helfen?

https://www.herber.de/bbs/user/91907.xls

  

Betrifft: AW: Filterfunktion von: Tino
Geschrieben am: 05.08.2014 12:04:38

Hallo,
wenn ich dich richtig verstanden habe und Deine Version
die Du angegeben hast stimmt könnte es so gehen.

In Zelle M2 diese Formel

=WENN(ZÄHLENWENNS($B$2:B2;B2;$E$2:E2;E2)=1;1;0)

Diese bis ans Ende runderziehen danach kannst Du mit dem Autofilter nach dieser Spalte filtern.

Gruß Tino


  

Betrifft: AW: Filterfunktion von: jo_cindy
Geschrieben am: 05.08.2014 13:32:28

Hallo Tino,

danke für deine schnelle Hilfe!!! Funktioniert :-)

Kannst du mir die Formel noch kurz erklären? Danke


  

Betrifft: AW: Filterfunktion von: Tino
Geschrieben am: 05.08.2014 13:49:55

Hallo,
ich hoffe ich kann dies verständlich rüberbringen!
ist analog zur einfachen Zählenwenn Funktion.
Ab xl2007 gibt es die Zählenwenns, mit der man in mehreren Spalten Zählen kann.

Wenn Du diese Formel nach unten kopierst, wird aus $B$2:B2;B2 eben $B$2:B3;B3 usw.
Zählt also das Vorkommen von oben bis zur Formelzeile und
wenn dies zum ersten Mal vorkommt ergibt dies 1 (in diesem Fall dann WAHR)
wenn der Suchbegriff zum zweiten, dritten ... mal oder gar nicht vorkommt
ist dies ungleich 1 und ergibt eben FALSCH.
Die Wenn-Funktion gibt entsprechend Wahr oder Falsch 1 oder 0 aus.

Gruß Tino


  

Betrifft: AW: Filterfunktion von: jo_cindy
Geschrieben am: 05.08.2014 16:07:47

Hi Tino, vielen Dank!


  

Betrifft: zu ZÄHLENWENNS() ... von: neopa C (paneo)
Geschrieben am: 05.08.2014 15:32:11

Hallo Jochen,

... dazu sieh auch mal hier: http://www.online-excel.de/excel/singsel.php?f=187

Gruß Werner
.. , - ...