Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Arbeitszeiten berechnen

Betrifft: Arbeitszeiten berechnen von: Kai
Geschrieben am: 07.08.2014 10:14:00

Hallo zusammen,

ich bin gerade dabei eine Excel-Liste zu erstellen mit denen ich die Bearbeitungszeit von Anfragen erfassen und auswerten kann.

Spalte A: Startzeit
Spalte B: Endzeit
Spalte C: Freitzeit ( zur Kennzeichnung von Wochenende / Urlaub / Feiertage )
Spalte D: Bearbeitungszeit

Bei der Berechnung der Bearbeitungszeit sollen nun zwei Punkte berücksichtigt werden:
1. Standardarbeitszeit ist von 08:00 bis 17:00 Uhr
2. Wenn ich in Spalte C eine Zeitangabe eintrage, soll diese von der Bearbeitungszeit abgezogen werden.

https://www.herber.de/bbs/user/91948.xlsx

Kann mir hier jemand helfen? Ich habe zwar mal eine Formel getestet, jedoch habe ich da Gefühl, dass die Zeit nicht richtig berechnet wird.

Schon mal vielen Dank im voraus.

Liebe Grüße

Kai

  

Betrifft: Du hast schon gegoogelt?... von: neopa C (paneo)
Geschrieben am: 07.08.2014 11:12:11

Hallo Kai,

,,, und Dich haben die 145.000 Treffer abgeschreckt?

Ich hab jetzt Deine Datei auch nicht angeschaut. Aber schau doch z.B. u.a. mal hier: http://www.excelformeln.de/formeln.html?gruppe=1 Formel 403 und 412 und zu den Grundlagen hier: http://www.online-excel.de/excel/singsel.php?f=129 und hier: http://www.online-excel.de/excel/singsel.php?f=130

Gruß Werner
.. , - ...


  

Betrifft: AW: Arbeitszeiten berechnen von: JoWE
Geschrieben am: 07.08.2014 11:17:07

Hallo Kai,

angenommen in C" wird "05:00" eingetragen (also 5 Std.) und die sollen in D2 als Minus berücksichtigt werden, könnte die Formel in D2 so aussehen: =((B2-A2)*24)-C2

Ich lasse die Frage trotzdem noch offen, weil es sicher noch andere und vllt. bessere Lösungen gibt.

Gruß
Jochen


  

Betrifft: AW: nochmal weil Häkchen vergessen von: JoWE
Geschrieben am: 07.08.2014 11:28:05

Hallo Kai,

angenommen in C2 wird "05:00" eingetragen (also 5 Std.) und die sollen in D2 als Minus berücksichtigt werden, könnte die Formel in D2 so aussehen: =((B2-A2)*24)-C2

Ich lasse die Frage trotzdem noch offen, weil es sicher noch andere und vllt. bessere Lösungen gibt.

Gruß
Jochen


  

Betrifft: es reicht =B2-A2 -C2 ... von: neopa C (paneo)
Geschrieben am: 07.08.2014 11:45:38

Hallo Jochen, hallo Kai,

... denn Du hast ja die komplette Zeitangabe in den Spalten A:B zu stehen. Das Zellenformat sollte jedoch [h]:mm sein.

Um Fehlerwerte abzufangen: auch so z.B.:

=WENN(ANZAHL(A2:B2)<2;"";B2-A2-C2)

Gruß Werner
.. , - ...


  

Betrifft: AW: es reicht =B2-A2 -C2 ... von: Kai
Geschrieben am: 07.08.2014 11:49:18

Hallo Werner,

danke für diee Antwort. Mein Fehler war auch eine falsche Formatierung. Jetzt passt es.

Vielen lieben Dank. :-)

Gruß

Kai


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeiten berechnen"