Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Excel-Funktion BEREICHE

Betrifft: Excel-Funktion BEREICHE von: Daniel B.
Geschrieben am: 09.08.2014 13:54:31

Guten Tag,

unter Formeln / Nachschlagen und Verweisen findet man die Excel-Funktion BEREICHE.
Nun ist mir schon klar, wie sie funktioniert:
=BEREICHE(A48) ergibt 1
=BEREICHE((A48;B48:B51;C43:C44))ergibt 3
=BEREICHE((B48:B51;C43)ergibt 2
Was aber um Himmels Willen kann man damit anfangen? Ich habe vieles probiert, damit weiter zu rechnen. Dies geht aber auf anderen Wegen auch.
Weiß jemand, welchen praktischen Nutzen diese Funktion hat bzw. haben soll?

Vielen Dank für Antworten

Daniel B.

  

Betrifft: Xl-Fkt BEREICHE ist wohl eine reine ... von: Luc:-?
Geschrieben am: 09.08.2014 20:38:16

…Info-Fkt, Daniel,
deren Nutzen marginal sein dürfte, da sie offensichtlich nur bei einer derartigen Aufführung unzusammen­hängender Bereiche fktioniert. Allerdings kann man so deren Anzahl feststellen, was ggf bei Konstrukten wie dem folgenden nützlich sein mag:
2⇐BEREICHE(((C28:D30;D32:E34) D29:D33))
In komplexeren Fmln ist diese Fkt ggf bedingt brauchbar, wenn sie einer anderen Fkt, die eine solche Angabe verarbeiten kann, als Argument übergeben wird, zB …
{=INDEX((C28:C30;E32:E34);3;1;BEREICHE((C28:C30;E32:E34)))}
Bei mehreren unzusammenhängenden Bereichen könnte man so die Bereichsangabe auch rückwärts gezählt machen.
Gruß, Luc :-?


  

Betrifft: AW: BEREICHE von: Ewald
Geschrieben am: 10.08.2014 11:22:32

Hallo,

Bereiche ist die Excelfunktion entsprechend Areas.Count.

Es ist nur eine von den Bereichsrückgabefunktionen.

ob in Formeln sinnvoll zu verwenden wissen die Formelfreaks besser.

In VBA lassen sich aber dadurch zB. aus einem zusammengesetzten Range sowohl die Gesamtsumme als auch die Summe der einzelnen Bereiche ermitteln.

Sub Bereich_auslesen()
Dim myrange As Range
Dim x As Long
Dim i As Long
Set myrange = Application.Union(Range("A48"), Range("B48:B51"), Range("C43:C44"))
x = myrange.Areas.Count
For i = 1 To x
MsgBox Application.WorksheetFunction.Sum(myrange.Areas(i))
Next
MsgBox Application.WorksheetFunction.Sum(myrange)
End Sub
Gruß Ewald


  

Betrifft: Anwendung von BEREICHE() eher äüßerst selten ... von: neopa C (paneo)
Geschrieben am: 10.08.2014 16:40:12

Hallo Luc,

... ich glaube mich zu erinnern, das {Boris} oder was es doch Jens (Fleckenstein) ? - ich weiß es wirklich nicht mehr - mal in einer Formel diese Funktion angewendet hat

Aber ansonsten kann ich mich auch nicht erinnern, dass diese Funktion in Formeln mal zur Anwendung kam.

Gruß Werner
.. , - ...


  

Betrifft: AW: Anwendung von BEREICHE() eher äüßerst selten ... von: Ewald
Geschrieben am: 11.08.2014 11:59:12

Hallo,

hier mal ein Beispiel mit Bereiche

 BCDE
23    
24Bereiche Umsätze   
25  8 
26  9 
27 410 
2815  
2926  
3037  
31    
32gesamt55  
33bereich16  
34bereich222  
35bereich327  
36    

NameBezug
Umsätze=Tabelle2!$B$28:$B$30;Tabelle2!$C$27:$C$30;Tabelle2!$D$25:$D$27

ZelleFormel
C32=SUMME(Umsätze)
C33=SUMME(INDEX(Umsätze;;;BEREICHE(Umsätze)-2))
C34=SUMME(INDEX(Umsätze;;;BEREICHE(Umsätze)-1))
C35=SUMME(INDEX(Umsätze;;;BEREICHE(Umsätze)))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


anstatt Bereiche kann aber der Index auch direkt angegeben werden.

Es scheint aber nur für Bereiche auf einer Tabelle zu gehen

Gruß Ewald


  

Betrifft: wie Du selbst schreibst, ist es ein Beispiel ... von: neopa C (paneo)
Geschrieben am: 11.08.2014 12:30:08

Hallo Ewald,

... welches auch anderweitig gelöst werden kann.
Daniel. B hatte aber gefragt: "...welchen praktischen Nutzen diese Funktion hat bzw. haben soll?" und den könnte ich ihm daran/damit leider auch nicht wirklich erklären.


Gruß Werner
.. , - ...




  

Betrifft: es führen viele Wege nach Rom von: Ewald
Geschrieben am: 11.08.2014 13:38:38

Hallo Werner,

...welchen man benutzt,muß ja jeder selbst entscheiden.

Auch ist ja nicht alles was machbar, immer der sinnvollste oder beste Weg.

Wie oben ja schon erwähnt ist "Bereiche" eine Bereichsrückgabefunktion die mir die Anzahl der Teilbereiche zurückgibt. Bei 3 sicher kein Problem, bei vielen kann das schon helfen.

Den Index zu bestimmen durch Herunterzählen der Bereichsanzahlangabe ist sicher nur eine Möglichkeit.

Oft ist es ja auch so, das Funktionen weil wenig bekannt, nicht genutzt werden.

Gruß Ewald


  

Betrifft: ...Da ist es dann schon merkwürdig, dass dieses... von: Luc:-?
Geschrieben am: 11.08.2014 14:19:36

…Thema beinahe zeitgleich gleich in 2 Foren auftaucht, Leute;
Hier ist das Analogon zu finden! ;-]
Gruß, Luc :-?


  

Betrifft: AW: ...Da ist es dann schon merkwürdig, dass dieses... von: Daniel B.
Geschrieben am: 13.08.2014 19:43:32

Hallo Excel-Freunde,

ich will mich nur noch bedanken für die doch recht rege Diskussion zur Funktion BEREICHE.
Das hilft mir schon weiter.

Grüße
Daniel B.


 

Beiträge aus den Excel-Beispielen zum Thema "Excel-Funktion BEREICHE"