Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis

Betrifft: sverweis von: Werner
Geschrieben am: 10.08.2014 13:38:11

Hallo Excelprofis,

ich benötige einmal mehr eure Hilfe.

In den Zellen der Spalte C wird eine Personalnummer (Tabelle Employees) eingegeben.
In den Zellen der Spalte D wird die jeweilige Arbeitszeit des Mitarbeiters eingegeben.
In den Zellen der Spalte E wird die Artikelbezeichnung (Kartenreiter) eingegeben.
In den Zellen der Spalte F wird die Nummer einer Arbeitsaufgabe eingegeben (aus Tabelle Art. 1, Art. 1, Covers, etc.).

https://www.herber.de/bbs/user/92000.xls

Bis auf nachfolgend beschriebenes funktioniert alles.

Was ich nicht hinbekomme ist folgendes…
Durch Eingabe der Nummer einer Arbeitsaufgabe (Zellen Spalte F) soll die entsprechende Arbeitsaufgabe bezogen auf die jeweilige Artikelbezeichnung (Zellen Spalte E) ausgegeben werden.
Bezogen auf eine Artikeltabelle funktioniert es. Jedoch habe ich keine Vorstellung wie das mit mehreren Artikeltabellen funktioniert.

Ich hoffe, dass ich mich verständlich genug ausgedrückt habe.

Vielen Dank für eure Hilfe
Gruß
Werner

  

Betrifft: AW: sverweis von: Spenski
Geschrieben am: 10.08.2014 14:08:25

hallo werner.

zb mit wenn und sverweis

G3=WENN(E3="Art. 1";SVERWEIS(F3;'Art. 1'!$A$5:$B$20;2;0);WENN(Donald!E3="Art. 2";SVERWEIS(F3;'Art. 2'!$A$4:$B$20;2;0)))

gruss


  

Betrifft: kleine korrektur von: Spenski
Geschrieben am: 10.08.2014 14:32:25

hatte Cover vergessen

G3=WENN(E3="Art. 1";SVERWEIS(F3;'Art. 1'!$A$4:$B$20;2;0);WENN(E3="Art. 2";SVERWEIS(F3;'Art. 2'!$A$4:$B$20;2;0);WENN(E3="Cover";SVERWEIS(F3;Covers!$A$4:$B$103;2;0);"")))

allerdings haut das nicht hin wenn du nicht in jeder zeile schreibst welcher artikel es ist (Spalte E)

mit hilfsspalte würds gehen aber vielleicht hat noch jmd ne andere idee

gruss


  

Betrifft: AW: sverweis von: Ewald
Geschrieben am: 10.08.2014 17:47:21

Hallo,

damit es was einfacher wird

für die Zellen in Spalte E in Donald Datengültigkeit/Liste art1;art2;cov

jetzt Namen vergeben für die Artikeltabellen

art1 = ='Art. 1'!$A$4:$C$20
art2 = ='Art. 2'!$A$4:$C$20
cov = = Covers!$A$4:$C$10

Die Formel lautet dann =SVERWEIS(F3;INDIREKT(E3);2;0)

Gruß Ewald


  

Betrifft: AW: sverweis von: Werner
Geschrieben am: 10.08.2014 18:18:08

Hallo Namensvetter und alle anderen Helfer…

Vielen Dank!
Das ist SUPER!!

Und schon wieder habe ich was dazugelernen.

Gruß
Werner


  

Betrifft: AW: sverweis von: Werner
Geschrieben am: 10.08.2014 19:23:06

Hallo Namensvetter und alle anderen Helfer…

Vielen Dank!

Das ist SUPER.

Und schon wieder konnte ich was dazulernen.

In einem Punkt benötige ich jedoch nochmal etwas Hilfe.

Solang die Zellen der Spalte G keine Daten enthalten, wird in den Zelle G3 und H3 #DIV/0! und in allen weiteren Zellen der Spalten G und H #NV angezeigt (Division durch 0 bzw. durch eine leere Zelle). Nun wollte ich mittels „WENN(ISTFEHLER(…“ dieses Anzeige unterdrücken, jedoch ohne Erfolg.
Würdet ihr mir bitte nochmal helfen?

Gruß
Werner


  

Betrifft: AW: sverweis von: Spenski
Geschrieben am: 10.08.2014 20:23:00

Nimm =wennfehler(DeineFormel;"")

Gruss


  

Betrifft: AW: sverweis von: Werner
Geschrieben am: 11.08.2014 01:19:55

Danke Spenski :-)

würdest Du mir bitte mitteilen wann/warum "wennfehler(.." und wann/warum "wenn(istfehler(..." eingesetzt wird?

Danke und Gruß
Werner


  

Betrifft: kombiniert mit INDIREKT() und VERWEIS() ... von: neopa C (paneo)
Geschrieben am: 10.08.2014 16:28:42

Hallo Namensvetter,

... in G3:

=SVERWEIS($F3;INDIREKT("'"&VERWEIS(9;1/($E$3:$E3<>"");$E$3:$E3)&"'!A2:C561");SPALTE(B1);0)

und Formel nach rechts und unten kopieren.

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "sverweis"