Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixformel-versprochenes nun realisiert ...

Betrifft: Matrixformel-versprochenes nun realisiert ... von: gk
Geschrieben am: 11.08.2014 14:46:03

versprochenes nun realisiert ...
von: neopa C

Ich weiß nicht warum ich auf meinen Beitrag nicht mehr antworten kann. In "Deine Beiträge" kann ich sie zwar einsehen aber nicht mehr antworten.

Danke an Werner für die tolle Unterstützung. Vl. kann er mir nocheinmal helfen mit der Gewinnaufteilung.
Wenn zb 2 erste Plätze sind, dann sollen sich diese Personen den Gewinn des ersten teilen. usw.

Leider kann ich die Spalten A:D in Auswertung nicht problemlos löschen.

Wegen meiner Frage Import wäre eine VBA freie Lösung super.
Eine Schaltfläche einzubinden, mit der aus anderen Excelarbeitsmappen die Tippliste eines Spielers importiert wird und an letzter Stelle der Tippliste angehängt wird?
Der Name des Spielers wäre dann der Dateiname der importierten Datei.
https://www.herber.de/bbs/user/92020.xlsm

Ich bin auch per mail über die ausgeblendete Seite erreichbar.

Danke im voraus.

  

Betrifft: Thread werden nach 7 Tagen archiviert, ... von: neopa C (paneo)
Geschrieben am: 11.08.2014 15:04:47

Hallo gk,

... kann dort niemand mehr antworten. Der Vollständigkeit halber hier der Link auf den archivierten Thread https://www.herber.de/forum/archiv/1372to1376/t1374037.htm.

Du hast meine dortige Frage noch nicht richtig verstanden. Erhalten immer die ersten 5 Ränge Gewinnbeteiligung, egal wieviel Spieler teilnehmen? Ist es immer der gleiche Prozentsatz?


Gruß Werner
.. , - ...


  

Betrifft: AW: Thread werden nach 7 Tagen archiviert, ... von: gk
Geschrieben am: 11.08.2014 15:20:53

Oh, sorry wegen doppelt,.....
Wegen der Archivierung, das wusste ich nicht.

Ja wahrscheindlich erhalten immer die ersten 5 Plätze einen Gewinn, aber es sollen auch wenn es 2 fünfte gibt den Gewinn geben.
Der Prozentsatz kann variieren.


  

Betrifft: noch immer nicht eindeutig ... und ... von: neopa C (paneo)
Geschrieben am: 11.08.2014 17:58:38

Hallo gk,

... deshalb nochmal nachgefragt: Wenn es z.B. drei erste Ränge gibt, teilen diese sich 55%+25%+10% des Preises und es bleiben 10% für Rang 4 und 5 oder?

Wenn dem so ist, dann hatte u.a. auch ich dafür schon mal vor Wochen / Monaten (?) hier im Forum eine Lösungsformel aufgestellt. Solltest Du diese nicht im Archiv bzw. durch Googlen finden dann schau ich die nächsten Tage noch mal, diese einfach neu zu konstruieren.

Zu Deinem 2.Frageteil:

Den VBA-freien Lösungsweg, wie ich mir den vorstelle, skizziere ich hier nur kurz.
In Deiner Arbeitsmappe werden soviel Tabellenblätter angelegt, wie Du max Spieler hast und dieses z.B_einfach Sp1, Sp2 ... etc benannt. Dort werden mit direktem Formelbezug die Daten aus den Dateien geholt (sofern vorhanden - lässt sich aber auch abprüfen), deren Namen den Tabellenblattnamen entsprechen. Und die so gesammelten Daten, werden aus den Tabellenblättern wieder über eindeutig adressierbaren Formelbezug in Dein Tabellenblatt "Tippliste" übernommen.

Gruß Werner
.. , - ...
Hier


  

Betrifft: AW: noch immer nicht eindeutig ... und ... von: gk
Geschrieben am: 11.08.2014 18:38:51

Hallo,

ja, das mit den teilen wie du angeführt hast geht so in Ordnung.

Ich habe soeben gesucht- Leider finde ich die angesprochene Formel nicht. :(


2. Teil:
Nein, nicht ganz. Es sollten die Tabellenblätter importiert werden können-Schaltfläche?
(Diese Tabellenblätter befinden sich in einem eigenen Ordner mit dem Dateinamen des jeweiligen Spielers)
Die Auswertung soll erkennen wie viele Spieler importiert worden sind.
Es sollte dann auch möglich sein, dass nachträglich Tabellenblätter importiert werden können.
(Die Tabellenblätter bekomme ich ausgefüllt per mail zurückgesendet mit Dateiname=Spielername)

In der Exceldatei sollten dann neben der Auswertungsdatei die Tabellenblätter der Spieler sein.

Ich hoffe, es ist verständlich.


  

Betrifft: so kommen wir nicht zum Ziel ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 09:22:04

Hallo gk,

... Du überlässt offensichtlich das Gedanken machen Anderen?

Was ist z.B. wenn weniger als 5 Spieler beteiligt sind ... etc?

Außerdem hab ich soeben festgestellt, dass Du zum Einen meine Hinweis im letzten Thread nicht richtig umgesetzt hast und das es durchaus Fälle geben kann, die eine andere Tippauswertungsformel erfordert (sieh Dir mal Deine letzte Tabelle genau an, da gibt es teilweise 3 Punkt für nichts) wie auch auch entsprechend angepasste Auswertung der Punktrangfolge.

In Tippauswertung!K6 sollte mE zumindest folgende Formel stehen:

=WENN((ANZAHL($D6:$F6)=0)+(ANZAHL(H6:J6)<1);0;(VORZEICHEN($D6-$F6)=VORZEICHEN(H6-J6))+(($D6-$F6) =(H6-J6))+(($D6=H6)*($F6=J6)))  
Auf Grund dessen, dass auch Spieler noch keinen Tipp abgegeben haben, habe ich die weiteren Auswertungsformeln angepasst. Damit ergeben sich im Beispiel nur 2 die Punkte erzielt haben.

Überarbeite also zunächst Deine Tabelle und gib eine separate (!) Zusatztabelle an, wo eine Gewinnverteilung den Rängen zugeordnet in Abhängigkeit - oder auch nicht - der Spieleranzahl erkenntlich ist.

Auswertung

 EFGJ
2RangNamePunkte Gewinn
31Spieler 054,01511 
42Name neu16,00362 
5     
6     
7     
8     
9     

Formeln der Tabelle
ZelleFormel
E3=WENN(G3="";"";RANG(G3;G$3:G$52))
F3{=WENN(G3="";"";INDEX(Tippliste!$1:$1;KKLEINSTE(WENN((Tippliste!$4:$4=G3); SPALTE($1:$1)); ZÄHLENWENN($G$3:G3;G3))-3))}
G3{=WENN(ZEILE(A1)>SUMME((Tippliste!$4:$4>0)*ISTZAHL(Tippliste!$4:$4)); "";KGRÖSSTE(Tippliste!$4:$4;ZEILE(A1)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: OT @ Werner von: Christian
Geschrieben am: 12.08.2014 11:06:54

Hallo Werner,

dass das eine "unendliche Geschichte" wird, hatte ich schon befürchtet! ;-)

https://www.herber.de/forum/archiv/1372to1376/t1374037.htm#1374145

Respekt für Deine Geduld!

MfG Christian


  

Betrifft: nu, guggmer mal ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 14:20:10

Hallo Christian,

... ob wir zumindest ein Teilthema als erledigt betrachten können. Das noch offene überlasse ich auch anderen ;-)


Gruß Werner
.. , - ...


  

Betrifft: AW: so kommen wir nicht zum Ziel ... von: gk
Geschrieben am: 12.08.2014 11:26:11

Hallo,
das sind so viele Faktoren.....

Es werden immer mindestens 5 Spieler teilnehmen.

Ich hoffe, dass ich jetzt alle Formeln richtig eingegeben habe.
Was mir aber jetzt noch aufgefallen ist, dass in Tippliste zb in O15 nichts ausgefüllt ist, aber trotzdem ein Punkt vergeben wird- oder zählt ein leeres Feld als 0 ?

Ich habe probiert die Tabelle mit der Rangordnung und Prozentverteilung zu erstellen, weiß aber nicht wie ich da genau weitermachen soll.

https://www.herber.de/bbs/user/92038.xlsm


  

Betrifft: die Verteilungsformel ... und ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 14:21:00

Hallo gk,

... zunächst aber Antwort auf Deine Frage: "...zählt ein leeres Feld als 0 ?". Momentan ja und zwar egal ob für "Heim" oder "Gast", aber nur wenn wenigstens ein Torergebnis angeben ist (kann auch eine 0 sein).

Wenn das nicht gewollt ist, dann einfach in Tippliste!K6

=WENN((ANZAHL($D6:$F6)=0)+(ANZAHL(H6:J6)<2);0; ...
Die Verteilungsformel in D3 setzt die Anpassungen der Formeln in F3:G3 voraus. Prüfe nochmal A3:C3. Die Formeln in K6:K8 nur der Vollständigkeit halber: K7 =100%-SUMME(H3:H52) K8 =SUMME(D:D)
Beachte jedoch mein %-Format für die Zellen mit Prozent.

 ABCDEFGHIJK
1           
2RangNamePunkte Gewinn  Rang Gewinn Prozent Spieleranzahl6
31SpielerA58,01633,00 1   33,00 € 55% Tippschein        10 €
42Spieler 1156,0165,40 2   15,00 € 25% Pot        60 €
52Spieler 256,0165,40 3     6,00 € 10%   
62Spieler 3356,0165,40 4     4,20 € 7% Kontrolle proz. Verteilung100%
72Spieler 456,0165,40 5     1,80 € 3% Noch zu vergebene Prozent:0%
82Spieler 556,0165,40      Gewinn-Kontrollsumme€ 60,00
9            
10            
11            

Formeln der Tabelle
ZelleFormel
A3=WENN(C3="";"";RANG(C3;C$3:C$52))
B3{=WENN(C3="";"";INDEX(Tippliste!$1:$1;KKLEINSTE(WENN((Tippliste!$4:$4=C3); SPALTE($1:$1)); ZÄHLENWENN($C$3:C3;C3))-3))}
C3{=WENN(ZEILE(A1)>SUMME((Tippliste!$4:$4>0)*ISTZAHL(Tippliste!$4:$4)); "";KGRÖSSTE(Tippliste!$4:$4;ZEILE(A1)))}
D3=WENN(A3>MAX(F:F); "";SUMME(INDEX(G:G;VERGLEICH(A3;F:F;)):INDEX(G:G;ZÄHLENWENN(A:A;A3)+A3+1))/ZÄHLENWENN(A:A;A3))
F3=WENN(G3="";"";ZEILE(A1))
G3=WENN(H3>0;$K$4*H3;"")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: die Verteilungsformel ... und ... von: gk
Geschrieben am: 12.08.2014 20:59:55

Hallo!
Super jetzt funktioniert die Aufteilung. Ich habe sämtliche Szenarien durchgespielt.

Jetzt wäre bitte noch die Import Sache... ;)

https://www.herber.de/bbs/user/92058.xlsm


  

Betrifft: dazu ist in ein neuer Thread sinnvoll ... von: neopa C (paneo)
Geschrieben am: 13.08.2014 09:01:15

Hallo gk,

... mich interessieren VBA-Lösungen nicht oder nur bedingt. Deshalb eröffne doch einen Thread mit dieser spez. Thematik.


Gruß Werner
.. , - ...


  

Betrifft: AW: dazu ist in ein neuer Thread sinnvoll ... von: Luschi
Geschrieben am: 13.08.2014 18:55:33

Hallo gk,

ich habe Dir aus dem Thread 'Importieren' erstmal eine Routine gemacht, mit der man die Spielansetzungen für mehrere/viele Teilnehmer als Datei unter dem Namen des Spielers anlegt.
Wenn ich heute Nacht nicht schlafen kann, mache ich auch die Import-Routine, ansonsten morgen vormittag.

Hier das Beispiel: https://www.herber.de/bbs/user/92083.xlsm

Gruß von Luschi
aus klein-Paris

PS: ein paar Erklärungen siehe Vba-Code


  

Betrifft: ein ergänzender Hinweis dazu ... von: neopa C (paneo)
Geschrieben am: 14.08.2014 09:43:14

Hallo Luschi,

... falls dieser Thread nächste Woche im Archiv versinken sollte, gk hatte hier: https://www.herber.de/forum/messages/1376174.html schon einen neuen Thread aufgemacht. Allerdings hat der Tenor ("hier hab ich, nun macht mal") möglicherweise potentielle Helfer bisher abgehalten.

Ich bin dann erst einmal paar Tage offline.


Gruß Werner
.. , - ...