Microsoft Excel

Herbers Excel/VBA-Archiv

"Mttelweit"aus Uhrzeit

Betrifft: "Mttelweit"aus Uhrzeit von: Stefan
Geschrieben am: 12.08.2014 11:06:05

Hallo zusammen,

ich habe ein Problem und komme einfach nicht weiter:

In der beigefügten Tabelle befinden sich Ankunftszeiten.
Ich möchte nun aus den Uhrzeiten die durchschnittliche Ankunftszeit ermitteln.
Bei mir kommt immer als Ergebnis 13:29 Uhr heraus, was zwar rechnerisch richtig sein mag, aber nicht das, was ich benötige. (irgendetwas zwsichen 23:10 und 0:45)

Weiß hier jemand eine Lösung?

Vielen Dank und viele Grße
Stfan

https://www.herber.de/bbs/user/92037.xlsx

  

Betrifft: AW: "Mttelweit"aus Uhrzeit von: fcs
Geschrieben am: 12.08.2014 11:20:28

Hallo Stefan,

dazu müsstets du vor der Mittelwertberechnung in einer Hilfsspalte zu allen Zeitwerten nach Mitternacht, die z.B. < 12:00:00 sind, den Wert 1 addieren.
Formel in C2:

=WENN(B2<ZEIT(12;0;0);B2+1;B2)

Diese Formel dann nach unten kopieren bis zum Ende der Liste und aus den berechneten Werten den Mittelwert berechnen.
Da kommt dann 23:59 als Ergebnis.

Gruß
Franz


  

Betrifft: AW: "Mttelweit"aus Uhrzeit von: Frank
Geschrieben am: 12.08.2014 11:21:42

Hallo Stefan,

ohne die Tabelle angeschaut zu haben - die Lösung liegt auf der Hand: Entweder Zeiten vor 24:00 als Differenz 24:00-Uhrzeit oder Zeiten nach 0:00 Uhr als Zeiten 24:00+Uhrzeit mitteln lassen und dann, je nach Ergebnis, wieder 24:00 abziehen oder dazurechnen.

Grüsse,
Frank


  

Betrifft: AW: "Mttelweit"aus Uhrzeit von: Daniel
Geschrieben am: 12.08.2014 11:24:45

Hi

in Spalte C folgende Formel und nach unten ziehen:
=WENN(B2<ZEIT(12;0;0);B2+1;B2)

dann die Mittelwertbildung mit:
=REST(MITTELWERT(C2:C17);1)

Gruß Daniel


  

Betrifft: Motto: doppelt hält besser? ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:27:24

Hallo Stefan alias Jenny,

... warum hier: https://www.herber.de/forum/messages/1375875.html nochmal das Gleiche?


Gruß Werner
.. , - ...


  

Betrifft: sorry, für meine falsche Aussage hier ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:45:09

Hallo Stefan,

.. ich hab in einem anderen Thread hier: https://www.herber.de/forum/messages/1375886.html meine Lösungsformel für Deine hiesige Anfrage eingetragen und glaubte dann wirklich, dieser wäre unter einem anderen Namen nochmal geschrieben :-(

Entschuldige bitte.


Gruß Werner
.. , - ...


  

Betrifft: AW: sorry, für meine falsche Aussage hier ... von: Stefan
Geschrieben am: 12.08.2014 11:47:57

Macht nichts, ist ja gelöst!
Aber danke für deine Mühe!

Gruß
STefan


  

Betrifft: AW: "Mttelweit"aus Uhrzeit von: Tino
Geschrieben am: 12.08.2014 11:28:05

Hallo,
das Problem dabei ist Urzeiten sind Dezimalzahlen und fängt bei 0 an!
23:45 = 0,989583333
00:00 = 0

Du müsstest also bei Zeiten die über Mitternacht gehen + 1 Addieren.

In etwa so

 ABC
1DatumAnkunft 
211.08.201423:4523:59
308.08.201423:10 
407.08.201423:25 
506.08.201423:40 
605.08.201423:55 
704.08.20140:05 
801.08.201423:45 
931.07.20140:20 
1030.07.201423:50 
1129.07.20140:30 
1228.07.20140:20 
1325.07.201423:45 
1424.07.20140:00 
1523.07.201423:50 
1622.07.20140:45 
1721.07.20140:45 

Formeln der Tabelle
ZelleFormel
C2=(SUMMEWENN(B2:B17;">=0,5";B2:B17)+SUMMENPRODUKT((B2:B17<0,5)*(B2:B17+1)))/ANZAHL(B2:B17)





Gruß Tino


  

Betrifft: DANKE von: Stefan
Geschrieben am: 12.08.2014 11:33:24

Vielen Dank an alle für die Lösungen!

Viele Grüße
Stefan


 

Beiträge aus den Excel-Beispielen zum Thema ""Mttelweit"aus Uhrzeit "