Microsoft Excel

Herbers Excel/VBA-Archiv

Suche in anderem Tabellenblatt

Betrifft: Suche in anderem Tabellenblatt von: Jenny
Geschrieben am: 12.08.2014 11:09:29

Hallo alle zusammen,

ich stehe leider ein wenig auf dem Schlauh. Kann mir das folgende jemand in eine Formel packen?

Gebe wahr aus, wenn D1 irgendwo im Bereich A1:A20000 der Tabelle 1 steht, auch wenn es nur ein Teil der Zelle ist.

Helft ihr mir bitte?

Gruß
Jenny

  

Betrifft: z.B. mit SVERWEIS() ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:13:12

Hallo Jenny,

..: so: =SVERWEIS("*"&D1&"*";A:A;1;)


Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. mit SVERWEIS() ... von: Jenny
Geschrieben am: 12.08.2014 11:58:14

Hallo Werner,

=SVERWEIS("*"&E3&"*";Tabelle1!A1:A20000;1;) gibt E3 aus, wenn es in Tabelle1 gefunden wird, nur danach kann ich schlecht filtern, wenn es nach kopieren der Formel 200 verschiedene Texte sind, daher wollte ich ja das die Formel Wahr oder Falsch ausgibt.

Gruß
Jenny


  

Betrifft: AW: Suche in anderem Tabellenblatt von: Matze Matthias
Geschrieben am: 12.08.2014 11:15:50

Hallo Jenny,
schon mal mit index und Vergleich gearbeitet?

http://www.online-excel.de/excel/singsel.php?f=39

Versuch dich mal,...Übung ist gut....

Matze


  

Betrifft: AW: Suche in anderem Tabellenblatt von: Jenny
Geschrieben am: 12.08.2014 12:03:21

Hallo Matze,

ja das kenne ich, benutze in einer anderen Tabelle die schöne Formel

=WENNFEHLER((INDEX(Tankstelle1!A:A;VERGLEICH(A1;Tankstelle1!A:A;0)-4)/1000)-(ISTZAHL(SUCHEN("Shell"; INDEX(Tankstelle1!A:A;VERGLEICH(A1;Tankstelle1!A:A;0)-1;1)))*0,01);"") 
nur hätte ich nicht gedacht dass das in diesem Fall zur Anwendung kommt, da ich ja eine Ausgabe WAHR oder Falsch suche und diese Formel einen Zelleninhalt ausgibt.

Gruß
Jenny


  

Betrifft: mit MITELWERT(WENN(...)) in einer MATRIXFormel .. von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:24:30

Hallo Jenyy,

... so: Tabelle1

 ABC
1DatumAnkunft23:59
211.08.201423:45 
308.08.201423:10 
407.08.201423:25 
506.08.201423:40 
605.08.201423:55 
704.08.20140:05 
801.08.201423:45 
931.07.20140:20 
1030.07.201423:50 
1129.07.20140:30 
1228.07.20140:20 
1325.07.201423:45 
1424.07.20140:00 
1523.07.201423:50 
1622.07.20140:45 
1721.07.20140:45 
18   

Formeln der Tabelle
ZelleFormel
C1{=MITTELWERT(WENN(B2:B99<>"";(B2:B99<0,5)+B2:B99))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: sorry, der Beitrag war hier deplatziert ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:40:43

Hallo Jenny,

... ich stand offensichtlich noch in Deinem Thread und hab den anderen gelesen :-( Tut mir leid.l


Gruß Werner
.. , - ...


  

Betrifft: AW: Suche in anderem Tabellenblatt von: Jenny
Geschrieben am: 12.08.2014 11:45:58

Hallo,

ich suche doch nur sowas wie

=WENN(ANZAHL2("*"&D1&"*";Tabelle1!A1:A20000)>0;"WAHR";"FALSCH")
zumindest so vom Sinn her.

Gruß
Jenny


  

Betrifft: dann besser mit VERGLEICH() ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 11:57:53

Hallo Jenny,

... so: =ISTZAHL(VERGLEICH("*"&D1&"*";Tabelle1!A1:A20000;))

Gruß Werner
.. , - ...


  

Betrifft: AW: dann besser mit VERGLEICH() ... von: Jenny
Geschrieben am: 12.08.2014 12:01:07

Hallo Werner, ich muss dir was gestehen, in meiner vorgeschlagenen Formel war ein Denkfehler,

es hätte

=WENN(ANZAHL2(D1;"*"&Tabelle1!A1:A20000&"*")>0;"WAHR";"FALSCH")
heißen sollen, also das D1 ein Teil eines Textes einer Zelle in Tabelle1!A1:A20000 sein soll.

Gruß
Jenny


  

Betrifft: hast Du die Formel getestet? ... von: neopa C (paneo)
Geschrieben am: 12.08.2014 12:27:21

Hallo Jenny,

... dann solltest Du bemerkt haben, dass ich Deine Vorstellung schon richtig interpretiert hatte.
Siehe:

 ABCD
1 WAHR text
2Start   
3etwas   
4abtext123   
5    
6Ende   
7    
8    

Formeln der Tabelle
ZelleFormel
B1=ISTZAHL(VERGLEICH("*"&D1&"*";Tabelle1!A1:A20000;))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: hast Du die Formel getestet? ... von: Jenny
Geschrieben am: 12.08.2014 12:37:15

Hallo Werner,

getestet habe ich sie, ob sie einen Fehler ausgibt. Ich habe natürlich nicht 20.000 Zeilen überprüft, ob das Ergebnis stimmt oder nicht.

Mir war halt nur aufgefallen, dass meine Ursprungsformel falsch war.
Aber dann scheints ja zu funktionieren. Danke.

Gruß
Jenny


 

Beiträge aus den Excel-Beispielen zum Thema "Suche in anderem Tabellenblatt"