Microsoft Excel

Herbers Excel/VBA-Archiv

Null unterdrücken

Betrifft: Null unterdrücken von: walter
Geschrieben am: 13.08.2014 22:01:26

Hallo Excelfreunde,
Wenn in Spieltage noch kein Ergnis vorliegt
sollen Zellen leer bleiben.
https://www.herber.de/bbs/user/92087.xls
Siehe Blatt Auskunft.
Wie muß die Formel Lauten?

Gruß
Walter

  

Betrifft: AW: Null unterdrücken von: Ewald
Geschrieben am: 13.08.2014 23:50:28

Hallo Walter,

markiere F2 bis G31

bedingte Formatierung/Formel

Formel =UND($F2=0;$G2=0)

Formatierung Schriftfarbe weiß

Gruß Ewald


  

Betrifft: AW: Null unterdrücken von: Daniel
Geschrieben am: 14.08.2014 09:28:44

Hi

wenn du einen Zellbezug auf eine leere Zelle erstellt, dann gibt dir Excel das Ergebnis 0 zurück.
wenn bei einer leeren Zelle auch der Leerstring das Ergebnis sein soll, dann geht das am einfachsten, indem man noch den Leerstring an den Zellbezug anfügt, dh statt =A1 dann =A1&""

heißt bei dir konkret als Formel für das Blatt Auskunft Zelle D2:
{=WENN(ISTFEHLER(INDEX(Spieltage!$A$1:$K$1000;KKLEINSTE(WENN(Spieltage!$A$1:$G$1000=$B$2;ZEILE($1:$999));ZEILE(I1));2));"";INDEX(Spieltage!$A$1:$G$1000;KKLEINSTE(WENN(Spieltage!$A$1:$G$1000=$B$2;ZEILE($1:$999));ZEILE(J1));6))&""}

für E2 dann analog.

Im Ergbnis werden dadruch die Zahlen zu Text, aber das sollte hier in der Auskunftstabelle nicht das Problem sein.

Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Null unterdrücken"