Microsoft Excel

Herbers Excel/VBA-Archiv

Prozentuale Verteilung

Betrifft: Prozentuale Verteilung von: Werner
Geschrieben am: 18.08.2014 19:02:08

Hallo Excel Profis,

Ich benötige Hilfe bei der Umsetzung folgender Aufgabe...

https://www.herber.de/bbs/user/92178.xlsx

In den Zellen der Spalte F der beigefügten Mappe werden Kürzel eingegeben. Diese bewirken, dass der Wert in den Zellen der Spalte B der Zelle/Spalte mit dem Kürzel als Titel zugewiesen wird. Nun soll der Wert auf 2 Zellen mit unterschiedlichem Kürzel verteilt werden, und zwar entsprechend der Prozentangabe in den Zellen der Spalte H.

Beispiel:
In der Zelle F2 wird das Kürzel sn eingetragen. Der Wert in der Zelle B2 wird daraufhin in der Zelle K2 angezeigt. Wenn nunmehr in der Zelle G2 das Kürzel ed eingetragen wird und in der Zelle H2 ein Prozentwert, soll der Prozentuale Anteil vom Wert in Zelle K2 subtrahiert und in Zelle L2 ausgegeben werden.
Dieses soll in allen Kombinationen bezogen auf die Spaltentitel möglich sein.

Ich muss gestehen, dass ich nicht mal ansatzweise eine Vorstellung habe wie es umzusetzen ist.

Danke und Gruß
Werner

  

Betrifft: AW: Prozentuale Verteilung von: UweD
Geschrieben am: 18.08.2014 19:57:06

Hallo

so??

nach rechts und unten copieren..


kw34

 BFGHIJKLMN
1        dumisneddussc
2      30.375,17   sned23%         23.388,88          6.986,29      
3      23.133,79   dus                 23.133,79    
4      12.706,21   ed               12.706,21      
5      14.835,17   du         14.835,17            
6        1.824,83   sc                     1.824,83   
7           228,03   sn                  228,03        
8        1.216,55   sn               1.216,55        
9        9.360,69   ed                 9.360,69      
10        4.646,55   sc                     4.646,55   
11        7.181,03   mied10%         6.462,93               718,10      
12        2.517,59   ed                 2.517,59      
13        2.331,72   ed                 2.331,72      

verwendete Formeln
Zelle Formel Bereich
I2 =WENN(UND($G2="";$H2=0;$F2=I$1);$B2;WENN($F2=I$1;$B2*(1-$H2);WENN($G2=I$1;$B2*$H2;""))) 

Tabellendarstellung in Foren Version 5.49


Gruß UweD


  

Betrifft: AW: Prozentuale Verteilung von: Luschi
Geschrieben am: 18.08.2014 21:34:58

Hallo UweD,

saubere Lösung ohne viel Zickerei (Vergabe von definierten Namen, Index, Vergleich, Bereich.Verschieben usw.).
Habe meinen Versuch gleich in die Tonne getreten nach dem Testen Deiner Lösung.

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: Prozentuale Verteilung von: Werner
Geschrieben am: 19.08.2014 03:32:59

Hallo UweD,

Klasse Lösung!
Auf den Gedanken die Spaltentitel mit den einzugebenen Kürzeln zu vergleichen wäre ich nie gekommen.

Vielen Dank

Gruß
Werner


  

Betrifft: Prozentuale Verteilung - ohne WENN... von: Erich G.
Geschrieben am: 19.08.2014 11:34:48

Hi Werner,
so ginge das auch:

 BFGHIJKLMN
1    dumisneddussc
230.375,17sned23%  23.388,886.986,29  
323.133,79dus      23.133,79 
412.706,21ed     12.706,21  
514.835,17du  14.835,17     
61.824,83sc       1.824,83
7228,03sn    228,03   
81.216,55sn    1.216,55   
99.360,69ed     9.360,69  
104.646,55sc       4.646,55
117.181,03mied10% 6.462,93 718,10  
122.517,59ed     2.517,59  
132.331,72ed     2.331,72  

Formeln der Tabelle
ZelleFormel
I2=(($F2=I$1)*(1-$H2)+($G2=I$1)*$H2)*$B2
J2=(($F2=J$1)*(1-$H2)+($G2=J$1)*$H2)*$B2
I3=(($F3=I$1)*(1-$H3)+($G3=I$1)*$H3)*$B3
J3=(($F3=J$1)*(1-$H3)+($G3=J$1)*$H3)*$B3


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

In den "leeren" Zellen in I2:N13 stehen Nullen, die man nicht sieht, wegen eines Zahlenformats wie z. B. #.##0,00;-#.##0,00;

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Erweiterung: Rundung von: Erich G.
Geschrieben am: 19.08.2014 11:50:16

Hi Werner,
spielt die Rundung keine Rolle?
Hier im Beispiel sieht Zeile 2 falsch aus - die Summe der Teilbeträge ist 1,04 statt 1,03.
Die Formeln ab I3 vermeiden das:

 BFGHIJKL
1    dumisned
21,03dumi50%0,520,52  
31,03dusn50%0,52 0,51 
41,03edmi50% 0,51 0,52

Formeln der Tabelle
ZelleFormel
I2=(($F2=I$1)*(1-$H2)+($G2=I$1)*$H2)*$B2
I3=RUNDEN(($F3=I$1)*(1-$H3)*$B3;2)+($G3=I$1)*($B3-RUNDEN((1-$H3)*$B3;2))

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Erweiterung: Rundung von: Werner
Geschrieben am: 19.08.2014 17:11:07

Hallo Erich,

Runden spielt in diesem Fall keine Rolle. Trotzdem vielen Dank für den Hinweis und die Formel zum runden. Mit Sicherheit werde ich eine entsprechende Routine später brauchen.

Die Tabelle, wenn sie fertig ist, soll mir bei der Produktionsplanung helfen. Welcher Auftrag kann in welcher Gruppe gefertigt werden, und/oder muss ein Auftrag auf mindestens 2 Gruppen aufgeteilt werden. Die Tabelle wird Stückminuten, Auftragsminuten und Kapazitätsminuten enthalten.
Wenn die Tabelle fertig ist, stelle ich sie zum Upload ins Forum.
Der Eine und/oder andre wird sich amüsieren  (bin Hobby Exceler kein Excel Profi) und Andere evtl. dem einen und/oder anderen Gedanken nutzen können.

Grüße aktuell aus Zrenjanin/SRB
Werner


  

Betrifft: AW: Erweiterung: Rundung von: Werner
Geschrieben am: 24.08.2014 10:47:53

Hallo Erich,
Auf Deine Hilfe (21.08.2014 01:16:38) bezüglich „Arbeitszeiten minus Pausenzeiten“ kann ich nicht direkt antworten, da ich die Mail offensichtlich versehentlich gelöscht habe .
Daher bedanke ich mich für die Hilfe auf dieser Antwortmail.

Fertige Mappe: https://www.herber.de/bbs/user/92260.xlsx

Dank Deiner Hilfe - „Prozentuale Verteilung - ohne WENN...“ - funktioniert das mit der prozentualen Verteilung super.
Jedoch habe ich diesbezüglich noch eine Bitte und benötige entsprechende Hilfe.
Wie müsste die Formel erweitert werden wenn gegebenenfalls weitere Spalten in dem bezeichneten Bereich hinzugefügt werden müssten.

Beispiel: https://www.herber.de/bbs/user/92261.xlsx
Wenn in Zelle P4 des beigefügten Beispiels ein a eingetragen wird und in Zelle Q4 eine Prozentangabe, soll der Prozentuale Anteil vom Wert in Zelle L4 in Zelle U4 ausgegeben werden.
In den Zellen V4 bis AB4 und AD4 soll der Wert aus Zelle L4 minus des Wertes in U4 entsprechend der bisherigen Berechnung ausgegeben werden.

Gruß und nochmals vielen Dank für Deine Hilfe
Werner


 

Beiträge aus den Excel-Beispielen zum Thema "Prozentuale Verteilung"