Microsoft Excel

Herbers Excel/VBA-Archiv

Auswahl nach bestimmten Kriterien

Betrifft: Auswahl nach bestimmten Kriterien von: Julia
Geschrieben am: 18.08.2014 20:36:29

https://www.herber.de/bbs/user/92182.xlsx

Hallo zusammen,

ich habe ein Tabellenblatt 1 (siehe oben), in der eine Tabelle mit Mitarbeitern geführt wird.
Es ist der Name hinterlegt und dazu trägt man ein, in welchem Bereich, ob Innen oder Außen und in welcher Schicht sie eingeteilt sind. Außerdem ist ihr Status (krank, Anwesend,..) angegeben.

Nun gibt es ein zweites Tabellenblatt. Das Übersichtsblatt. Diese Tabelle soll die Daten automatisch aus dem Tabellenblatt 1 ziehen. Es sollen also alle Mitarbeiter automatisch eingefügt werden, die im Hof arbeiten, Innen eingeteilt, in der Frühschicht eingetragen und zudem den Status Anwesend haben.

Am Ende dürfen nur die weiß hinterlegten Mitarbeiter Mai und Ott in der Übersicht erscheinen.

Kann mir dabei bitte jemand helfen?
Vielen Dank schon einmal!
Grüße

  

Betrifft: AW: Auswahl nach bestimmten Kriterien von: {Boris}
Geschrieben am: 18.08.2014 21:35:50

Hi Julia,

Tabellenblatt2, B3:

{=WENNFEHLER(INDEX('Tabellenblatt 1'!A$3:A$30;KKLEINSTE(WENN(('Tabellenblatt 1'!$C$3:$C$30="Hof") *('Tabellenblatt 1'!$D$3:$D$30="Innen")*('Tabellenblatt 1'!$E$3:$E$30="Frühschicht") *('Tabellenblatt 1'!$F$3:$F$30="Anwesend");ZEILE($1:$28));ZEILEN($1:1)));"") }

Ist eine {ARRAY!}formel - Eingabe mit Strg-Shift-Enter!

Formel dann sowohl runter als auch nach rechts kopieren.

VG, Boris


 

Beiträge aus den Excel-Beispielen zum Thema "Auswahl nach bestimmten Kriterien"