Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrere Bedingungen

Betrifft: Mehrere Bedingungen von: ismail ünal
Geschrieben am: 19.08.2014 22:51:11

Hallo Freunde,
ich hab eine Komplizierten Fall. Wenigstens für mich ist es so.
Ich habe die beispiel im Anhang.Meine Wunsch ist dass im Zelle B6 folgendes ergibt;

im falle B3 & B4, beide sind Kleiner als 1,22 dann soll es so berechnen; (B3 * B4)/2,4

im falle B3 & B4 sind grösser als 1,22 UND B3 ist grösser als B4 dann soll es ERGEBEN; B3

im falle B3 & B4 sind grösser als 1,22 UND B4 ist grösser als B3 dann soll es ERGEBEN; B4

im falle B3 oder B4 (nur eine von dem) ist grösser als 1,22 , das grössere soll das ergebnis sein.

Wie baue ich alle drei zusammen bitte??

Für ein schnelle Hilfe bin ich dankbar.

Mit freundlichen grüssen.

https://www.herber.de/bbs/user/92191.xlsx

  

Betrifft: AW: Mehrere Bedingungen von: Matthias L
Geschrieben am: 20.08.2014 00:29:01

Hallo

Bin nicht sicher, aber probiers mal als erster Ansatz

Tabelle1

 AB
2 masse
3breite1,22
4länge1,44
5anzahl2
6formel1,44

Formeln der Tabelle
ZelleFormel
B6=WENN(UND(B3<1,22;B4<1,22);(B3*B4)/2,4;WENN(UND(UND(B3>1,22;B4>1,22);B3>B4);B3;WENN(UND(UND(B3>1,22;B4>1,22);B4>B3);B4;WENN(UND(MAX(B3:B4)>1,22;MIN(B3:B4)<=1,22);MAX(B3:B4);""))))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Mehrere Bedingungen von: ismail ünal
Geschrieben am: 20.08.2014 02:19:37

Hallo Mathias,
Herzlichen dank. Das klappt eigentlich super, wie du es gebaut hast. Nur ich hab das letzte Word, falsch geschrieben. uns war; im falle B3 oder B4 (nur eine von dem) ist grösser als 1,22 , das grössere soll das ergebnis sein...Es sollte eigentlich sein;im falle B3 oder B4 (nur eine von dem) ist grösser als 1,22 , (B3 * B4)/2,4..Ich versuch mal mit deinen formel was zu drehen..Aber deine Max-Min ist mir unbekannt..vielleicht schaff ich trotzdem..

Besten dank für deine Zeit.

Herzliche grüsse.


  

Betrifft: AW: Mehrere Bedingungen von: Matthias L
Geschrieben am: 20.08.2014 07:13:32

Hallo


  1. im falle B3 & B4, beide sind Kleiner als 1,22 dann soll es so berechnen; (B3 * B4)/2,4

  2. im falle B3 & B4 sind grösser als 1,22 UND B3 ist grösser als B4 dann soll es ERGEBEN; B3

  3. im falle B3 & B4 sind grösser als 1,22 UND B4 ist grösser als B3 dann soll es ERGEBEN; B4

  4. im falle B3 oder B4 (nur eine von dem) ist grösser als 1,22 , das grössere soll das ergebnis



  5. Das heißt also Du willst bei Viertens: (B3 * B4)/2,4 als Ergebnis ?
    Was aber ist dann mit Erstens ? Soll das dann so bleiben?


Gruß Matthias


  

Betrifft: AW: Mehrere Bedingungen von: ismail ünal
Geschrieben am: 20.08.2014 12:23:09

Hallo Mathias,

ja es sol so bleiben.
Irgendwie schaff ich es nicht.

Schöne grüsse.


  

Betrifft: AW: Mehrere Bedingungen von: ismail ünal
Geschrieben am: 20.08.2014 13:00:44

Hi Matthias,
gelöst..Nur die letzte bereich habe ich, PROBIERT ;) und es war doch richtig.
Super net von dir.
Schöne grüsse.
Ismail
PS; Ich kann das ganze formel hier nicht schreiben, weil es html ist ..Keine ahnung was das problem ist.

WENN(UND(MAX(B3:B4)>1,22;MIN(B3:B4)<=1,22);((B3*B4)/2,4)))))


 

Beiträge aus den Excel-Beispielen zum Thema "Mehrere Bedingungen"