Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Rentenbeginn berechnen (Formel)

Betrifft: Rentenbeginn berechnen (Formel) von: Erwin
Geschrieben am: 20.08.2014 07:45:58

Guten Morgen,
bekanntermaßen ändert sich der Rentenbeginn stufenweise von 65 auf 67 Jahre.
vgl. http://de.wikipedia.org/wiki/Regelaltersrente

Jetzt habe ich bei http://xxcl.de/0022.htm folgende Formel gefunden:
Altersrentenbeginn-Datum zum Geburtsdatum A1:
=DATUM(JAHR(A1);MONAT(A1)+MAX(MIN(JAHR(A1);1964)*{0;1;2}-{-781;1165;3123});1)

Da die Formel einen kleinen Fehler hat wollte ich A. Wolff, den Inhaber der Webseite anschreiben und ihn um darauf hinzuweisen, dass es ein Problem mit den Personen gibt, die am 01. eines Monats geboren sind (Vollendung des Lebensjahres bekanntermaßen am Vortag, also -1 Monat); leider kommt ein ERROR beim Kontaktformular.

Meine Lösung wäre über eine ...wenn am 1. geboren...dann Monat -1...sonst...

=WENN(TAG(A1)=1;DATUM(JAHR(A1);MONAT(A1-1)+MAX(MIN(JAHR(A1);1964)*{0;1;2}-{-781;1165;3123});1); DATUM(JAHR(A1);MONAT(A1)+MAX(MIN(JAHR(A1);1964)*{0;1;2}-{-781;1165;3123});1))

Das ist doch etwas monströs die Formel, gibt es nichts kürzeres?

Grüße Erwin

  

Betrifft: AW: Rentenbeginn berechnen (Formel) von: Wilfried Höttl
Geschrieben am: 20.08.2014 08:31:17

Hallo!

Meinst du es so?

Tabelle1

 ABCDE
1EingabedatumJahre +/-Monate +/-Tage +/- 
228.02.1955636101.09.2018

Formeln der Tabelle
ZelleFormel
E2=DATUM(JAHR(A2)+B2;MONAT(A2)+C2+(TAG(A2+1)=1); (TAG(A2+1) <> 1)*MIN(TAG(A2); TAG(DATUM(JAHR(A2)+B2;1+MONAT(A2)+C2;))))+D2


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß
Wilfried


  

Betrifft: AW: Rentenbeginn berechnen (Formel) von: Erwin
Geschrieben am: 20.08.2014 08:46:03

Hallo Wilfried,
grundsätzlich ist es auch mit Hilfsspalten, einer Wertetabelle und SVERWEIS zu schaffen, das wollte ich aber nicht.
Da die Datei schon viele Tabs hat, ca. 500 Personen umfasst und schon mehr als 95 Spalten hat, wollte ich die Formellösung, da ich nicht noch mehr Daten generieren wollte.

Gibt es noch andere Lösungen?

Grüße Erwin


  

Betrifft: AW: Rentenbeginn berechnen (Formel) von: fcs
Geschrieben am: 20.08.2014 11:34:50

Hallo Erwin,

da nur der Monat korrigiert werden muss, musst du nicht die komplette Formel ins WENN packen, sondern nur im Monats-Teil ein WENN einbauen.

=DATUM(JAHR(A1);MONAT(A1 - WENN(TAG(A1)=1;1;0)) + MAX(MIN(JAHR(A1);1964)*{0;1;2}-{-781;1165;3123});1) 
und schon hast du nur noch ein Monsterchen von Formel.

Gruß
Franz


  

Betrifft: Super - passt "Monsterrespekt" owT von: Erwin
Geschrieben am: 20.08.2014 12:06:30




 

Beiträge aus den Excel-Beispielen zum Thema "Rentenbeginn berechnen (Formel)"