Microsoft Excel

Herbers Excel/VBA-Archiv

VBA um Adelstitel zu trennen

Betrifft: VBA um Adelstitel zu trennen von: An
Geschrieben am: 28.08.2014 16:14:24

Hey leute,

ich habe lange recherchiert und habe folgenden VBA gefunden:

[code]


Sub Namen_Titel_trennen()

    Dim lloZeile As Long, larstrSplit1() As String, larstrSplit2() As String, liTitel As _
Integer, liName As Integer
    
        For lloZeile = 1 To Cells(Rows.Count, 1).End(xlUp).Row
            larstrSplit1 = Split(Range("A" & lloZeile).Value, ".")
            larstrSplit2 = Split(Trim(larstrSplit1(UBound(larstrSplit1))), " ")
                For liName = 0 To UBound(larstrSplit2) - 1
                    Range("C" & lloZeile).Value = Range("C" & lloZeile).Value & larstrSplit2( _
liName) & " "
                Next
            Range("D" & lloZeile).Value = larstrSplit2(UBound(larstrSplit2))
                For liTitel = 0 To UBound(larstrSplit1) - 1
                    Range("B" & lloZeile).Value = Range("B" & lloZeile).Value & larstrSplit1( _
liTitel) & "."
                Next
        Next

End Sub
[/code]

An sich macht dieser Code genau das was ich will: Titel, Name und Vornamen trennen.
Was ich noch vermisse, ist, dass der Code auch Adelstitel erkennt und zum Nachnamen dazu voranfügt.

Ich denke da an so etwas zb. [code]{=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A1));TEIL(A1;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A1))+1;99);TEIL(A1;MAX((TEIL(A1;SPALTE($1:$1);1)=" ")*SPALTE($1:$1))+1;99))}[/code]

Nur, dass dies halt irgendwie mit in die VBA formel integriert wird... leider habe ich keine ahnung von VBA-Programmierung, was sich aber hoffentlich langsam verbessern wird :)

Hat jemand eine Idee, wie ich die Adelstitel mit in den Code integrieren kann?

Achja, was mir auch noch einfällt:
Gibt es eigentlich auch die Möglichkeit, dass das Ergebnis des VBA-Codes geglättet wird, also dass die Leerzeichen am Anfang und am Ende gleich entfernt werden? Im moment mache ich das immer noch anschließend manuell...
Und außerdem wollte ich wissen, wie der Code aussehen würde, wenn in eine weitere Spalte noch zusätzlich (wenn vorhanden) die Anrede "Herr" oder "Frau" getrennt wird? Also sprich gleiches Spiel wie oben, nur dass dann noch eine weitere Spalte mehr existiert, die Herr oder Frau ausgibt?

Vielen Dank im Voraus!
Mit freundlichen Grüßen
Peter

PS: hier ein paar Beispiele:

http://s14.directupload.net/images/140828/9a82rhn7.png

Wird nach anwenden deises VBA-Codes:
[code]

Sub Namen_Titel_trennen()

    Dim lloZeile As Long, larstrSplit1() As String, larstrSplit2() As String, liTitel As _
Integer, liName As Integer
   
        For lloZeile = 1 To Cells(Rows.Count, 1).End(xlUp).Row
            larstrSplit1 = Split(Range("A" & lloZeile).Value, ".")
            larstrSplit2 = Split(Trim(larstrSplit1(UBound(larstrSplit1))), " ")
                For liName = 0 To UBound(larstrSplit2) - 1
                    Range("C" & lloZeile).Value = Range("C" & lloZeile).Value & larstrSplit2( _
liName) & " "
                Next
            Range("D" & lloZeile).Value = larstrSplit2(UBound(larstrSplit2))
                For liTitel = 0 To UBound(larstrSplit1) - 1
                    Range("B" & lloZeile).Value = Range("B" & lloZeile).Value & larstrSplit1( _
liTitel) & "."
                Next
        Next

End Sub
[/code]

zu:
http://s1.directupload.net/images/140828/ynadm29w.png

Wie ihr sehen könnt, bleibt der Adelstitel (hier) "de, von, zu" beim Vornamen und wird als zweiten Vornamen erkannt, was ja falsch ist. Zudem stimmt das Feld für "Frau und Herr" nicht.
Ich stelle mir die optimalaufteilung so vor: (A1= Anrede, B1=Titel, C1=Vorname(n), D1=Nachname mit Adelstitel)

http://s7.directupload.net/images/140828/wzt8myxw.png

Und als i-Tüpfelchen wäre es eben klasse, wenn alle Zellen im Anschluss noch geglättet werden, sodass keine Leerzeichen mehr am Anfang und Ende eines Wortes stehen.

Versteht ihr nun was ich meine? :)

Danke und Gruß!
Peter

  

Betrifft: In wieviel Foren gefragt? von: hary
Geschrieben am: 28.08.2014 16:40:36

Moin
Anfragen in vielen Foren heisst nicht immer viele Antworten.
gruss hary


  

Betrifft: AW: wird in OfficeLösung bearbeitet von: Daniel
Geschrieben am: 28.08.2014 16:44:52

und braucht hier nicht weiter verfolgt werden.

ich kanns ja verstehen, dass jemand hofft, schneller antwort zu bekommen, wenn man seine Frage in mehreren Foren gleichzeitig stellt (man weiss als Neuling ja auch nicht immer, wo schnell geantwortet wird und wo es dauert).
Wenn man aber im anderen Forum schon antwort bekommen hat, sollte man das unterlassen, dass ist den den Helfern im anderen Forum gegenüber respektlos.

Gruß Daniel


  

Betrifft: Komplexe Aufgabe - Teillösung www.excelformeln.de von: NoNet
Geschrieben am: 28.08.2014 17:08:57

Hallo Peter,

schau Dir mal folgende Seite an (Teil-Lösung per Funktion - nicht per VBA !) :

http://www.excelformeln.de/formeln.html?welcher=158

Dein Makro funktioniert auch nicht sauber, hier ein paar Beispiele von o.g. Seite und Deines Makros :

ABCDEFGH
3
4
5
6
7
8
9
10
11
12
13

Funktionen im Tabellenblatt
Zelle Formel 
B5   =LINKS(A5;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A5);SPALTE(5:5)))-SUMME(MMULT((WECHSELN(A5;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A5)*{4;4;4;4;3;3};1))
B6   =LINKS(A6;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A6);SPALTE(6:6)))-SUMME(MMULT((WECHSELN(A6;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A6)*{4;4;4;4;3;3};1))
B7   =LINKS(A7;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A7);SPALTE(7:7)))-SUMME(MMULT((WECHSELN(A7;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A7)*{4;4;4;4;3;3};1))
B8   =LINKS(A8;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A8);SPALTE(8:8)))-SUMME(MMULT((WECHSELN(A8;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A8)*{4;4;4;4;3;3};1))
B9   =LINKS(A9;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A9);SPALTE(9:9)))-SUMME(MMULT((WECHSELN(A9;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A9)*{4;4;4;4;3;3};1))
B10   =LINKS(A10;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A10);SPALTE(10:10)))-SUMME(MMULT((WECHSELN(A10;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A10)*{4;4;4;4;3;3};1))
B11   =LINKS(A11;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A11);SPALTE(11:11)))-SUMME(MMULT((WECHSELN(A11;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A11)*{4;4;4;4;3;3};1))
B12   =LINKS(A12;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A12);SPALTE(12:12)))-SUMME(MMULT((WECHSELN(A12;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A12)*{4;4;4;4;3;3};1))
B13   =LINKS(A13;VERWEIS(999;SUCHEN(" ";GLÄTTEN(A13);SPALTE(13:13)))-SUMME(MMULT((WECHSELN(A13;{"von ";"van ";"und ";"der ";"zu ";"ob "};)<>A13)*{4;4;4;4;3;3};1))
C5   =RECHTS(A5;LÄNGE(A5)-LÄNGE(B5)
C6   =RECHTS(A6;LÄNGE(A6)-LÄNGE(B6)
C7   =RECHTS(A7;LÄNGE(A7)-LÄNGE(B7)
C8   =RECHTS(A8;LÄNGE(A8)-LÄNGE(B8)
C9   =RECHTS(A9;LÄNGE(A9)-LÄNGE(B9)
C10   =RECHTS(A10;LÄNGE(A10)-LÄNGE(B10)
C11   =RECHTS(A11;LÄNGE(A11)-LÄNGE(B11)
C12   =RECHTS(A12;LÄNGE(A12)-LÄNGE(B12)
C13   =RECHTS(A13;LÄNGE(A13)-LÄNGE(B13)
D5   =WENN(ODER(ISTFEHLER(FINDEN(" ";A5));CODE(LINKS(A5;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A5));ISTFEHLER(FINDEN("von ";A5));ISTFEHLER(FINDEN("zu ";A5))); WENN(UND(CODE(TEIL(A5;FINDEN(" ";A5)+1;1)) < 97;LÄNGE(A5)-LÄNGE(WECHSELN(A5;" ";)) > 1);TEIL(A5;1;FINDEN(" ";A5;FINDEN(" ";A5)+1));TEIL(A5;1;FINDEN(" ";A5)));LINKS(A5; WENN(NICHT(ISTFEHLER(FINDEN("von ";A5)));FINDEN("von ";A5);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A5)));FINDEN("zu ";A5);FINDEN("ob ";A5)))-1))
D6   =WENN(ODER(ISTFEHLER(FINDEN(" ";A6));CODE(LINKS(A6;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A6));ISTFEHLER(FINDEN("von ";A6));ISTFEHLER(FINDEN("zu ";A6))); WENN(UND(CODE(TEIL(A6;FINDEN(" ";A6)+1;1)) < 97;LÄNGE(A6)-LÄNGE(WECHSELN(A6;" ";)) > 1);TEIL(A6;1;FINDEN(" ";A6;FINDEN(" ";A6)+1));TEIL(A6;1;FINDEN(" ";A6)));LINKS(A6; WENN(NICHT(ISTFEHLER(FINDEN("von ";A6)));FINDEN("von ";A6);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A6)));FINDEN("zu ";A6);FINDEN("ob ";A6)))-1))
D7   =WENN(ODER(ISTFEHLER(FINDEN(" ";A7));CODE(LINKS(A7;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A7));ISTFEHLER(FINDEN("von ";A7));ISTFEHLER(FINDEN("zu ";A7))); WENN(UND(CODE(TEIL(A7;FINDEN(" ";A7)+1;1)) < 97;LÄNGE(A7)-LÄNGE(WECHSELN(A7;" ";)) > 1);TEIL(A7;1;FINDEN(" ";A7;FINDEN(" ";A7)+1));TEIL(A7;1;FINDEN(" ";A7)));LINKS(A7; WENN(NICHT(ISTFEHLER(FINDEN("von ";A7)));FINDEN("von ";A7);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A7)));FINDEN("zu ";A7);FINDEN("ob ";A7)))-1))
D8   =WENN(ODER(ISTFEHLER(FINDEN(" ";A8));CODE(LINKS(A8;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A8));ISTFEHLER(FINDEN("von ";A8));ISTFEHLER(FINDEN("zu ";A8))); WENN(UND(CODE(TEIL(A8;FINDEN(" ";A8)+1;1)) < 97;LÄNGE(A8)-LÄNGE(WECHSELN(A8;" ";)) > 1);TEIL(A8;1;FINDEN(" ";A8;FINDEN(" ";A8)+1));TEIL(A8;1;FINDEN(" ";A8)));LINKS(A8; WENN(NICHT(ISTFEHLER(FINDEN("von ";A8)));FINDEN("von ";A8);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A8)));FINDEN("zu ";A8);FINDEN("ob ";A8)))-1))
D9   =WENN(ODER(ISTFEHLER(FINDEN(" ";A9));CODE(LINKS(A9;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A9));ISTFEHLER(FINDEN("von ";A9));ISTFEHLER(FINDEN("zu ";A9))); WENN(UND(CODE(TEIL(A9;FINDEN(" ";A9)+1;1)) < 97;LÄNGE(A9)-LÄNGE(WECHSELN(A9;" ";)) > 1);TEIL(A9;1;FINDEN(" ";A9;FINDEN(" ";A9)+1));TEIL(A9;1;FINDEN(" ";A9)));LINKS(A9; WENN(NICHT(ISTFEHLER(FINDEN("von ";A9)));FINDEN("von ";A9);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A9)));FINDEN("zu ";A9);FINDEN("ob ";A9)))-1))
D10   =WENN(ODER(ISTFEHLER(FINDEN(" ";A10));CODE(LINKS(A10;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A10));ISTFEHLER(FINDEN("von ";A10));ISTFEHLER(FINDEN("zu ";A10))); WENN(UND(CODE(TEIL(A10;FINDEN(" ";A10)+1;1)) < 97;LÄNGE(A10)-LÄNGE(WECHSELN(A10;" ";)) > 1);TEIL(A10;1;FINDEN(" ";A10;FINDEN(" ";A10)+1));TEIL(A10;1;FINDEN(" ";A10)));LINKS(A10; WENN(NICHT(ISTFEHLER(FINDEN("von ";A10)));FINDEN("von ";A10);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A10)));FINDEN("zu ";A10);FINDEN("ob ";A10)))-1))
D11   =WENN(ODER(ISTFEHLER(FINDEN(" ";A11));CODE(LINKS(A11;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A11));ISTFEHLER(FINDEN("von ";A11));ISTFEHLER(FINDEN("zu ";A11))); WENN(UND(CODE(TEIL(A11;FINDEN(" ";A11)+1;1)) < 97;LÄNGE(A11)-LÄNGE(WECHSELN(A11;" ";)) > 1);TEIL(A11;1;FINDEN(" ";A11;FINDEN(" ";A11)+1));TEIL(A11;1;FINDEN(" ";A11)));LINKS(A11; WENN(NICHT(ISTFEHLER(FINDEN("von ";A11)));FINDEN("von ";A11);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A11)));FINDEN("zu ";A11);FINDEN("ob ";A11)))-1))
D12   =WENN(ODER(ISTFEHLER(FINDEN(" ";A12));CODE(LINKS(A12;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A12));ISTFEHLER(FINDEN("von ";A12));ISTFEHLER(FINDEN("zu ";A12))); WENN(UND(CODE(TEIL(A12;FINDEN(" ";A12)+1;1)) < 97;LÄNGE(A12)-LÄNGE(WECHSELN(A12;" ";)) > 1);TEIL(A12;1;FINDEN(" ";A12;FINDEN(" ";A12)+1));TEIL(A12;1;FINDEN(" ";A12)));LINKS(A12; WENN(NICHT(ISTFEHLER(FINDEN("von ";A12)));FINDEN("von ";A12);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A12)));FINDEN("zu ";A12);FINDEN("ob ";A12)))-1))
D13   =WENN(ODER(ISTFEHLER(FINDEN(" ";A13));CODE(LINKS(A13;1))>96);"";WENN(UND(ISTFEHLER(FINDEN("ob ";A13));ISTFEHLER(FINDEN("von ";A13));ISTFEHLER(FINDEN("zu ";A13))); WENN(UND(CODE(TEIL(A13;FINDEN(" ";A13)+1;1)) < 97;LÄNGE(A13)-LÄNGE(WECHSELN(A13;" ";)) > 1);TEIL(A13;1;FINDEN(" ";A13;FINDEN(" ";A13)+1));TEIL(A13;1;FINDEN(" ";A13)));LINKS(A13; WENN(NICHT(ISTFEHLER(FINDEN("von ";A13)));FINDEN("von ";A13);WENN(NICHT(ISTFEHLER(FINDEN("zu ";A13)));FINDEN("zu ";A13);FINDEN("ob ";A13)))-1))

MATRIX-Funktionen im Tabellenblatt :
ZelleFormel
E5   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A5));TEIL(A5;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A5))+1;99);TEIL(A5;MAX((TEIL(A5;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E6   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A6));TEIL(A6;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A6))+1;99);TEIL(A6;MAX((TEIL(A6;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E7   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A7));TEIL(A7;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A7))+1;99);TEIL(A7;MAX((TEIL(A7;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E8   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A8));TEIL(A8;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A8))+1;99);TEIL(A8;MAX((TEIL(A8;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E9   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A9));TEIL(A9;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A9))+1;99);TEIL(A9;MAX((TEIL(A9;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E10   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A10));TEIL(A10;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A10))+1;99);TEIL(A10;MAX((TEIL(A10;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E11   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A11));TEIL(A11;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A11))+1;99);TEIL(A11;MAX((TEIL(A11;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E12   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A12));TEIL(A12;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A12))+1;99);TEIL(A12;MAX((TEIL(A12;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)
E13   {=WENN(ANZAHL(FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A13));TEIL(A13;VERWEIS(99;FINDEN({" zu ";" von ";" ob ";" de ";" van ";" auf ";" vom "};A13))+1;99);TEIL(A13;MAX((TEIL(A13;SPALTE($4:$4);1)=" ")*SPALTE($4:$4))+1;99)

Tabelle eingefügt mit Syntaxhighlighter 4.15

Es ist weder per VBA noch per Funktion einfach, das zu lösen - zumal es zu viele Anreden/Titel, Vor- und Nachnamen sowie Präpositionen zu Adelstiteln gibt !

Ich möchte hier nicht mit einem Lösungsversuch einsteigen, da es m.E. keine 100%-Lösung gibt !

Gruß, NoNet


  

Betrifft: AW: Komplexe Aufgabe - Teillösung www.excelformeln.de von: An
Geschrieben am: 28.08.2014 17:31:08

Hallo NoNet,

vielen Dank für deine Info!
Gibt es denn eigentlich eine Möglichkeit, diese Formeln in VBA "umzuwandeln", sodass das Skript diese Formeln automatisch einfügt?

Danke und gruß!

PS: An Daniel:
Danke für den Hinweis, aber wie du gesagt hast, ich hoffe halt mehr antworten zu kriegen, wenn ich auf verschiedenen foren meine Anfrage stelle, macht ja auch irgendwie sinn oder nicht? ;)
Und für dieses Problem habe ich auch noch bisher in keinem anderen forum eine antwort bekommen.

Peter


  

Betrifft: AW: Komplexe Aufgabe - Teillösung www.excelformeln.de von: Daniel
Geschrieben am: 28.08.2014 18:31:06

PS: An Daniel:
Danke für den Hinweis, aber wie du gesagt hast, ich hoffe halt mehr antworten zu kriegen, wenn  _
ich auf verschiedenen foren meine Anfrage stelle, macht ja auch irgendwie sinn oder nicht? ;)
Und für dieses Problem habe ich auch noch bisher in keinem anderen forum eine antwort bekommen.

Peter
Helfen dir mehrer Anworten wirklich (die können ja auch alle gleich sein)?
Würdest du auch so handeln, wenn du für jede Antwort eine entsprechende Gegenleistung erbringen müsstest?
Ist es sinnvoll, sich anders zu verhalten, als es von den andern Forumsteilnehmen (und vorallem von denjenigen, die hier antworten) erwünscht wird und sich damit unbeliebt zu machen?
Gruß Daniel


  

Betrifft: AW: Komplexe Aufgabe - Teillösung www.excelformeln.de von: An
Geschrieben am: 29.08.2014 13:55:53

Hallo,

erst einmal vielen Dank für alle Antworten und Infos etc!!

Nun möchte ich mich bei allen Teilnehmern öffentlich entschuldigen, dass ich sogenanntes "Cross-Posting" betrieben habe.

Ich habe mir ehrlich gesagt, nicht sehr viel dabei gedacht, und wusste nicht, dass es dermaßen unangemessen ist.

In der Foren-Welt bin ich noch recht neu und deshalb möchte ich mich entschuldigen, und verspreche, dass ich Themen nur auf anderen Foren poste, wenn es in diesem nicht / spät beantwortet wird.

Ich hoffe, dass ihr mir meinen Fehler verzeiht!

Liebe Grüße
Peter


  

Betrifft: AW: Komplexe Aufgabe - Teillösung www.excelformeln.de von: Daniel
Geschrieben am: 29.08.2014 14:32:09

Na dann, willkommen im Club.
ich denke du hast jetzt gemerkt, welchen Aufwand das Crossposting verursachen kann.
Wenn du dir mal in den Beiträgen die Zeiten anschaust, dann wirst du feststellen, dass du sowohl im Herber- als auch im Officeforum in der Regel schnelle und kompetente Antwort bekommst, so dass es eigentlich nicht notwendig ist, eine Anfrage mehrfach zu stellen.
Das mag in Foren mit weniger Traffic anders sein, aber hier definitiv nicht.

Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "VBA um Adelstitel zu trennen"