Microsoft Excel

Herbers Excel/VBA-Archiv

Saldorechnung in Excel

Betrifft: Saldorechnung in Excel von: Stephan M.
Geschrieben am: 01.09.2014 18:16:12

Liebe Excel-Fans,

ich würde gerne Excel nutzen, um meine persönlichen Finanzen in Ordnung zu bringen und mir einen Überblick zu verschaffen.

Auf einem Tabellenblatt möchte ich mtl. Konto Ein- und Ausgänge je Thema erfassen, Beispiel anbei. In Spalte D stehen die Einnahmen je Thema (Spalte C), in Spalte E die Ausgaben. In Spalte J hätte ich gerne immer das aktuelle Saldo je Thema gewusst, um zu wissen, wie der Saldo im jeweiligen Thema ist.

https://www.herber.de/bbs/user/92426.xlsx

Wäre klasse, wenn Sie mir hier aushelfen könnten!!

Tausend Dank und viele Grüße
Stephan

  

Betrifft: AW: Saldorechnung in Excel von: hary
Geschrieben am: 01.09.2014 18:32:26

Moin Stephan
Eine Moeglichkeit.



Tabelle1

 IJ
4Kleidung600
5Urlaub250
6Spende600

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
J4:J6=SUMMENPRODUKT(($C$4:$C$13=I4)*(($D$4:$D$13)+($E$4:$E$13)))  =SUMPRODUCT((R4C3:R13C3=RC[-1])*((R4C4:R13C4)+(R4C5:R13C5)))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: Saldorechnung in Excel von: Stephan M.
Geschrieben am: 01.09.2014 18:46:20

Super klasse, ich danke Euch!!


  

Betrifft: AW: Saldorechnung in Excel von: Matthias L
Geschrieben am: 01.09.2014 18:35:24

Hallo Stephan

Hinweis
Im Forum gilt allgemein das "Du" zum Ansprechen.


Zur Frage
Es gibt da unterschiedliche Möglichkeiten

Eine davon ist die Formel =SummeWenn
oder auch =SummeWenns oder =Summenprodukt

Ich habs mal in einer Spalte realisiert:
Tabelle1

 BCDHIJ
3 FilterE / A   
4SeptemberKleidung200,00 €SALDENKleidung600,00 €
5 Urlaub150,00 €Urlaub250,00 €
6 Spende200,00 €Spende600,00 €
7OktoberKleidung200,00 €   
8 Urlaub150,00 €   
9 Spende200,00 €   
10 Urlaub-200,00 €   
11NovemberKleidung200,00 €   
12 Urlaub150,00 €   
13 Spende200,00 €   

Formeln der Tabelle
ZelleFormel
J4=SUMMEWENN($C$4:$C$13;$I4;$D$4:$D$13)
J5=SUMMEWENN($C$4:$C$13;$I5;$D$4:$D$13)
J6=SUMMEWENN($C$4:$C$13;$I6;$D$4:$D$13)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias