Microsoft Excel

Herbers Excel/VBA-Archiv

Spaltenwerte addieren_2

Betrifft: Spaltenwerte addieren_2 von: Peter Weber
Geschrieben am: 05.09.2014 09:46:22

Hallo Zusammen,

In der Zeile 10, ab Spalte C, stehen meine Monatswerte.
In der Zeile 13 möchte ab Spalte C, die Werte der Zeile 10 aufsummieren.
Soweit kein Problem.
Nun möchte ich aber die Formel nach rechts kopieren aber so, dass nach 12 Monaten die Aufsummierung wieder mit Januar anfängt.

Ich habe bereits eine gute Lösung von Rudi (s. Archiv 1379333) erhalten.

Jetzt habe ich das Problem, dass sobald ein #NV in der Zeile vorliegt die Berechung wie Rudi sie vorgeschlagen hat nicht mehr funktioniert.

Wie könnte die Formel =SUMMENPRODUKT((JAHR($C9:D9)=JAHR(D9))*$C10:D10) angepasst werden, damit die #NV ignoriert werden und die Berechnung ausgeführt wird.

Leider kann ich keine 0 verwenden, weil diese Werte in ein xy-Diagramm übernommen werden und die 0-en angezeigt werden.

LG, Peter

  

Betrifft: AW: Spaltenwerte addieren_2 von: Rudi Maintaire
Geschrieben am: 05.09.2014 10:00:55

Hallo,
vermeide doch einfach die #NV.

Gruß
Rudi


  

Betrifft: AW: Spaltenwerte addieren_2 von: Peter Weber
Geschrieben am: 05.09.2014 12:23:30

Hallo Rudi,

geht leider nicht.
Die Y-Werte werden aus einer anderen Tabelle mit zig Tausend Werten generiert.

Kann man irgendwie den Befehl Istfehler in deine Formel einbauen?

LG, Peter


  

Betrifft: AW: Spaltenwerte addieren_2 von: Rudi Maintaire
Geschrieben am: 05.09.2014 12:45:31

Hallo,
geht leider nicht.
glaub ich nicht.

Die Y-Werte werden aus einer anderen Tabelle mit zig Tausend Werten generiert.
was heißt das?

Kann man irgendwie den Befehl Istfehler in deine Formel einbauen?
Müsste man mit Summe() als Matrixformel realisieren können.
{=SUMME(wenn (istfehler($c10:d10);0;(JAHR($C9:D9)=JAHR(D9))*$C10:D10))}

Gruß
Rudi



Gruß
Rudi


 

Beiträge aus den Excel-Beispielen zum Thema "Spaltenwerte addieren_2"