Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit US-Datum

Betrifft: Problem mit US-Datum von: Elmar
Geschrieben am: 11.09.2014 13:31:28

Hallo zusammen,
ich habe ein auf den ersten Blick eher banales Problem:
Ich möchte von US-Uhrzeit auf deutsche Uhrzeit umrechnen lassen und zwar 13.000 Datensätze.
Die Uhrzeiten liegt wie folgt vor:

1. Spalte: Uhrzeit im Format hh:mm:ss
2. Spalte: AM oder PM als TEXT

Ich würde jetzt gerne die Uhrzeit in ein verwendbares, deutsches Format umrechnen lassen, also aus den getrennten Informationen die beispielsweise als "01:15:44" und in der Spalte neben dran als "PM" vorliegen eine Spalte mit dem deutschen Inhalt 13:15:44 Uhr machen.
Hat jemand eine Idee wie man das machen könnte außer von Hand?
Danke und viele Grüße
Elmar

  

Betrifft: AW: Problem mit US-Datum von: ChrisL
Geschrieben am: 11.09.2014 13:40:43

Hi Elmar

Problems from am to pm ;)

=WENN(B1="AM";A1;A1+0.5)

Zelle als Zeit formatieren, Formel runterziehen, kopieren, Inhalte einfügen, "Werte"

cu
Chris


  

Betrifft: AW: Problem mit US-Datum von: ChrisL
Geschrieben am: 11.09.2014 15:44:11

Hi Elmar

Noch ein Versuch:
=WENN(ODER(UND(B1="PM";STUNDE(A1)<12);UND(B1="AM";STUNDE(A1)=12));A1+0.5;A1)
cu
Chris


  

Betrifft: AW: Problem mit US-Datum von: Elmar
Geschrieben am: 11.09.2014 15:49:51

Toll vielen Dank Chris! So geht es, zumindest ich bei den "+0.5" statt dem Punkt ein Komma nutze.
Geht einwandfrei.
Jetzt muß ich mir noch eine sinnvolle Darstellung überlegen, wie ich ca. 13.000 Anrufe innerhalb von einem Jahr am besten in einem Diagramm im Tagesablauf meinetwegen zwischen 07.00 und 19.00 Uhr darstellen will. Vielleicht eine Art von Häufigkeitsverteilung... :-)
Die Daten sind ja jetzt aufbereitet dank Euch!

Gruß
Elmar


  

Betrifft: AW: Problem mit US-Datum von: Elmar
Geschrieben am: 11.09.2014 16:10:59

Toll vielen Dank Chris! So geht es, zumindest ich bei den "+0.5" statt dem Punkt ein Komma nutze.
Geht einwandfrei.
Jetzt muß ich mir noch eine sinnvolle Darstellung überlegen, wie ich ca. 13.000 Anrufe innerhalb von einem Jahr am besten in einem Diagramm im Tagesablauf meinetwegen zwischen 07.00 und 19.00 Uhr darstellen will. Vielleicht eine Art von Häufigkeitsverteilung... :-)
Die Daten sind ja jetzt aufbereitet dank Euch!

Gruß
Elmar


  

Betrifft: AW: Problem mit US-Datum von: Matthias L
Geschrieben am: 11.09.2014 13:42:16

Hallo

Meinst Du so?

 ABC
101:44:15PM13:44:15
201:44:15AM01:44:15

Formeln der Tabelle
ZelleFormel
C1=WENN(B1="PM";ZEIT(STUNDE(A1)+12;MINUTE(A1);SEKUNDE(A1));A1)
C2=WENN(B2="PM";ZEIT(STUNDE(A2)+12;MINUTE(A2);SEKUNDE(A2));A2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Problem mit US-Datum von: Elmar
Geschrieben am: 11.09.2014 14:08:00

Hallo,

super danke, das ging fix!
Ein kleiner Fehler entsteht bei allen Uhrzeiten zwischen 12:00 PM und 12:59PM
12:33:34 PM wird damit bspw. zu 0:33:34 also der Anruf (um Anrufauswertung geht es)
wäre dann nachts gekommen statt in der Mittagspause?
Kann man das irgendwie verhindern?
Viele herzlichen Dank
Elmar


  

Betrifft: geht das nicht nur 2 x bis 12 AM/PM von: Matthias L
Geschrieben am: 11.09.2014 14:36:37

Hallo

12:33:34 PM ? Gibts das?
Es gibt doch nur 2x12 Stunden

Dann müsste es so da stehen:
00:33:34 PM = 12:33:34 post meridiem ( nach mittag )
00:33:34 AM = 00:33:34 ante meridiem ( vor mittag ) oder eben zum merken After Midnight ;-)

Gruß Matthias


  

Betrifft: AW: geht das nicht nur 2 x bis 12 AM/PM von: Elmar
Geschrieben am: 11.09.2014 14:57:00

Hallo,
ja anscheinend schon, siehe:
http://de.wikipedia.org/wiki/Uhrzeit#Englischsprachige_L.C3.A4nder
Viele Grüße
Elmar


 

Beiträge aus den Excel-Beispielen zum Thema "Problem mit US-Datum"