Microsoft Excel

Herbers Excel/VBA-Archiv

Wennfunktion-Operatoren auslesen

Betrifft: Wennfunktion-Operatoren auslesen von: Wolfram
Geschrieben am: 07.10.2014 08:58:02

Hallo an alle, ich habe folgendes Problem:

Möchte eine einfache Wennfunktion erstellen:

Die Tabelle sieht so aus
Sollwert/Istwert/Operator/Berechnetes Feld

Ich möchte in "Berechnetes Feld" anzeigen, ob der Sollwert erfüllt ist oder nicht. Manchmal ist dies der Fall wenn der Istwert über dem Sollwert liegt, manchmal muss er darunter liegen. Ich wollte nun mit einer Wennformel arbeiten
Wenn A Operator B Dann +, Sonst -

Wie kann ich die Formel nutzen und den Operator dabei aus der Zelle Operator lesen?

Vielen Dank für ein paar Tipps

  

Betrifft: ist verschieden interpretierbar ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 09:03:16

Hallo Wolfram,

... deshalb stell doch mal einen kleinen (kopierfähigen) Datenauszug oder eine Arbeitsmappe hier ein.

interpretierbar


Gruß Werner
.. , - ...


  

Betrifft: AW: Wennfunktion-Operatoren auslesen von: RPP63
Geschrieben am: 07.10.2014 09:09:56

Hallo!
Mal sehen, ob ich das richtig verstanden habe:


Tabelle3

 ABCDE
1SollIstOpErgErläuterung
217>Wahrist 7>1?
335<Falschist 5<3?
453>Falschist 3>5?
571<Wahrist 1<7?

verwendete Formeln
Zelle Formel Bereich N/A
D2: D5=WENN(C2=">";B2>A2;A2>B2)  

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip

http://Hajo-Excel.de/tools.htm


Gruß, Ralf


  

Betrifft: AW: Wennfunktion-Operatoren auslesen von: Wolfram
Geschrieben am: 07.10.2014 10:50:07

@Ralf, ja genau so ist es gemeint und deine Formel hilft mir schon weiter, vielen Dank!


  

Betrifft: AW: Wennfunktion-Operatoren auslesen von: Daniel
Geschrieben am: 07.10.2014 10:00:24

Hi
gehe so vor:

1. schreibe in das Operatorfeld direkt das Zeichen "<" oder ">", je nach dem ob der Wert aus Spalte A grösser sein muss oder der der Wert aus Spalte B

2. Selektiere die Zelle D2 (die erste Zelle des berechneten Feldes

3. Öffne den Namensmanager (Formeln - Definierte Namen - Namensmanager) und erstelle dort mit NEU einen neuen Namen:
Name: Test
Bezieht sich auf: =AUSWERTEN(Tabelle1!A2&Tabelle1!C2&Tabelle1!B2)

4. Schreibe in die Zelle D2 die Formel =Test

mit der Funktion "Auswerten" kann man Textstrings wie Formeln berechnen lassen, wenn der Textstring wie eine Formel geschrieben ist.
leider ist die Funktion "Auswerten" eine alte Excel4Makro-Funktion, welche nur innerhalb eines Namens verwendet werden kann.

Gruß Daniel


  

Betrifft: AW: Wennfunktion-Operatoren auslesen von: Wolfram
Geschrieben am: 07.10.2014 12:50:37

Sorry, irgenwie war die Lösung von Ralf doch nicht das was ich gesucht habe. Ich versuche nochmal eine Datei hochzuladen, ich hoffe ihr versteht was ihr meint.
Schon vielen Dank für die vielen Antworten, die schon eingegangen sind.

hier die Datei https://www.herber.de/bbs/user/93002.xls


  

Betrifft: AW: Wennfunktion-Operatoren auslesen von: RPP63
Geschrieben am: 07.10.2014 13:16:09

Hi!
Entweder Du nutzt Daniels Vorschlag (denn Du kannst nicht ohne weiteres eine Verkettung auswerten),
oder Du musst die Formel erweitern:


Tabelle1

 ABCDE
1SollwertOperator-Vergleich SollIstIstwertOperator-Vergleich SollIstEgebnis
25<6Wenn 5 < 6 dann "+" sonst "-"'+
35>6Wenn 5 > 6 dann "+" sonst "-"'-
48>9 '-
59>8 '+

verwendete Formeln
Zelle Formel Bereich N/A
E2:E5=WENN((B2="<")*(A2<C2);"+";WENN((B2=">")*(A2>C2);"+";"-"))  

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip

http://Hajo-Excel.de/tools.htm


(die "*" in der Formel sind eine Verkürzung eines UND-Konstrukts)

Gruß, Ralf


  

Betrifft: AW: Wennfunktion-Operatoren auslesen von: Daniel
Geschrieben am: 07.10.2014 13:29:29

Hi
ich wüsste jetzt nich, was gegen die Lösugn von Ralf spricht.
alternativ kannst du auch diese Formel verwenden, über die WAHL-Funktion hast du auch noch die Möglichkeit ohne grossen Aufwand weitere Vergleichsoperatoren zu integrieren:
=WENN(WAHL(VERGLEICH(B2;{"<".">"};0);A2<C2;A2>C2);"+";"-")

Gruß Daniel


  

Betrifft: Das geht so wie von dir gewünscht, ... von: Luc:-?
Geschrieben am: 07.10.2014 19:44:59

…Wolfram,
mit Daniels Vorschlag oder etwas einfacher mit einer simplen VBA-pgmierten UDF (aber in beiden Fällen nur in einer .xls, .xlsm/b, falls die UDF in derselben Datei steht, bei AddIn-Standort der UDF auch .xlsx) auf Basis der vbFkt Evaluate:
ZFml in E2[:E3]:=WENN(GetFVal("="&A2&B2&C2);"+";"-") mit der UDF

Function GetFVal(ByVal FText$): GetFVal = Evaluate(FText): End Function
Gruß, Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Wennfunktion-Operatoren auslesen"