Microsoft Excel

Herbers Excel/VBA-Archiv

Formel

Betrifft: Formel von: ReSt
Geschrieben am: 13.10.2014 20:03:33

Hallo
Ich habe in Zelle A1 eine Zahl von 1-11.
In Zelle A2 möchte ich auch eine Zahl von 1-11.
Nur darf die Zahl nicht gleich sein wie in Zelle A1.
Welche Formel soll ich anwenden ?
Vergeblich bemühe ich mich um dieses Problem.
Wer kann mir einen Start geben ?

Gruss Reto

  

Betrifft: AW: Formel von: Hajo_Zi
Geschrieben am: 13.10.2014 20:05:25


Tabelle2 (2)

 A
11
2 

Daten, Gültigkeit  
Zelle Zulassen Daten Wert1 Wert2 Leere Zellen ignorieren Zellendropdown Titel Eingabemeldung Eingabemeldung Titel Fehler Fehlermeldung Typ Fehlermeldung
A2BenutzerdefiniertZwischenA2<>A1     Wahr             Stopp
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.18 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Formel von: Hajo_Zi
Geschrieben am: 13.10.2014 20:07:10

das ist falsch


  

Betrifft: AW: 2. Versuch von: Hajo_Zi
Geschrieben am: 13.10.2014 20:10:39


Tabelle2 (2)

 A
11
22

Daten, Gültigkeit  
Zelle Zulassen Daten Wert1 Wert2 Leere Zellen ignorieren Zellendropdown Titel Eingabemeldung Eingabemeldung Titel Fehler Fehlermeldung Typ Fehlermeldung
A2BenutzerdefiniertZwischen=ZÄHLENWENN(A1:A2;A2)=1     Wahr             Stopp
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.18 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Formel von: ReSt
Geschrieben am: 13.10.2014 20:23:12

Hallo Hajo
Vielleicht habe ich mich falsch ausgedrückt, aber ich möchte keine bedingte Formatierung.
Ansonsten habe ich deine Antwort falsch verstanden.
Am liebsten hätte ich eine Formel, da die Zahl automatisch entstehen muss.

Gruss Reto


  

Betrifft: AW: Formel von: Hajo_Zi
Geschrieben am: 13.10.2014 20:29:10

gut, ich habe keine bedingte Formatierung benutzt, dann trifft die Lösung ja zu.

Gruß Hajo


  

Betrifft: AW: Formel von: Daniel
Geschrieben am: 13.10.2014 20:19:09

HI

probiers mal so: =REST(A1+ZUFALLSBEREICH(0;9);11)+1

Gruß Daniel


  

Betrifft: AW: Formel von: ReSt
Geschrieben am: 13.10.2014 20:35:41

Hallo daniel
besten dank für deine Antwort.
Ich habe mir deine Formel eingebaut.
Bis jetzt funktioniert sie wunderbar. Keine Duplikate.
Was ich aber nicht verstehe ist:ZUFALLSBEREICH(0;9)

Gruss Reto


  

Betrifft: AW: Formel von: Daniel
Geschrieben am: 13.10.2014 21:15:09

Zufallsbereich(A;B)
Erzeugt Zufallszahlen als Ganzzahlen zwischen A und B.

Um deine Anforderung zu erfüllen, muss ich zu deiner Zahl eine Zahl zwischen 1 und 10 addieren und den Rest bilden. Da die Restfunktion aber das verbotene 0 zulässt, muss ich von Ergebnis von Rest noch 1 hinzuaddieren. Die diese 1 muss ich vorher vom Zufallsbereich abziehen, sonst würde ich ja Zahlen zwischen 2 und 11 hinzuaddieren und dann würde sich bei 11 dein Wert aus A1 wiederholen.

Gruß Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Formel"