Microsoft Excel

Herbers Excel/VBA-Archiv

Interpolation

Betrifft: Interpolation von: Marco
Geschrieben am: 26.10.2014 23:23:44

Hallo und Guten Abend!

Ich verzweifle gerade bei der Interpolation in Excel. Ich weiß das es dieses Thema schon oft genug gibt, leider komme ich bei der Umsetzung einfach nicht zum Ergebnis...:-(

Mein Problem:

Ich habe eine Spalte (A) in der Zahlenwerte von 40.000 bis 340.000 stehen (20.000 Schritte) und eine weitere Spalte (B) in der Werte bzw. Umrechnungskoeffizienten stehen (z.B. bei 40.000 = 1,08 oder bei 200.000 = 0,79).
Datei: https://www.herber.de/bbs/user/93386.xls

Nun erhalte ich bei meiner eigentlichen Rechnung z.B. das Ergebnis 123.785,00 und benötige dafür den entsprechenden Umrechnungskoeffizienten aus der o.g. Tabelle.

Es wäre sehr nett, wenn sich dies jemand einmal kurz ansehen könnte...

Mit freundlichen Grüßen
Marco

  

Betrifft: SVerweis von: Jürgen V.
Geschrieben am: 27.10.2014 00:34:27

Hallo Marco,

dafür reicht ein einfacher SVerweis:

=SVERWEIS(E2;A2:B17;2)

Gruß, Jürgen


  

Betrifft: AW: SVerweis von: Marco
Geschrieben am: 27.10.2014 00:43:54

Hallo Jürgen,

vielen Dank für die schnelle Antwort.

Das Problem ist nur, das ich auch diese Werte benötige, die in meiner Tabelle nicht angegeben sind.
Sollte z.b. 110.000 als Ergebnis rauskommen, müsste der Wert von 0,92 angezeigt werden, damit ich damit weiterrechnen kann.

Gruß, Marco


  

Betrifft: SVERWEIS() mit INDEX() und VERGLEICH() und ... von: neopa C (paneo)
Geschrieben am: 27.10.2014 08:16:14

Hallo Marco,

... interpolieren:

=WENNFEHLER(SVERWEIS(E2;A:B;2;);INDEX(B:B;VERGLEICH(E2;A:A))+(E2-INDEX(A:A;VERGLEICH(E2;A:A))) /(INDEX(A:A;VERGLEICH(E2;A:A)+1-ZÄHLENWENN(A:A;E2))-INDEX(A:A;VERGLEICH(E2;A:A)))*(INDEX(B:B; VERGLEICH(E2;A:A)+1-ZÄHLENWENN(A:A;E2))-INDEX(B:B;VERGLEICH(E2;A:A))))

Gruß Werner
.. , - ...


  

Betrifft: SVERWEIS-Werte interpolieren von: WF
Geschrieben am: 27.10.2014 09:23:49

siehe unsere:
http://www.excelformeln.de/formeln.html?welcher=441

Salut WF