Microsoft Excel

Herbers Excel/VBA-Archiv

Verleih

Betrifft: Verleih von: Jorgi
Geschrieben am: 28.10.2014 20:27:46

Hallo zusammen,

ich hätte mal wieder ein kleines anliegen. Hoffe ihr könnt mir helfen.
Tabelle 1 ist meine Grundliste.
Tabelle 2 sind Filme im Verleih.
Jetzt sollte per VBA alle Werte von der Artikelnummer von der Tabelle2 in Tabelle1 eingefügt werden. Aber nur die Werte Tabelle 2 K und O in die Tabelle1 P und Q
Ich habe die Zahlen mal rot markiert. Wäre so eine Abfrage möglich ?

https://www.herber.de/bbs/user/93428.xlsx

Danke und gruß
Jorgi

  

Betrifft: AW: Verleih von: fcs
Geschrieben am: 29.10.2014 06:36:21

Hallo Jorgi,

warum unbedingt eine VBA-Lösung? Es geht doch auch perFormel.
Tabelle1

 ABCDEFGHIJKLMNOPQ
1ArtikelnummerBezeichnungBestellungWer           VerleihJa
2554Edge of the Tomorrow1111111111111711

Formeln der Tabelle
ZelleFormel
P2=WENNFEHLER(SVERWEIS($A2;Tabelle2!$A:$O;11;FALSCH); "")
Q2=WENNFEHLER(SVERWEIS($A2;Tabelle2!$A:$O;15;FALSCH); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß
Franz