Microsoft Excel

Herbers Excel/VBA-Archiv

Additionsproblem

Betrifft: Additionsproblem von: Dieter Krause
Geschrieben am: 02.11.2014 14:17:45

Hallo,

ich komm nicht weiter;( brauch dringend Hilfe.

Folgendes Problem:

In A1-AX stehen Zahlen - z.B. die 1. Nun sollen die untereinander stehenden Zahlen aus A solange addiert werden, bis in B ebenfalls eine 1 erscheint.
Ist das erfüllt, dann soll das Zählen von Null beginnen!

So solls dann aussehen:

A1=leer.B1=leer..C1
A2=1....B2=leer..C2
A3=1....B3=leer..C3
A4=leer.B4=leer..C4
A5=1....B5=1.....C5=3

A6=1....B6=leer..C6
A7=leer.B7=leer..C7
A8=1....B8=1.....C8=2

LG und vielen Dank im Voraus

  

Betrifft: AW: Additionsproblem von: Hajo_Zi
Geschrieben am: 02.11.2014 14:31:40


Tabelle6

 ABC
1   
21  
31  
4   
5113
61  
7   
8112

verwendete Formeln
Zelle Formel Bereich N/A
C1=WENN(UND(A1=1;B1=1);A1;"")  
C2:C8=WENN(UND(A2=1;B2=1);SUMME($A$1:A2)-SUMME($C$1:C1);"")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.20 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Additionsproblem von: Dieter Krause
Geschrieben am: 02.11.2014 14:45:04

Hallo Hajo,

vielen, vielen Dank! Ich hab Stunden gebastelt ohne Erfolg;(
Es klappt - prima!

Gruss
Dieter