Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrere Suchkriterien und mehrere Ergebnisse

Betrifft: Mehrere Suchkriterien und mehrere Ergebnisse von: Doerk
Geschrieben am: 08.11.2014 15:58:28

Hallo Ihr Lieben,

ich bin der neue und komme ab jetzt öfter :-)

Nun aber zu meiner Herausforderung. Wir haben einen kleinen RC-Club und wollten mal Ordnung in den Bestand bringen. Dazu dachte ich ist Excel ganz gut.

Hier meine kleine Tabelle im ersten Versuch
https://www.herber.de/bbs/user/93628.xlsx

Es geht darum, dass ich nach dem Fahrzeug & Fehlteilen bzw defekten o.ä Dingen suchen möchte. Als Ergebnis stelle ich mir vor:

Suchkriterium: "Auto 2" & "fehlt"

Ergebnis: "Reifen, Motor, Akku"

Ist so etwas möglich?

Ich habe wirklich schon viel recherchiert - bin jedoch nicht wirklich fündig geworden...

Es wäre toll, wenn ihr mir helfen könnt.

VG Doerk

  

Betrifft: wird ziemlich lang von: WF
Geschrieben am: 08.11.2014 16:41:15

Hi,

in B13 folgende Arrayformel:
{=WENNFEHLER(INDEX(1:1;KKLEINSTE(WENN(INDIREKT("A"&VERGLEICH($B19;$A1:$A13;0)&":J"&VERGLEICH($B19; $A1:$A13;0))=$B21;SPALTE($A:$J));SPALTE(A1)));"") }
nach rechts kopieren

Salut WF


  

Betrifft: dito für die INDIREKT-Gegner von: WF
Geschrieben am: 08.11.2014 16:51:15

{=WENNFEHLER(INDEX(1:1;KKLEINSTE(WENN(INDEX(A:A;VERGLEICH($B19;$A1:$A13;0)):INDEX(J:J;VERGLEICH($B19; $A1:$A13;0))=$B21;SPALTE($A:$J));SPALTE(A1)));"") }

WF


  

Betrifft: da wird ja jeder zum INDEX()-Gegner ;-) ... von: neopa C (paneo)
Geschrieben am: 08.11.2014 17:36:47

Hallo WF,

... wenn Du hierbei einfach zwei "Dollars" unter den Tisch fallen lässt ;-)

Du wolltest aber sicherlich schreiben:
{=WENNFEHLER(INDEX(1:1;KKLEINSTE(WENN(INDEX($A:$A;VERGLEICH($B19;$A1:$A13;0)) :INDEX(J:J;VERGLEICH($B19; $A1:$A13;0))=$B21;SPALTE($A:$J));SPALTE(A1)));"") }

Gruß Werner
.. , - ...


  

Betrifft: AW: da wird ja jeder zum INDEX()-Gegner ;-) ... von: Doerk
Geschrieben am: 08.11.2014 17:38:31

Ah, ich werd verrückt - auf einmal funktioniert es.


  

Betrifft: AW: da wird ja jeder zum INDEX()-Gegner ;-) ... von: Doerk
Geschrieben am: 08.11.2014 17:42:08

Ich verstehe jedoch die Formel nicht wirklich.

Wofür steht "1:1"?
Warum ...Spalte(A1)... am ende der Formel?

VG


  

Betrifft: zwei Kurzzfragen zwei Kurzantworten.... von: neopa C (paneo)
Geschrieben am: 08.11.2014 17:48:52

Hallo,

... 1:1 steht für Zeile 1 und Spalte (A1) für 1, welche zur 2 und dann zur 3 ... wird, wenn die Formel nach rechts kopiert wird und damit SPALTE(A1) zu SPALTE(B1) ... .


Gruß Werner
.. , - ...


  

Betrifft: AW: zwei Kurzzfragen zwei Kurzantworten.... von: Doerk
Geschrieben am: 08.11.2014 17:53:52

Ah - da geht mir ein Licht auf.

Da dieses Datenblatt dann jedoch mit ca. 350 Modellen und etwa 40 gelisteten Teilen gefüllt wird möchte ich diese Abfrage gern in einem anderen Tabellenblatt übernehmen.
Muss dann vor "1:1" & "Spalte(A1)" jeweils "Tabelle2!"?

VG & Danke


  

Betrifft: Sergio Leone: "für ein paar Dollar mehr" von: WF
Geschrieben am: 08.11.2014 17:46:12

das war in den sechzigern - also lange vor Excel.

WF


  

Betrifft: der Name sagt mir schon was, aber ... von: neopa C (paneo)
Geschrieben am: 08.11.2014 17:52:39

Hallo WF,


... wir konnten eben damals nur "Das siebte Kreuz" etc. schauen.

Gruß Werner
.. , - ...


  

Betrifft: mit Clint Eastwood / Musik: Ennio Morricone von: WF
Geschrieben am: 08.11.2014 18:23:31




  

Betrifft: Werner, du hattest jetzt doch ... von: Rudi Maintaire
Geschrieben am: 10.11.2014 16:00:26

Hallo,
... 25 Jahre Zeit, diese eklatante Lücke zu schließen. ;-)

Gruß
Rudi


  

Betrifft: na, ja ... von: neopa C (paneo)
Geschrieben am: 10.11.2014 18:37:36

Hallo Rudi,

... wo ist nur die Zeit hin, schenke mir doch nochmal die Zeit oder ich schenk mir diese ;-)


Gruß Werner
.. , - ...


  

Betrifft: es geht aber auch ganz ohne ... von: neopa C (paneo)
Geschrieben am: 08.11.2014 17:44:40

Hallo WF,

... und dann auch viel kürzer:

{=WENNFEHLER(INDEX(1:1;KKLEINSTE(WENN(($A3:$A15=$B19)*($A3:$J15=$B21);SPALTE($A1:$J1));SPALTE(A1))); "") }

Gruß Werner
.. , - ...


  

Betrifft: hab ich doch ne Macke gefunden von: WF
Geschrieben am: 08.11.2014 18:06:48

Hi Werner,

wenn irgendwo in der Tabelle (außer in der Suchzeile) ne Fehlermeldung steht, gibt's bei Dir kein Ergebnis.

WF


  

Betrifft: mit WENNEN ist's OK von: WF
Geschrieben am: 08.11.2014 18:11:36

{=WENNFEHLER(INDEX(1:1;KKLEINSTE(WENN($A3:$A15=$B19;WENN($A3:$J15=$B21;SPALTE($A1:$J1)));SPALTE(A1))) ; "") }

WF


  

Betrifft: AW: mit WENNEN ist's OK von: Doerk
Geschrieben am: 08.11.2014 18:14:39

Könnt ihr mir hier noch einmal helfen?

Da dieses Datenblatt dann mit ca. 350 Modellen und etwa 40 gelisteten Teilen gefüllt wird möchte ich diese Abfrage gern in einem anderen Tabellenblatt übernehmen.
Muss dann vor "1:1" & "Spalte(A1)" jeweils "Tabelle2!"?

VG & Danke


  

Betrifft: AW: Mehrere Suchkriterien und mehrere Ergebnisse von: fcs
Geschrieben am: 08.11.2014 18:32:56

Hallo Doerk,

ich würde die Daten in etwas anderer Form erfassen.

Eine Tabelle für die Modelle.
Eine 2. Tabelle für die Modelle/Teile, deren Status erfasst werden soll.

Eine Übersicht und eine Auswertung, die die Daten aus den anderen Daten auswerten.

In einem weiteren Blatt werden die Auswahlwerte für Drop-Down-Auswahlen in den Eingabeblättern erfasst.

Bei dieser Art des Tabellenaufbaus lassen sich die Daten zu Modellen und Teilen fast beliebig erweitern ohne dass die Übersicht verloren geht.

Hier deine Datei entsprechend angepasst.
https://www.herber.de/bbs/user/93630.xlsx

Gruß
Franz


  

Betrifft: AW: Mehrere Suchkriterien und mehrere Ergebnisse von: Doerk
Geschrieben am: 08.11.2014 18:41:27

Hej Franz,

danke für deine Arbeit.

(Ich werde meinen Kenntnisstand für Excel von gut auf NAJA ändern) :)

Das ist glaube ich schon etwas zu komplex - für mich.

Die andere Variante gefällt mir schon ganz gut. Nur leider bekomme ich es nicht hin diese Formel in einem anderen Tabellenblat zu etablieren.

Das Ergebnis ist dann immer "Produkt"

{=WENNFEHLER(INDEX(Tabelle2!1:1;KKLEINSTE(WENN((Tabelle2!$A3:$A15=$B19)*(Tabelle2!$A3:$J15=$B21); SPALTE(Tabelle2!$A1:$J1));SPALTE(Tabelle2!A1))); "") }

Was mache ich falsch?


  

Betrifft: AW: Mehrere Suchkriterien und mehrere Ergebnisse von: Doerk
Geschrieben am: 08.11.2014 18:50:35

Ich ziehe meine Frage zurück - das funktioniert jetzt soweit.

Da wir hier jedoch von bis zu 40 Fehlteilen reden - ist es eventuell möglich die Auflistung auch untereinander vorzunehmen?


VG & Danke vielmals


  

Betrifft: dann wechseln die die Dollars die "Taschen" ... von: neopa C (paneo)
Geschrieben am: 08.11.2014 18:55:00

Hallo Doerk,

... dann so:
[=WENNFEHLER(INDEX(Tabelle2!$1:$1;KKLEINSTE(WENN((Tabelle2!A$3:A$15=B$19)*(Tabelle2!A$3:J$15=B$21);SPALTE(A1:J1));ZEILE(A1)));"")}

Gruß Werner
.. , - ...


  

Betrifft: AW: dann wechseln die die Dollars die "Taschen" ... von: Doerk
Geschrieben am: 09.11.2014 08:15:17

Danke Werner!


 

Beiträge aus den Excel-Beispielen zum Thema "Mehrere Suchkriterien und mehrere Ergebnisse"