Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixformel

Betrifft: Matrixformel von: Peter
Geschrieben am: 21.11.2014 14:03:33

Guten Tag

In meiner Tabelle frage ich in Zelle I3 das Total aller Werte pro fortlaufende Nummer, das 43 übersteigt ab.
Dazu habe ich mir zwei Hilfsspalten (C + D) angelegt.

Ich suche nach einer Formel, mit der ich diese den Summe 43 übersteigenden Werte aufsummieren kann, ohne dass die Spalten C + D gebraucht werden.

Gruss, Peter

https://www.herber.de/bbs/user/93943.htm
https://www.herber.de/bbs/user/93944.xlsx

  

Betrifft: ja und nein ... von: neopa C (paneo)
Geschrieben am: 21.11.2014 14:20:49

Hallo Peter,

... die Spalte C bedarf es nicht. Die Hilfsspalte D würde ich belassen.
Die Werte dafür ermittelst Du ab D4 wie folgt:

=WENN(A5>A4;MAX(B4+B3-H$3;0);"")

Und dann die Matrixformel (ohne Erfordernis der spez. Eingabe) in I3:
=SUMME(INDEX(D:D;VERWEIS(9;1/(A1:A99=F3);ZEILE(A:A))):INDEX(D:D;VERWEIS(9;1/(A1:A99=G3);ZEILE(A:A))))

Gruß Werner
.. , - ...


  

Betrifft: AW: ja und nein ... von: Peter
Geschrieben am: 24.11.2014 10:20:17

Hallo Werner
Besten Dank.
Gruss, Peter


 

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel"