Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellenabfrage

Betrifft: Tabellenabfrage von: Torsten
Geschrieben am: 23.11.2014 09:00:18

Hallo Forum,
Komme nicht richtig weiter.
Vielleicht könnt Ihr mir weiterhelfen.
Habe eine Besucherliste erstellt.
Nun möchte ich gern in I2 einen Namen eingeben und in
Spalte J und K dann das Ergebnis.

Beispieltabelle:
https://www.herber.de/bbs/user/93959.xlsx

Wünsche noch einen schönen Sonntag

Gruß Torsten

  

Betrifft: Dein Tabellenaufbau... von: {Boris}
Geschrieben am: 23.11.2014 10:33:05

Hi Torsten,

...ist nicht gut, auch die Verbundzellen sind suboptimal.
Kannst Du etwas mehr zu Deinem Vorhaben sagen?

VG, Boris


  

Betrifft: AW: Dein Tabellenaufbau... von: Torsten
Geschrieben am: 23.11.2014 11:09:11

Hallo Boris,
danke der Nachfrage.
Hatte mir schon gedacht, das der Aufbau nicht besonders gut ist, aber ging für mich nicht anders.
Lösung von Tino klappt.
Wünsche dir noch einen schönen Sonntag.
Gruß Torsten


  

Betrifft: AW: Tabellenabfrage von: Tino
Geschrieben am: 23.11.2014 10:44:05

Hallo,
habe es mal so versucht.

https://www.herber.de/bbs/user/93960.xlsx


Gruß Tino


  

Betrifft: AW: Tabellenabfrage von: Torsten
Geschrieben am: 23.11.2014 11:06:01

Hallo Tino,
Danke, so wollte ich es gern haben.
wünsche noch einen schönen Sonntag.
Gruß Torsten


  

Betrifft: alternativ eine hilfsspaltenfreie Lösung ... von: neopa C (paneo)
Geschrieben am: 23.11.2014 12:01:32

Hallo Torsten,

... weil ich sie vorhin nun mal aufgestellt hatte.

 BCDEFGHIJK
2      EingabeTorsten 1  
3        Dez. 14Elsa
4        ( 1 Woche ) 
5        Dez. 14Lore
6        ( 3 Woche ) 
7        Jan. 15Hedwig
8        ( 31 Woche ) 
9        Feb. 15Dietmar
10        ( 33 Woche ) 
11          
12 Elsa DietmarHedwig Lore     
13Dez. 14Torsten 1Torsten 2Torsten 3Torsten 4     
14( 1 Woche )     
15Dez. 14Torsten 5Torsten 6Torsten 7Torsten 1     
16( 3 Woche )     
17Jan. 15Torsten 2Torsten 3Torsten 4Torsten 5     
18( 1 Woche )     
19Jan. 15Torsten 6Torsten 7Torsten 1Torsten 2     
20( 31 Woche )     
21Feb. 15Torsten 3Torsten 4Torsten 5Torsten 6     
22( 1 Woche )     
23Feb. 15Torsten 7Torsten 1Torsten 2Torsten 3     
24( 33 Woche )     
25          

Formeln der Tabelle
ZelleFormel
J3{=WENN(ZEILE(A1)>2*ZÄHLENWENN(C$13:F$29;I$2); "";INDEX(B:B;KKLEINSTE(WENN(C$13:F$29=I$2;ZEILE(A$13:A$29)+REST(ZEILE(A2); 2)); REST(ZEILE(A1); 2)+KÜRZEN(ZEILE(A1)/2))))}
K3{=WENNFEHLER(INDEX($12:$12;MIN(WENN((C$13:F$29=I$2)*(ZEILE(B$13:B$29)=(KKLEINSTE(WENN((B$13:B$29=J3)*(C$13:F$29=$I$2); ZEILE(A$13:A$29)); ZÄHLENWENN(J$3:J3;J3)))); SPALTE(C1:F1)))); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: alternativ eine hilfsspaltenfreie Lösung ... von: Torsten
Geschrieben am: 23.11.2014 22:24:54

Hallo Werner,
danke das du mir wieder geholfen hast.
Wünsche noch einen schönen Abend.
Gruß Torsten