Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixformel

Betrifft: Matrixformel von: Christian
Geschrieben am: 24.11.2014 12:09:35

Hallo zusammen,
ich habe in der angehängten Datei eine Tabelle mit einer Matrixformel erstellt, die die Anzahl der Daten aus den rosanen Zellen, die in dem jeweiligen Monat liegen, ausgibt. Allerdings gibt die Datei für Jan15 immer eine 100 aus, obwohl keine Werte eingegeben bzw. eingelesen wurden. Ich möchte gerne, dass die Tabelle erst Zahlen ausgibt, wenn auch Werte vorhanden sind.

Kann mir da bitte jemand einen Tipp geben?

https://www.herber.de/bbs/user/93979.xlsx

Vielen Dank im Voraus.

Gruß,
Christian

  

Betrifft: AW: Matrixformel von: AndrRo
Geschrieben am: 24.11.2014 12:19:27

Hallo Christian,

ändere die Tormel wie folgt.

Für Zelle T5 (keine Matrixformel):
=SUMMENPRODUKT((ISTLEER($C$16:$C$115)=FALSCH)*(MONAT($C$16:$C$115)=MONAT(S5)))

gruss

Andreas


  

Betrifft: AW: Matrixformel von: Christian
Geschrieben am: 24.11.2014 12:25:50

Hallo Andreas,
danke für die schnelle Antwort. Funktioniert einwandfrei mit deiner Formel. Habe das für alle Zellen in der rechten Tabelle abgeändert.

Gruss,

Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel"