Microsoft Excel

Herbers Excel/VBA-Archiv

Autovervollständigen

Betrifft: Autovervollständigen von: guffels
Geschrieben am: 09.04.2015 22:49:48

Hallo zusammen,

ich habe in einer Tabelle einen Bereich, in dem ein Benutzer Namen aus einer Auswahlliste eingeben kann, aber auch andere. Um sozusagen dem Benutzer auch die Funktion Autovervollständigen anzubieten, habe ich die Namen oberhalb des Bereiches eingegben. Im linken Feld funzt das genau so wie ich will, in der rechten Spalte funktioniert es leider nicht. Ich habe mittlerweile vieles versucht; Zellen formatieren, Liste neu eingeben, etc.. Ohne Erfolg.
Ich hoffe, hier kann mir jemand aufzeigen, wo der Fehler liegt!?!

Im Voraus schon mal vielen Dank für Eure Mühen!

https://www.herber.de/bbs/user/96988.xls

Gruß guffels

  

Betrifft: AW: Autovervollständigen von: Matze Matthias
Geschrieben am: 09.04.2015 22:59:46

Hallo guffles (Vorname bitte),

kann deinem Anliegen nicht folgen , bei mir funktionieren Beide Seiten.

Gib mal rechts ein T ein du wirst merken das sich nix tut, gib nun ein "u" ein du siehst der Vorschlag erscheint.
Das liegt daran das 2 Namen mit T beginnen.
Schlimmer wird's wenn es mehrere Nachnamen Zb Mustermann gibt, Klaus, Peter Karsten,
dann muss der Musterman eben komplett geschrieben werden.

Gruß Matze


  

Betrifft: AW: Autovervollständigen von: guffels
Geschrieben am: 11.04.2015 14:17:18

Hallo Matze,

bin leider erst gerade dazu gekommen, mich noch mal mit dem Thema zu beschäftigen.
Bei mir zuhause (Excel 2013) und auf der Arbeit (Excel 2003) ist es so, dass ich im linken Bereich z.B. ein "T" eingebe und sich noch nichts tut, so bald ich aber zusätzlich noch ein "u" oder "e" eingebe, schlägt Excel mir den entsprechenden Namen vor und ich kann ihn mit Eingabe bestätigen. Bei einem "F" passiert dies schon sofort, da es nur einen Namen mit dem Anfangsbuchstaben "F" gibt. Im rechten Bereich passiert eben genau das nicht.
Ich verstehe Deine Antwort im Bezug auf das "u" auch nicht, da weder in der linken noch in der rechten Spalte ein Name mit "U" am Anfang existiert...

Gruß Michael


  

Betrifft: Profi bitte ansehen ! Autovervollständigen von: Matze Matthias
Geschrieben am: 11.04.2015 18:02:01

Hi Michael,

mit "Tu..." war ja auch so gemeint wie du es geschrieben hast, allerdings hab ich den unteren gelb markierten Bereich erst gar nicht gesehen und dachte es geht um den blauen Bereich. Da geht es ja.


AB ZEILE 64 :


Ich habe jetzt leider nix feststellen können woran dieses Auftreten liegen kann und stelle dies bezüglich den Beitrag auf "offen" damit einer der Profis sich der Sache annimmt.

Ich hatte dann die Spalten alle getrennt und die verbundenen Zellen aufgelöst aber das Ergebnis war das gleiche :-( https://www.herber.de/bbs/user/97028.xls

Ich bin nun selber neugierig woran das wieder liegen kann.


Gruß Matze


  

Betrifft: AW: Profi bitte ansehen ! Autovervollständigen von: ChrisL
Geschrieben am: 13.04.2015 15:51:24

Hi

In Spalte B gibt es Nummern. Wenn du diese in Spalte P ebenfalls einträgst, dann funktioniert es.

So richtig erklären kann ich das Verhalten auch nicht. Auf die Idee hat mich folgender Artikel (Punkt 5) gebracht:
http://www.computerwissen.de/office/excel/artikel/was-sie-bei-beim-einsatz-der-funktion-autovervollstaendigen-in-ihren-excel-tabellen-beachten-sollten.html

Überprüfen Sie die Position der aktiven Zelle: Diese muss sich innerhalb des Datenbereichs befinden. Der Datenbereich ist der Zellbereich, der alle Daten enthält und zudem von leeren Zellen oder Tabellenrändern begrenzt ist. Excel vervollständigt Einträge innerhalb des Datenbereichs und in der leeren Zeile unterhalb des Datenbereichs. Angenommen, der Datenbereich erstreckt sich über den Zellbereich A1:C20: Excel vervollständigt dann alle Einträge, die in eine Zelle innerhalb von A21 bis C21 eingegeben werden, selbst dann, wenn die darüberliegende Zelle leer ist. Einträge, die in die Zellen A22 bis C22 eingegeben werden, werden nicht vervollständigt.

cu
Chris


  

Betrifft: AW: Profi bitte ansehen ! Autovervollständigen von: guffels
Geschrieben am: 13.04.2015 22:00:04

Hallo Chris,

tatsächlich es funzt! Hatte schon fast aufgegeben. Ich muss zwar zugeben, dass ich auch nicht ganz genau verstehe, wieso es daran lag, aber Hauptsache es funktioniert.

Vielen Dank noch mal !!!!

Gruß Michael