Tabelle umsortieren

Bild

Betrifft: Tabelle umsortieren
von: Christian
Geschrieben am: 31.05.2015 22:42:37

Guten Abend,
ich möchte Euch um einen Rat fragen.
Ich habe eine Tabelle, die ist in etwa so aufgebaut
Spalte A/B
A D
A E
A F
B G
B H
B I
B J
C K
C L
C M
C N
C O
daraus soll werden
A D E F
B G H I J
C K L M N O
die Tabelle ist nach Spalte A sortiert, die Texte in Spalte A können zwischen 1 und 17mal vorkommen.
Hat da jemand eine Idee?
Viele Grüße und Danke
Christian

Bild

Betrifft: AW: Tabelle umsortieren
von: Daniel
Geschrieben am: 31.05.2015 23:01:26
Hi
1. in C die Formel: =B1&Wenn(A1=A2;";"&C2;"")
2. die Formel nach unten ziehen, kopieren und als Wert einfügen
3. Spalte B löschen
4. Daten - Datentools - Duplikate entfernen auf die Spalten A:B anwenden und Spalte A als Kriterium verwenden
5. Daten - Datentools - Text in Spalten auf die Spalte B anwenden und das Trennzeichen aus der Formel verwenden (;)
Gruß Daniel

Bild

Betrifft: AW: Tabelle umsortieren
von: Christian
Geschrieben am: 31.05.2015 23:11:57
Hallo Daniel,
ich glaube ich hab mich leider missverständlich ausgedrückt.
Das Ziel soll jeweils eine eigene Zelle sein, nur halt statt vorher horizontal, jetzt vertikal.
Gruß
Christian

Bild

Betrifft: AW: Tabelle umsortieren
von: Daniel
Geschrieben am: 31.05.2015 23:51:44
nö, ich hab dich da schon richtig verstanden.
hast du es ausprobiert mit allen 5 Schritten?
Gruß Daniel

Bild

Betrifft: AW: Tabelle umsortieren
von: Sepp
Geschrieben am: 31.05.2015 23:06:18
Hallo Christian,
Tabelle1

 ABCDEFGHIJKL
1Wert 1Wert 2  Wert 1       
2AD  ADEF    
3AE  BGHIJ   
4AF  CKLMNO  
5BG          
6BH          
7BI          
8BJ          
9CK          
10CL          
11CM          
12CN          
13CO          
14            

Formeln der Tabelle
ZelleFormel
E2{=INDEX($A$2:$A$100;MIN(WENN(A2:A100<>"";ZEILE(2:100))))}
F2{=WENN(ZÄHLENWENN($A$2:$A$100;$E2)<SPALTE(A$1); "";INDEX($B$2:$B$100;KKLEINSTE(WENN($A$2:$A$100=$E2;ZEILE($1:$17)); SPALTE(A$1))))}
E3{=WENN(SUMME(ZÄHLENWENN(A$2:A$100;E$2:E2))>=ANZAHL2(A$2:A$100); "";INDEX($A$2:$A$100;VERGLEICH(1;(ZÄHLENWENN(E$2:E2;A$2:A$100)=0)*(A$2:A$100<>""); 0)))}
F3{=WENN(ZÄHLENWENN($A$2:$A$100;$E3)<SPALTE(A$1); "";INDEX($B$2:$B$100;KKLEINSTE(WENN($A$2:$A$100=$E3;ZEILE($1:$17)); SPALTE(A$1))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: es gäb auch eine Formellösung ohne {} ...
von: der neopa C
Geschrieben am: 01.06.2015 14:45:47
Hallo Christian,
... sollte es Dich noch interessieren, dann melde Dich einfach nochmal.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: es gäb auch eine Formellösung ohne {} ...
von: Christian
Geschrieben am: 01.06.2015 19:42:03
Hallo Werner,
gerne, immer her damit, aber ist das nicht am einfachsten per Makro zu lösen?
Gruß
Christian

Bild

Betrifft: am einfachsten ist sicherlich die Lösung, ...
von: der neopa C
Geschrieben am: 02.06.2015 11:27:56
Hallo Christian,
... die Dir Daniel angeboten hat. Eine VBA-Lösung ist nur dann einfacher, wenn sie denn schon erstellt ist ;-) Ich bevorzuge für mich eben vorrangig Formellösungen. Mein Angebot war nur als Alternative zu Sepps Vorschlag gedacht.
Etwas Irritierend finde ich nur Deine Antwort auf Daniels Vorschlag: "ich glaube ich hab mich leider missverständlich ausgedrückt. Das Ziel soll jeweils eine eigene Zelle sein, nur halt statt vorher horizontal, jetzt vertikal" Was meinst Du denn nun damit? Bei einer Formellösung ala Sepp und mir, müsstest Du die Spalten A:B anschließend noch ausblenden.
Noch interessiert?
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Tabelle umsortieren"