Schichtplan mit Excel und VBA(?)

Bild

Betrifft: Schichtplan mit Excel und VBA(?)
von: Paul
Geschrieben am: 08.06.2015 19:12:16

Guten Abend,
ich bin gerade dabei einen Schichtplan zu bauen. In diesem Plan werden die verschiedenen Schichten per Kürzel z.B. (AB1,AB2,AB3,BC1,BC2,BC3) sowie die Zeiten eingetragen. Die Frage die ich mir stelle ist folgende. Ist es zu bewerkstelligen dass ich die Arbeitszeiten für jedes Schichtkürzel in einer Variable festlegen kann und diese dann z.b. so nutzen kann:
Spalte A (Schichtkürzel)
Spalte B Namen (werden händisch eingetragen)
Spalte C Schichtbeginn |Selbe Zeile wie Schichtkürzel in Spalte A |(Autofüllung über die Erkennung des Schichtkürzels in Spalte A)
Spalte D Schichtende |Selbe Zeile wie Schichtkürzel in Spalte A | (Autofüllung über die Erkennung des Schichtkürzels in Spalte A)
Ich möchte ganz ehrlich sein, ich erwarte mir hier keine Komplettlösung meines "Problems" da ich mir ziemlich sicher bin dass eine Lösung mit Hilfe von VBA möglich ist, allerdings sicherlich sehr aufwändig. Ich wäre daher über ein paar Lösungsansätze & Tipps schon höchst erfreut! :)

Bild

Betrifft: AW: Schichtplan mit Excel und VBA(?)
von: Hajo_Zi
Geschrieben am: 08.06.2015 19:13:45
benutze Sverweis()


Bild

Betrifft: AW: Schichtplan mit Excel und VBA(?)
von: Werner
Geschrieben am: 09.06.2015 00:43:56
Hallo Paul,
für mein Beispiel stehen in Zeile 1 Überschriften, Daten ab Zeile 2. In Spalte G9 - I9 sind die Schichtkürzel und die Start und Ende Zeiten hinterlegt.

G6	H6	I6	
Hinterlegte Schichtzeiten			
Schicht	Beginn	Ende	
AB1	12:00	18:00	
AB2	13:00	19:00	
AB3	14:00	20:00	
BC1	15:00	21:00	
BC2	16:00	22:00	
BC3	17:00	23:00	
			
			
	Die Spalten kannst du ja ggf. ausblenden		
oder auf einem gesonderten Blatt hinterlegen			
Formeln
in C2:=WENNFEHLER(SVERWEIS(A2;G$9:I$14;2);"")
in D2:=WENNFEHLER(SVERWEIS(A2;G$9:I$14;3);"")
und so weit nach unten ziehen wie du es brauchst.
Gruß Werner

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Schichtplan mit Excel und VBA(?)"