VBA Anzahl Begriffe je Monat

Bild

Betrifft: VBA Anzahl Begriffe je Monat
von: Krycho89
Geschrieben am: 22.06.2015 15:05:45

Hallo Forumsmitglieder,
ich habe ein Problem an dem ich nicht weiter kommen.
Ich würde gerne die Anzahl der Werte von einem Datenblatt anhand eines Zeitintervalls und Begriffen herausfinden.
Das Zeitintervall befindet sich immer zwischen zwei Monaten und ist zum besseren Verständnis als File beigefügt.
https://www.herber.de/bbs/user/98373.xlsm
Das mit den Zeitintervallen habe ich hinbekommen, die Schwierigkeit habe ich mit den zu filternden Begriffen die in einem Array stehen.

Suchbegriffe(1) = Array("*ausrund*", "*blend *", "*blending*")
Suchbegriffe(2) = Array("*deviation*", "*abweichung*", "*gaps*", "*lücken*")
...

Kann mir jemand helfen, wie der code aussehen müsste um die Anzahl der Begriffe pro Monat herauszufinden?
Viele Grüße und Danke!

Bild

Betrifft: AW: VBA Anzahl Begriffe je Monat
von: Crizz
Geschrieben am: 22.06.2015 18:39:04
Kann mir hierbeiniemandhelfen?
Gruß Chris

Bild

Betrifft: AW: VBA Anzahl Begriffe je Monat
von: Crizz
Geschrieben am: 22.06.2015 18:39:35
Kann mir hierbeiniemandhelfen?
Gruß Chris

Bild

Betrifft: Dir kann durchaus geholfen wdn, nur hat wohl ...
von: Luc:-?
Geschrieben am: 22.06.2015 20:55:46
…nicht jeder Lust dazu und außerdem ist es ja etwas komplizierter, Crizz Krycho!
Als FmlLösung könnte das so aussehen:

 GHIJKL
1mod Monatklassischausrund blend blendingdeviation abweichung gaps lücken
2Januar0000 
3Februar0000 
4März300300 
5April300300 
6Mai310310 
7Juni300300 
8Juli8282 
9August0000 
10September0000 
11Oktober0000 
12November0000 
13Dezember0000 
14H2[:H13]:=SUMMENPRODUKT((MONAT($C$2:$C$140)=ZEILEN($1:1))*(LÄNGE($F$2:$F$140)>LÄNGE(WECHSELN(
15                    WECHSELN(WECHSELN(KLEIN($F$2:$F$140);"ausrund";"");"blend";"");"blending";""))))
16I2[:I13]:=SUMMENPRODUKT((MONAT($C$2:$C$140)=ZEILEN($1:1))*(LÄNGE($F$2:$F$140)>LÄNGE(WECHSELN(WECHSELN(
17                WECHSELN(WECHSELN(KLEIN($F$2:$F$140);"deviation";"");"abweichung";"");"gaps";"");"lücken";""))))
18J2:J13: {=SUMME(INDEX((MONAT($C2:$C140)=SPALTE($A:$M))*(LÄNGE(" "&$F2:$F140)>LÄNGE(INDEX(
19                SplitVx(" "&KLEIN($F2:$F140);VSplit(J$1);-1);;1)));0;ZEILE(1:12)))}
20K2:K13: {=SUMME(INDEX((MONAT($C2:$C140)=SPALTE($A:$M))*(LÄNGE(" "&$F2:$F140)>LÄNGE(INDEX(
21                SplitVx(" "&KLEIN($F2:$F140);VSplit(K$1);-1);;1)));0;ZEILE(1:12)))}
Anmerkung: Es könnte natürlich sein, dass du das etwas anders gemeint hast, aber dann musst du es auch genauer beschreiben!
Die beiden linken Spalten enthalten eine klassische Lösung nur mit Xl-StandardFktt, die rechten eine mit UDFs, die im Archiv zu finden sind (bei Interesse und Nichtfinden der passenden Version kann ich die Links angeben).
Anderenfalls musst du wohl mit deinem Pgm jede Zelle durchgehen und einen pro Monat neu beginnenden Zähler mitlaufen lassen, der die Zelle nur zählt, wenn mit Hilfe des Like-Operators eine Übereinstimmung mit einem der Suchbegriffe erzielt wurde. Dabei kannst du dich ggf am Verhalten der Fmln orientieren.
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: AW: Dir kann durchaus geholfen wdn, nur hat wohl ...
von: Krycho89
Geschrieben am: 25.06.2015 14:40:04
Hallo Luc :-?,
entschuldige die verspätete Antwort, aber da ich mir eine Lösung mit VBA geschrieben habe, wollte ich erst das Endresultat hier posten.
Die Lösung funktioniert mit einem zweidimensionalem Array.
Die Datei mit der Lösung füge ich auch bei.
https://www.herber.de/bbs/user/98476.xlsm
Viele Grüße und Danke

 Bild

Beiträge aus den Excel-Beispielen zum Thema "VBA Anzahl Begriffe je Monat"