Index, Vergleich o.ä. ??

Bild

Betrifft: Index, Vergleich o.ä. ??
von: Hubert
Geschrieben am: 21.07.2015 17:19:25

Hallo Excelfreunde
Ich habe folgendes Problem.
Ich will von Tabelle1 Werte nach Tabelle0 rüber holen.
Es müssen in der Formel aber 2 verschiedene Kriterien abgefragt werden
und wenn diese mit der Tabelle 1 übereinstimmen, kann der dort stehende Wert
rüber geholt werden.
Ich komme im Moment da überhaupt nicht hinter.
Vielleicht kann mir einer von euch helfen.
Eine Beispieltabelle habe ich hochgeladen.
https://www.herber.de/bbs/user/98981.xls
Vielen Dank schon jetzt.
Hubert

Bild

Betrifft: Doppelvergleich
von: WF
Geschrieben am: 21.07.2015 17:38:05
Hi,
=INDEX(A1:H9;VERGLEICH("B";A1:A9;0);VERGLEICH(D2;A2:H2;0))
WF

Bild

Betrifft: ja; mit INDEX() und VERGLEICH() ...
von: der neopa C
Geschrieben am: 21.07.2015 17:41:23
Hallo Hubert,
... folgende Formel in B4: nach rechts und unten ziehend kopieren:
Tabelle0

 BCDEFGH
201.01.1502.01.1503.01.1504.01.15  Kennziffer
3       
4  111,00   5
5  222,00   6
6 333,00    7
7   444,00  8
8       

Formeln der Tabelle
ZelleFormel
B4=WENN(ISTNV(VERGLEICH(B$2;Tabelle1!$C:$C;)*VERGLEICH($H4;Tabelle1!$J:$J;))+(INDEX(Tabelle1!$C:$C;VERGLEICH($H4;Tabelle1!$J:$J;))<>B$2); "";INDEX(Tabelle1!$F:$F;VERGLEICH($H4;Tabelle1!$J:$J;)))


Tabelle1

 BCDEFGHIJ
1 Datum  Euro   Kennziffer
2 03.01.15  111,00   5
3 03.01.15  222,00   6
4 02.01.15  333,00   7
5 04.01.15  444,00   8
6         


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Index, Vergleich o.ä. ??
von: Luschi
Geschrieben am: 21.07.2015 17:52:45
Hallo Hubert,
oder mittels Summenprodukt(...) und ein bischen Formatierung.
https://www.herber.de/bbs/user/98983.xls
Gruß von Luschi
aus klein-Paris

Bild

Betrifft: hier ist SUMMENPRODUKT() am geeignetsten ...
von: der neopa C
Geschrieben am: 22.07.2015 15:51:08
Hallo Luschi,
... weil wie im konkreten Fall es ja wirklich auch Werte für gleiche Kennziffern für den gleichen Tag geben kann und die Formel dann auch gleich die Summenbildung realisiert. Ich hab mich dazu sehr von der Fragestellung leiten lassen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Index, Vergleich o.ä. ??
von: Hubert
Geschrieben am: 21.07.2015 23:53:30
Hallo WF,
Hallo Werner
Hallo Luschi
Vielen lieben Dank für eure Antworten.
Ich für meinen Teil hatte total ein Brett vor dem Kopf, aber
mit Hilfe von euch komme ich jetzt weiter und sehe wieder klarer.
Die Formeln passen einwandfrei.
Nochmal Dank für eure Mühe und die schnellen Antworten
Schönen Gruß
Hubert

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Index, Vergleich o.ä. ??"