mehrere Felder aus Zeile ausgeben

Bild

Betrifft: mehrere Felder aus Zeile ausgeben
von: Andreas
Geschrieben am: 23.07.2015 14:21:22

Hallo,
folgendes Problem:
Meine Tabelle:
AK 1 \ AK2 \ AK3 \ AK4\ AK5 \ Runde 1 \ Runde 2 \ Runde 3
off \ ja \ ja \ off \ ja
off \ off \ ja \ ja \ ja
. . . . .
. . . . .
. . . . .
In den Feldern unter Runde 1 \ Runde 2 \ Runde 3 sollte in Zeile 2 und folgende immer die Überschrift der "ja-Felder" erscheinen. Es gibt immer 3 ja´s und 2 nein´s, nur die Verteilung ist anderes.
Ich hoffe ich habe das Problem richtig beschrieben, vielen Dank für Eure Hilfe.
reidi

Bild

Betrifft: INDEX() und AGGREGAT() ...
von: der neopa C
Geschrieben am: 23.07.2015 14:26:15
Hallo reidi,
... folgende Formel nach rechts und unten ziehen kopieren:

=WENNFEHLER(INDEX($1:$1;AGGREGAT(15;6;SPALTE(1:1)/($A2:$F2="ja");SPALTE(A1)));"")

Gruß Werner
.. , - ...

Bild

Betrifft: AW: INDEX() und AGGREGAT() ...
von: Andreas
Geschrieben am: 23.07.2015 14:44:08
Hallo Werner,
es erscheint die Warnung "Zirkelbezug", aber es funktioniert!
Vielen Dank.
reidi

Bild

Betrifft: wo und wie hast Du die Formel eingesetzt? ...
von: der neopa C
Geschrieben am: 23.07.2015 14:56:49
Hallo reidi,
... auch wenn die Formeldefinition den Anschein erweckt, dürfte normalerweise keine Zirkelbezugswarung kommen. Jedenfalls kam bei mir bei gleichartigen Anwendungen noch nie eine.
Kannst Du mir den diesbzgl. relevanten Teil Deiner Datei als Auszugsdatei hoch laden. Interessiert mich und würde der Ursache auf den Grund gehen wollen.
Gruß Werner
.. , - ...


Bild

Betrifft: AW: wo und wie hast Du die Formel eingesetzt? ...
von: Andreas
Geschrieben am: 23.07.2015 16:04:12
Hallo Werner,
hier der Link zu dem Auszug meiner Tabelle:
https://www.herber.de/bbs/user/99040.xlsx
Ich habe per pdf Formular eine Abfrage für eine Tagung gemacht (liegt als csv vor). Die Teilnehmer können dort 3 aus 5 Vorträgen wählen.
Ich hätte gerne eine "übertragbare" Lösung, falls ich bei der nächsten Veranstaltung zum Beispiel 4 aus 7 Vorträgen habe.
Nochmals vielen Dank, dass Du Dich meinem Problem annimmst.
Viele Grüße
reidi

Bild

Betrifft: in Deiner Datei ist keine Formel ...
von: der neopa C
Geschrieben am: 23.07.2015 16:19:23
Hallo reidi,
... und somit kann ich Deine vorhin getroffene Feststellung noch immer nicht nachvollziehen.
Bezogen auf diese Datei hätte die Formel für N6 wie folgt angepasst werden müssen:
=WENNFEHLER(INDEX($5:$5;AGGREGAT(15;6;SPALTE(1:1)/($H6:$M6="ja");SPALTE(A1)));"")
und diese Formel nach rechts und unten ziehend kopieren. Bei mir (habe auch Excel 2010) kommt da jedenfalls kein Zirkelbezug.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: in Deiner Datei ist keine Formel ...
von: reidi
Geschrieben am: 24.07.2015 07:57:49
Hallo Werner,
vielen Dank, der Zirkelbezug ist weg.
Ausgegeben wird jetzt aber ab Spalte A, also beginnend bei "Anrede".
Außerdem habe ich die Formel nicht verstanden, sodass ich sie nicht auf eine neue Veranstaltungen mit z.B. 4 aus 7 wählbaren Vorträgen anwenden könnte.
Viele Grüße
reidi

Bild

Betrifft: die Formel "passt" sich an ...
von: der neopa C
Geschrieben am: 24.07.2015 08:18:41
Hallo reidi,
... und zwar wenn nur zwei "ja" je Person vorhanden sind, weist sie auch nur 2 aus.
Wenn mehr als drei "ja" vorhanden sind, weist sie im Ergebnis soviel aus wie vorhanden sind, wenn die Formel weit genug nach rechts kopiert wurde. Wenn jedoch auch dann nur drei Ergebnisse gewünscht sind (also nur drei Formeln je Zeile vorhanden sind) werden nur die ersten 3 Überschriften mit einem "ja"-Eintrag gelistet.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: die Formel "passt" sich an ...
von: reidi
Geschrieben am: 24.07.2015 09:32:38
Hallo Werner,
vielen Dank, das ist ja klasse!
Jetzt habe ich nur noch das Problem, dass unter Runde 1 die Überschirft der Spalte A, also "Anrede", ausgegeben wird. Unter Runde 2 dann die Überschrift der Spalte B usw.
Kannst Du das noch lösen oder habe ich was falsch rüber kopiert?
Viele Grüße
reidi

Bild

Betrifft: oh Mann, bin Urlaubsreif ...
von: der neopa C
Geschrieben am: 24.07.2015 09:55:05
Hallo reidi,
... hier liegt noch ein Schreibfehler in meiner gestrigen Formel vor. Anstelle H6 sollte es richtig A6 lauten.
Also: =WENNFEHLER(INDEX($5:$5;AGGREGAT(15;6;SPALTE(1:1)/($A6:$M6="ja");SPALTE(A1)));"")
Wobei die Formel voraussetzt, dass es keinen Namen, Vornamen und Ort gibt der "ja" heißt.
Ansonsten sicherheitshalber:
=WENNFEHLER(INDEX($5:$5;AGGREGAT(15;6;(SPALTE(1:1)+7)/($H6:$M6="ja");SPALTE(A1)));"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: oh Mann, bin Urlaubsreif ...
von: reidi
Geschrieben am: 24.07.2015 10:48:58
Hallo Werner,
absolut Spitze!
Jetzt funktioniert es genau wie ich möchte. Vielen, vielen Dank.
Von meiner Seite darfst Du sofort in den Urlaub, ich hoffe für Dich es ist wirklich nicht mehr so lange hin bis es soweit ist.
Viele Grüße
reidi

Bild

Betrifft: Danke Dir, handelt sich nur noch um Stunden owT
von: der neopa C
Geschrieben am: 24.07.2015 11:01:34
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "mehrere Felder aus Zeile ausgeben"