beim runterziehen soll sich die Spalte verändern

Bild

Betrifft: beim runterziehen soll sich die Spalte verändern
von: Urban
Geschrieben am: 14.08.2015 10:48:06

Hallo liebe Forumsmitglieder, ich hoffe ihr könnt mir bei folgendem Problem helfen:
Ich habe eine Kreuztabelle. Daraus will ich eine andere Kreuztabelle erstellen. Hier ist mal ein Ausschnitt von meinen sehr großen Tabellen:
Kreuztabelle 1:
.. B C D E
1 1
2 1 1 1
3 1
4 1 1
Kreuztabelle 2: Hier würde ich gerne die Anzahl angeben, wie oft z. B. in Spalte B und Spalte C eine 1 vorkommt. Es soll nur gezählt werden, wenn sowohl in Spalte B und C eine 1 vorkommt.
.. B C D E
B
C
D
E
Dafür habe ich auch schon folgende Formel gefunden:
=SUMMENPRODUKT((Tabelle2!$B:$B<>0)*(Tabelle2!C:C<>0))
Diese Formel kann ich nun problemlos nach rechts verschieben, dann weiß ich, wie oft sich die jeweilige Spalte (C, D, E....) mit Spalte B überschneidet.
Nun suche ich nach einer Lösung, wie ich die Formel runterziehen kann, sodass nun alles mit Spalte C verglichen wird, z. B. Spalte C mit D vergleichen:
=SUMMENPRODUKT((Tabelle2!$C:$C<>0)*(Tabelle2!D:D<>0))
Für das Fett markierte suche ich nun nach einer Lösung zum runterziehen.
Kann mir jemand helfen?
Vielen Dank schonmal!
Liebe Grüße :)

Bild

Betrifft: statt z.B. =SUMME(Tabelle2!$C:$C)
von: WF
Geschrieben am: 14.08.2015 12:23:12
schreibst Du:
=SUMME(INDIREKT("Tabelle2!$"&ZEICHEN(ZEILE(X67))&":$"&ZEICHEN(ZEILE(X67))))
das kannst Du runterkopieren
Salut WF

Bild

Betrifft: AW: statt z.B. =SUMME(Tabelle2!$C:$C)
von: Urban
Geschrieben am: 14.08.2015 13:41:18
Hallo WF,
vielen Dank für die schnelle Antwort. Allerdings funktioniert die Formel nicht so richtig. Soweit ich das sehe, kann ich hier das folgende Kriterium nicht angeben (z. B. wenn ich die Beziehung von B und C untersuche): Es soll nur eine Summe gebildet werden, wenn sowohl in Spalte B als auch in Spalte C (in Kreuztabelle 1) eine Zahl steht.
Oder für was steht in Deiner Formel das Zeichen(Zeile(x67))? für was steht das Zeichen und die Zeile?
Sorry für das Nachfragen, aber ich verstehe es nicht ganz.
Freue mich auf Hilfe! Viele Grüße :)

Bild

Betrifft: Du wolltest Tabelle2!$C:$C ...
von: WF
Geschrieben am: 14.08.2015 14:49:22
runterkopieren (hast Du extra fett hervorgehoben) - der Rest hat mich also nicht interessiert.
ZEILE(X67) ist nichts anderes als 67.
nur runterkopiert wird daraus ZEILE(X68) das ist 68 usw.
Die nackte Zahl 67 runterkopiert bleibt immer 67.
ZEICHEN(67) ist der Buchstabe C; ZEICHEN(68) ergo D
WF

 Bild

Beiträge aus den Excel-Beispielen zum Thema "beim runterziehen soll sich die Spalte verändern"