Makro Mittelwert Standardabweichung

Bild

Betrifft: Makro Mittelwert Standardabweichung
von: Julia559
Geschrieben am: 24.08.2015 14:46:39

Hallo zusammen,
ich möchte per VBA einen Mittelwert und eine Standardabweichung ausrechnen. Die Zellen, die zu berücksichtigen sind liegen jeweils 7 Zeilen auseinander (in denen allerdings auch Werte stehen); d.h. die Mittelwertformel soll die Zellen A7;A14;A21;...;A70006 umfassen. Die Standardabweichung bezieht sich ebenfalls auf die selben Zellen. Anschließend soll der Mittelwert in der Zelle A700013 und die Standardabweichung in der Zelle A700020 angezeigt werden. Ich denke, dass mir eine For next Schleife (for i = 1 to 10000) weiterhelfen könnte. Allerdings weiß ich nicht, wie ich diese Schleife in die average- bzw. stdev-Formel integrieren kann. Sind dies überhaupt die richtigen Formeln, da ich einzelne Zellen und nicht einen ganzen Bereich berücksichtigen möchte?
Vielen Dank für eure Hilfe.
Julia

Bild

Betrifft: Makro Mittelwert Standardabweichung 2
von: Julia559
Geschrieben am: 24.08.2015 14:48:38
... und falls es eine Rolle spielen sollte, bei meinen einzelnen Werten (A7; A14;...) handelt es sich um Dezimalzahlen, die für einen Prozentsatz stehen.

Bild

Betrifft: AW: warum VBA? wenn doch eine Formel reicht ...
von: ... neopa C
Geschrieben am: 25.08.2015 08:23:50
Hallo Julia,
... da sich kein VBAler auf Deine Frage gemeldet hat, geh ich davon aus, dass diese auch so gedacht haben.
Folgende Matrixformel für die Mittelwertermittlung ist ausreichend:
{=MITTELWERT(WENN((REST(ZEILE(A1:A700020);7)=0)*ISTZAHL(A1:A700020);A1:A700020))}
Umrandende { } nicht mit eingeben, sondern Formel mit STRG+SHIFT+RETURN abschließen!
Und analog für die Standardabweichung :
{=STABW.N(WENN((REST(ZEILE(A1:A700020);7)=0)*ISTZAHL(A1:A700020);A1:A700020))}
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Makro Mittelwert Standardabweichung"