Wenn Frage

Bild

Betrifft: Wenn Frage
von: Christian
Geschrieben am: 03.09.2015 13:14:38

Hallo,
habe folgende Frage zu Wenn Funktion: Aus der Differenz der Max und Min Werte, soll über Wenn-Funktion ein Prozentwert ausgegeben werden. Es funktionert bis auf D4. Weiss jemand voran das liegen kann?
https://www.herber.de/bbs/user/99996.xlsx
Danke, Christian

Bild

Betrifft: AW: Wenn Frage
von: Rudi Maintaire
Geschrieben am: 03.09.2015 13:23:35
Hallo,
systembedingte Rundungsfehler!
in C4 steht 0,0300000000000011
Also selbst runden.
Das letzte Wenn() ist überflüssig.
=WENN(RUNDEN(A2-B2;6)<=0,03;20;WENN(RUNDEN(A2-B2;6)<=0,1;15;10))
Gruß
Rudi

Bild

Betrifft: AW: Wenn Frage
von: SF
Geschrieben am: 03.09.2015 13:24:39
Hola,
Gleitkommaproblematik. Runde in der Formel deine Ergebnisse vorher auf 2 Stellen.

=WENN(runden(A2-B2;2)<=0,03;20;WENN(runden(A2-B2;2)<=0,1;15;WENN(runden(A2-B2;2)>0,1;10)))
Gruß,
steve1da

Bild

Betrifft: AW: Wenn Frage
von: Christian
Geschrieben am: 03.09.2015 13:30:11
Supi, Problem gelöst.
Danke, Christian

 Bild

Beiträge aus den Excel-Beispielen zum Thema "zählen wenn"