Per Makro ein Klick auf Zelle mit Link ausführen

Bild

Betrifft: Per Makro ein Klick auf Zelle mit Link ausführen
von: Ingo Siemon
Geschrieben am: 08.09.2015 07:30:50

Hallo
Ich habe eine Excel-Tabelle.
In Spalte A befinden sich Vornamen.
In Spalte B befinden sich Nachnamen.
In Spalte E befinden sich E-Mail-Adressen.
In Spalte L befinden sich mailto-Links zu den E-Mail-Adressen aus Spalte E.
Inklusive der Namen aus den Spalten A und B.
Die Formel für Spalte L lautet:
=WENN(K2="";"";HYPERLINK("mailto:"&A2&" " &B2&" <"&K2&">";"E-Mail"))
Der daraus resultierende Link schaut dann so aus:
Vorname Nachname
Nun möchte ich gerne ein Makro erstellen.
Das Makro soll bei Ausführung den Link in Spalte L anklicken.
Und zwar immer in der gerade aktiven Zeile.
Ist das machbar?
Da ich leider nur VBA-Anfänger bin, würde ich mich freuen, wenn Ihr mir da helfen könntet.
Gruß
Ingo

Bild

Betrifft: AW: Per Makro ein Klick auf Zelle mit Link ausführen
von: Beverly
Geschrieben am: 08.09.2015 14:10:20
Hi Ingo,
versuche es mal so:

Sub HyperlinkAusfuehren()
    ActiveWorkbook.FollowHyperlink Cells(ActiveCell.Row, 12).Hyperlinks(1).Address
End Sub



Bild

Betrifft: AW: Per Makro ein Klick auf Zelle mit Link ausführen
von: Ingo Siemon
Geschrieben am: 08.09.2015 14:19:33
Hallo Karin
Danke für Deine Hilfe.
Ich habe das soeben probiert.
Beim Ausführen des Makros bekomme ich die Fehlermeldung:
"Laufzeitfehler '9': Index außerhalb des gültigen Bereichs"
Woran kann das denn liegen?
Gruß

Bild

Betrifft: Per Makro ein Klick auf Zelle mit Link ausführen
von: Rudi Maintaire
Geschrieben am: 08.09.2015 17:10:44
Hallo,
das kannst du nicht aus der Formel ableiten.

Sub aaa()
  Dim r As Long
  r = ActiveCell.Row
  ActiveWorkbook.FollowHyperlink "mailto:" & Cells(r, 1) & " " & Cells(r, 2) & " <" & Cells(r,  _
11) & ">"
End Sub

Gruß
Rudi

Bild

Betrifft: Ich habe es hinbekommen. Danke für Eure Hilfe
von: Ingo Siemon
Geschrieben am: 09.09.2015 00:03:43
Ich habe es hinbekommen.
Danke für Eure Hilfe

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Per Makro ein Klick auf Zelle mit Link ausführen"