Wochenarbeitszeiterfassung mit Reisezeiten

Bild

Betrifft: Wochenarbeitszeiterfassung mit Reisezeiten
von: Astrid Rudat
Geschrieben am: 12.09.2015 11:13:57

Hallo Forum,
ich verzweifele so langsam. Die Situation ist Folgende. Ich soll für unsere Servicetechniker, die sowohl im Haus arbeiten als auch auf Reisen sind, ein Excelformular für die Arbeitszeiterfassung erstellen.
Nun zu meinem Beispiel:
1. Tag normale Arbeit im Haus
2. Tag Tagesdienstreise
3.+4. Tag mehrtägige Dienstreise
Datum Abreise AZ-Beginn AZ-Ende Ankunft Pause Summe
17.08. 07:00 18:30 00:30 11:00
18.08. 06:00 08:00 19:00 21:15 01:00 14:15
19.08. 06:00 09:30 18:00 00:30 11:30
20.08. 08:30 17:00 19:00 00:30 10:00
Gesamt: 46:45
Gibt es für diese verschiedenen Summenformeln eine "Gesamtformel" für die Summenzelle?
Vielen Dank schon Mal im Voraus für schnelle Hilfe.

Bild

Betrifft: AW: Wochenarbeitszeiterfassung mit Reisezeiten
von: Sepp
Geschrieben am: 12.09.2015 13:15:10
Hallo Astrid,
Tabelle1

 ABCDEFG
1DatumAbreiseAZ-BeginnAZ-EndeAnkunftPauseSumme
217.08.2015 07:0018:30 00:3011:00
318.08.201506:0008:0019:0021:1501:0014:15
419.08.201506:0009:3018:00 00:3011:30
520.08.201508:3017:0019:00 00:3010:00
6       
7       
8Gesamt:46:45     

Formeln der Tabelle
ZelleFormel
G2=MAX(D2:E2)-MIN(B2:C2)-F2


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: AW: Wochenarbeitszeiterfassung mit Reisezeiten
von: Astrid Rudat
Geschrieben am: 12.09.2015 13:53:31
Danke Sepp für die schnelle Antwort.

Bild

Betrifft: AW: Wochenarbeitszeiterfassung mit Reisezeiten
von: Werner
Geschrieben am: 13.09.2015 14:58:58
Hallo Astrid,
hier meine Formel. Die wenn(und Abfrage sorgt dafür, dass auch dann nur die reine Arbeitszeit berechnet wird, falls versehentlich zusätzlich eine Abreisezeit oder Ankunftszeit erfasst wurde. Nur wenn eine Abreisezeit und eine Ankunftszeit erfasst wurde fließen diese Zeiten in die Berechnung ein.
Zudem passt bei der Formel die Berechnung auch dann, wenn die Zeiten für Arbeitsende oder Ankunft nach Mitternacht liegen sollten.
=WENN(UND($B2<>"";$E2<>"");REST($E2-$B2;1)-$F2;REST($D2-$C2;1)-$F2)
Gruß Werner

Bild

Betrifft: AW: Wochenarbeitszeiterfassung mit Reisezeiten
von: Werner
Geschrieben am: 13.09.2015 20:03:39
Hallo Astrid,
meine Formel vom letzten Beitrag war natürlich Quatsch. Du brauchst ja die Auswertung auch wenn in Spalte B eine Zeit erfasst ist und in E nicht, genauso wenn in E eine Zeit erfasst ist und in B nicht -bei mehrtägigen Aufenthalt-.
Ich habe es dann so gelöst:
=WENN(UND($B2<>"";$E2="");REST($D2-$B2;1)-$F2;WENN(UND($B2="";$E2<>"");REST($E2-$C2;1) -$F2;WENN(UND($B2<>"";$E2<>"");REST($E2-$B2;1)-$F2;REST($D2-$C2;1)-$F2)))
So ist das Ergebnis auch dann korrekt wenn das Arbeitsende bzw. die Ankunftszeit nach Mitternacht sein sollte.
Gruß Werner

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Von mehreren Emailkontos eines ansprechen"