Excel - Toleranz prüfen

Bild

Betrifft: Excel - Toleranz prüfen
von: svenja
Geschrieben am: 16.10.2015 15:24:01

Liebes Forum,
in der beigefügten Datei
https://www.herber.de/bbs/user/100833.xls
habe ich schon Formel in der Spalte M "Decision" geschrieben, um zu prüfen, ob alle Messwerte von Spalten E bis J (Maß 1 -4) jeglicher Zeile zwischen der jeweiligen Toleranz liegen.
Es muss folgende Anforderungen erfüllt werden:
1. solange keine Messwerte ausgefüllt werden, bleibt die Zelle "Decision" leer,
2. sobald ein Messwert eingetragen wurde, beginnt die Prüfung:
2a)wenn die Messwerte in der Toleranz liegen, gibt "OK" zurück;
2b)solange ein Messwert, welcher außerhalb der Toleranz liegt, auftaucht, gibt dann "NIO" zurück.
Dabei ist mein Problem nun:
wenn ich nicht alle vier Messwerte (z.B. nur einen Messwert) eintrage, obwohl dieser in der Toleranz liegt, zeigt es schon "NIO"...
Kann jemand darum helfen?
Vielen Dank schon mal im Voraus!!
Grüße
Svenja

Bild

Betrifft: AW: Excel - Toleranz prüfen
von: Spenski
Geschrieben am: 16.10.2015 15:42:25
hi probier die Formel mal
M20=WENN(ANZAHL(E20:L20)=0;"";WENN(ODER(UND(E20<>0;E20<=C20;E20>=D20);UND(G20<>0;G20<=C20;G20>=D20);UND(H20<>0;H20<=C20;H20>=D20);UND(J20<>0;J20<=C20;J20>=D20);UND(K20<>0;K20<=C20;K20>=D20);UND(L20<>0;L20<=C20;L20>=D20));"OK";"NIO"))
mfg
Christian

Bild

Betrifft: AW: Excel - Toleranz prüfen
von: svenja
Geschrieben am: 16.10.2015 15:54:31
Hi Christian,
es funktioniert mit deiner Formel leider immer noch nicht ganz richtig. Also es ist nun so:
wenn ich einen falschen Messwert eintrage, zeigt es ja "NIO", aber solange ich einen richtigen Messwert eingetragen habe, obwohl der Falsche noch drin ist, zeigt es schon wieder "OK"...
MfG
Svenja

Bild

Betrifft: AW: Excel - Toleranz prüfen
von: Spenski
Geschrieben am: 16.10.2015 16:02:34
ja stimmt hast recht...kleinen Moment :D

Bild

Betrifft: AW: Excel - Toleranz prüfen
von: svenja
Geschrieben am: 16.10.2015 16:06:38
Oki danki. Vielleicht ist es wegen der Formatierung (permanent leere Zelle von Spalten F und I), kann man nicht einfach "E:J" prüfen?

Bild

Betrifft: AW: Excel - Toleranz prüfen
von: Spenski
Geschrieben am: 16.10.2015 16:41:23
so jetzt aber hat bissl gedauert :D
M20=WENN(ANZAHL(E20:J20)=0;"";(WENN(ANZAHL(E20:J20)=ZÄHLENWENNS(E20:J20;">"&0;E20:J20;"<="&C20;E20:J20;">="&D20);"OK";"NIO")))
hoffe das passt :D
gruss
christian

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel - Toleranz prüfen"