Summenprodukt ersetzen

Bild

Betrifft: Summenprodukt ersetzen
von: Armin
Geschrieben am: 20.10.2015 10:50:53

Hallo zusammen,
ich habe ein kleines Problem.
Ich werte in einer Tabelle über eine Summenprodukt-Formel, mit Vergleich verschachtelt,aus welcher Kunde wie oft über eine gewisse Gewichtsgrenze kommt.
Problem ist, das einige Buchungen aus diversen Gründen öfter auftauchen ( siehe Beispiel )
Diese Aufträge dürfen aber nur einmal gezählt werden.
Da ich aber über 300 Kunden durchsuche und das auch noch nach 15 verschiedenen Gewichtsgrenzen sind es unzählige Formeln und ich muss auf die Auswertung der Tabelle ca. 20 Minuten warten.
Jetzt würde ich das gerne vereinfach, aber habe keine Ahnung wie, egal ob per VBA oder eine bessere Formel als Summenprodukt.
Kann mir bitte hier jemand helfen?
https://www.herber.de/bbs/user/100896.xlsx
Gruß Armin

Bild

Betrifft: AW: ich kann aber..
von: Bernd
Geschrieben am: 20.10.2015 11:01:39
keine Summenprodukt oder andere Formeln Deiner Beispielmappe entnehmen.
lg Bernd

Bild

Betrifft: AW: Summenprodukt ersetzen
von: hary
Geschrieben am: 20.10.2015 11:02:24
Moin
Hast du dir schon mal Pivot angesehen? Evtl. braucht es noch eine Hilfsspalte.
Gruss hary

Bild

Betrifft: AW: Summenprodukt ersetzen
von: Armin
Geschrieben am: 20.10.2015 11:37:41
Stimmt Dir Formel ist aktuell nicht mit drinnen.
hier ein Beispiel:
=SUMMENPRODUKT((Buchungsliste!$Z$1:$Z$3570=$A86) *(VERGLEICH(Buchungsliste!$Z$1:$Z$3570&Buchungsliste!$D$1:$D$3570; Buchungsliste!$Z$1:$Z$3570&Buchungsliste!$D$1:$D$3570;)=ZEILE(Buchungsliste!$Z$1:$Z$3570)) *(Buchungsliste!$M$1:$M$3570>=44000)*(Buchungsliste!$M$1:$M$3570<45000))
Passt nicht ganz zur Beispiel-Datei, da es aus der Orginal ist.
ÜberPivot habe ich auch schon nach gedacht, aber bin auch hier noch nicht auf einen grünen Zweig gekommen.
Gruß Armin

Bild

Betrifft: auf Dein Beispiel bezogen: mit Hilfsspalte
von: WF
Geschrieben am: 20.10.2015 11:52:40
Hi,
in K2 (Hilfsspalte) schreibst Du:
=WENN(E2>40000;D2&A2;0)
runterkopieren
in i4:
=SUMMENPRODUKT((LINKS(K$2:K$99;LÄNGE(H4))=H4)/ZÄHLENWENN(K$2:K$99;K$2:K$99&""))*(H4<>"")
runterkopieren
WF

Bild

Betrifft: AW: auf Dein Beispiel bezogen: mit Hilfsspalte
von: Armin
Geschrieben am: 20.10.2015 13:25:47
Hallo WF,
dann habe ich aber wieder zich summenprodukt Formeln.
Diese benötigen einfach sehr lange bis diese Berechnet sind.
Das würde ich gerne umgehen.
Gruß Armin

Bild

Betrifft: AW: PIVOTauswertung plus ZÄHLENWENNS() ...
von: ... neopa C
Geschrieben am: 20.10.2015 14:28:49
Hallo Armin,
... es gibt wohl kaum schnelleres, als eine PIVOTauswertung. Die für Dein Beispiel notwendige habe ich in F11:H17 mit ein paar Mausklicks aufgestellt und auch die Formelauswertung in I4:I5 ist durch ZÄHLENWENNS() sehr schnell.
Ergänzender Hinweis: Die Liste aller Kundennamen für Deine Originaldatei in Spalte H kannst Du auch sehr schnell mit einer zusätzlichen PIVOTauswertung aufstellen.
Durch die die Definition des Vergleichswertes in I2 sowie die Zuweisung eines Autofilter in I3 bist Du zusätzlich variabel.

 ABCDEFGHI
1Aufragsnr.IdentifikationDatumUnternehmerLadung, Brutto kg    
2170771503.08.2015Kunde 143700  Suche alles über :40000
3170781903.08.2015Kunde 225680   Anzahl
4170793103.08.2015Kunde 335700  Kunde 11
5170801003.08.2015Kunde 442860  Kunde 42
6170801003.08.2015Kunde 442860    
7170801003.08.2015Kunde 442860    
8170813103.08.2015Kunde 336700    
9170851003.08.2015Kunde 447300    
10         
11     Aufragsnr.UnternehmerLadung, Brutto kg 
12     17077Kunde 143700 
13     17078Kunde 225680 
14     17079Kunde 335700 
15     17080Kunde 442860 
16     17081Kunde 336700 
17     17085Kunde 447300 
18         

Formeln der Tabelle
ZelleFormel
I4=ZÄHLENWENNS(G:G;H4;H:H;">"&I$2)
I5=ZÄHLENWENNS(G:G;H5;H:H;">"&I$2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: PIVOTauswertung plus ZÄHLENWENNS() ...
von: Armin
Geschrieben am: 20.10.2015 17:06:02
Super so funktioniert es einwandfrei.
Vielen Vielen Dank.
Gruß Armin

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt ersetzen"