Pivot Herausforderung

Bild

Betrifft: Pivot Herausforderung
von: Andrea
Geschrieben am: 23.10.2015 08:22:33

Hallo an alle Pivot Spezialisten,
ich habe eine Monsterdatei, welche über Pivot in Excel zu aussagekräftigen Info´s führt. Nun habe ich aber einige Bestandteile die nicht angezeigt bekomme, da die Werte nicht einfach als Summe, Anzahl oder Mittelwert... angezeigt werden können. Diese müssten in der Pivot Tabelle mit einer "wenn - dann - Formel" hinterlegt werden. >Wenn Mitarbeiter 1 einen Zuschlag bekommt, dann zeige den Betrag unter der Spalte Zuschlag< ???? Habt Ihr dazu eine Lösung ??????
ROHDATEN
persnr --------CODIERUNG------ betrag
Mitarbeiter 1 Zuschlag------- 30,72
Mitarbeiter 1 Urlaub--------- 11,58
Mitarbeiter 2 Zuschlag------- 76,57
Mitarbeiter 2 Krankheit------ 31,6
Mitarbeiter 3 Urlaub--------- 1,27
gewünschtes Ergebnis:
-------------Zuschlag Urlaub Krankheit
Mitarbeiter 1 30,72 11,58 ---------
Mitarbeiter 2 76,57 ----- 31,6
Mitarbeiter 3 ----- 1,27 ---------

Bild

Betrifft: AW: ich erkenne momentan Dein Problem nicht ...
von: ... neopa C
Geschrieben am: 23.10.2015 08:35:06
Hallo Andrea,
... Du musst doch nur diefelder "Codierung" in die Spaltenbeschriftung, "PersonNr" in die Zeilenbeschriftung und "Betrag" in Werte ziehen. Oder was meinst Du genau?
Eine Datei könnte dann hilfreich sein.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ich erkenne momentan Dein Problem nicht ...
von: Andrea
Geschrieben am: 23.10.2015 14:11:07
Hallo Werner,
vielen lieben Dank für die Rückfrage!
Kann die Lösung denn so einfach sein???? Aber ich habe die Felder aus der Spalte Codierung ja nicht in meiner Feldliste /-; oder wie bekomme ich die da rein????
https://www.herber.de/bbs/user/100994.xlsx
ich habe einen Ausschnitt aus meiner Monsterdatei hochgeladen.
Mein Kopf raucht...

Bild

Betrifft: AW: manches ist halt einfach ...
von: ... neopa C
Geschrieben am: 23.10.2015 16:47:15
Hallo Andrea,
... allerdings solltest Du in Deinen Rohdaten noch etwas korrigieren. Deine "persnr" sind teilweise Textwerte und teilweise Zahlenwerte. Durch eine Multiplikation mit 1 erhältst Du einheitlich Zahlenwerte. Deine Formel in C2 ergibt teilweise ein #NV. Vorschlag zur Änderung:
=WENNFEHLER(SVERWEIS(B2;bsp_codierung!$A$2:$B$223;2;FALSCH);"Sonstiges")
Und dann solltest Du das Feld "CODIERUNG" in der PIVOTauswertung in die Spaltenbeschriftung ziehen und nicht "Werte". Dann sollte es korrekt sein.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: manches ist halt einfach ...
von: Andrea
Geschrieben am: 24.10.2015 10:48:25
Oh mein Gott (ja ich meine Dich (-;)
es funktioniert !!!
Im Nachgang weiß ich nicht, warum ich schon Stunden darüber gesessen bin... aber Pivot ist nicht meine Heimat. VIELEN DANK das war mit wirklich eine große Hilfe
Ich hoffe ich darf Dich nochmals fragen, wenn ich nicht weiter komme!

Bild

Betrifft: AW: gerne doch owT
von: ... neopa C
Geschrieben am: 25.10.2015 13:14:58
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "VBA SummeWenn 2 Kriterien und mehrere Ergebnisse"