Summewenn() auf Abwegen...

Bild

Betrifft: Summewenn() auf Abwegen...
von: Clavis
Geschrieben am: 26.10.2015 07:49:23

Hallo zusammen!
Leider bin ich bei einem Problem mit meinem begrenzten Excel-Latein am Ende.
Ich habe zwei Zahlenreihen, bspw.
Zeile A: 0 0 10 40 30 0
Zeile B: 20 10 20 40 10 0
diese sollen spaltenweise jeweils miteinander verglichen werden; wenn in Zeile A ein Wert größer Null steht; dann sollen die jeweils kleineren Werte addiert und in einer Zelle ausgegeben werden (im Beispiel hier also 10+40+10 der 3-5. Spalte). Spalte 1 und 2 sollen ignoriert werden, da der Wert in Zeile A nicht größer Null ist.
Ich glaube, die Lösung ist ganz naheliegend, aber ich komme einfach nicht darauf! Vielen Dank für Eure Mühen und Lösungsvorschläge!

Bild

Betrifft: AW: schon wieder??? owT
von: ... neopa C
Geschrieben am: 26.10.2015 07:57:21
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Summewenn() auf Abwegen...
von: fcs
Geschrieben am: 26.10.2015 08:13:03
Hallo Clavis,
so trivial ist eine Lösung hier nun auch nicht. Hier zwei Lösungs-Formeln, wobei ich die SUMMENPRODUKT-Formel bevorzuge, auch wenn sie auf den 1. Blick etwas verwirrend aussieht.
Tabelle2

 ABCDEFGH
1001040300  
2201020401006060

Formeln der Tabelle
ZelleFormel
G2=SUMMENPRODUKT((A1:F1>0)*(((A1:F1>=A2:F2)*A2:F2))+((A1:F1<A2:F2)*A1:F1))
H2{=SUMME(WENN(A1:F1>0;WENN(A1:F1>=A2:F2;A2:F2;A1:F1); 0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß
Franz

Bild

Betrifft: AW: ich nehme mittlerweile an ...
von: ... neopa C
Geschrieben am: 26.10.2015 08:19:44
Hallo Franz,
... dass Clavis ein Problem mit seinem Browser hat, denn es ist mittlerweile seine dritte identische Anfrage. Erstaunlich ist nur, dass sie über Tage versetzt ist. Dazu sieh mal hier: https://www.herber.de/forum/messages/1454278.html
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ich nehme mittlerweile an ...
von: Jan
Geschrieben am: 26.10.2015 10:32:22
Hallo,
nur kurz zu der vermeintlichen Browserproblematik (Habe mit dem Thema sonst hier nix zu tun):
Bei mir muss ich (Internet Explorer) die Forenseite mit Strg + F5 neu laden, damit neue Beiträge angezeigt werden. Bei "normalem" Neuladen der Seite wird immer nur der Stand beim (erstmaligen) öffnen der Seite in der Forenübersicht angezeigt. Vielleicht bin ich da nicht der einzige.
Gruß,
Jan

Bild

Betrifft: Das haben wir schon so oft diskutiert, ...
von: Luc:-?
Geschrieben am: 26.10.2015 20:39:18
…Leute…
Ja, Jan,
das wird wohl dadurch passieren! Sollte sich aber auch bei Klick auf FORUMSLISTE oder NeuAufruf (leider nicht immer in Gänze!) aktualisieren.
Gruß, Luc :-?

Bild

Betrifft: AW: Das haben wir schon so oft diskutiert, ...
von: Jan
Geschrieben am: 27.10.2015 14:13:15
Entschuldige,
ich lese nur sporadisch mit, habe deswegen bisher noch nicht mitbekommen, dass das Thema schon oft diskutiert wurde. Habe es nur angesprochen, weil ich eben nicht von Browserproblemen ausging.
Wenn es bekannt ist, umso besser, danke auch nochmal für deinen Hinweis.
Schönen Tag!
Jan

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summewenn() auf Abwegen..."